Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

iPhone 4. iOS 5.0.1. Jailbroken (Un-tethered).

The phone was bought by a friend of mine. He uninstalled some tweaks from cydia (i believe themes ringtones etc). One uninstall asked for a respring and after the respring, the cydia icon was gone. Tried re-jailbreaking and checking "Install Cydia" only with redsnow, no help. Secondly, can a jailbroken phone be reset? I mean "Erase All Content and Settings"? I've tried doing that as well but the phone goes into a boot loop mode.

Any suggestions would be much appreciated.

asked 04 Apr '12, 15:51

ayzeee's gravatar image

ayzeee
2086312


Once you have clicked the Erase All Content and Settings there is no turning back as the phone can not be reset and it will not boot. The reason being that during the jailbreak the files were reorganised and during the reset it can no longer find them and pair up properly. There is however still hope.

  1. verify you have your SHSH blobs for 5.0.1 and save them locally, you can do this with the Fetch feature in reds0w.
  2. build a custom no bb 5.0.1 ipsw in redsn0w.
  3. stitch your 5.0.1 SHSH blobs to your custom no bb ipsw.
  4. enter pwn'd dfu using redsn0w.
  5. shift (option mac) restore in iTunes and select your custom stitched no bb ipsw.
  6. Activate with original carrier SIM card.
  7. jailbreak as needed using redsn0w.

You can grab what you need from here: JailbreakQA Links

Please post in comments if you have further questions regarding the procedure for your situation. For most accurate advice, please access the Settings App on your device and provide from General>About the Model, Version, Carrier, Serial (first five digits), and Modem Firmware.

Your info will look something like this:

Model: MC603B Carrier: O2 UK Version: 4.3.3 Serial: 88035xxxxxx Modem Firmware: 4.10.01

Hope this helps, best wishes and good luck!

link

answered 04 Apr '12, 15:58

JuergenWest's gravatar image

JuergenWest ♦
11.0k352344

haha oops, i read as a 4S. i deleted my own ignorant answer above ;)

(04 Apr '12, 16:00) theiphoneguy ♦ theiphoneguy's gravatar image

I'm going to try out Jurgen's suggestion and will get back with the results.

(04 Apr '12, 16:04) ayzeee ayzeee's gravatar image

It worked.

Saved my blobs using tinyumbrella as redsn0w was not detecting the blobs.

Had to select 'Get shsh from Cydia' in tinyumbrella to get blobs for 5.0.1 - otherwise it was only saving for 5.1

Stitched and restored and it worked.

Thanks!

(04 Apr '12, 16:47) ayzeee ayzeee's gravatar image

awesome.. glad that worked!

(04 Apr '12, 17:01) JuergenWest ♦ JuergenWest's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,722

Asked: 04 Apr '12, 15:51

Seen: 3,376 times

Last updated: 04 Apr '12, 17:01

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.