Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

three days ago, i went to cydia to uninstall a tweak and when it rebooted, cydia was gone. i don't know how to get it back and i do not have ifile on my iphone. since there is way to restore to 5.0.1 i don't know what to do. I have tried to rejailbreak it with absinthe but it says your device is already jail broken.. i have ifun box downloaded if that could help get cydia back on my iphone. please and thanks to whoever can help me.

asked 27 Mar '12, 14:42

BallerE4Life's gravatar image

BallerE4Life
118410

Try ifun box, if not download the latest redsn0w, when this happened to me, i just went to jailbreak on redsn0w, it just re-jailbroke my idevice. I hope this helps!!! :)

(28 Mar '12, 03:09) Thequestioner Thequestioner's gravatar image

@Thequestioner redsn0w does not work on 4s.

(28 Mar '12, 03:10) justinred ♦ justinred's gravatar image

@justinred well then use ifunbox, sorry if i misunderstood, but i think that you can also use ifaith???

(28 Mar '12, 03:13) Thequestioner Thequestioner's gravatar image

No he cannot use iFaith on a 4s.

(28 Mar '12, 03:19) justinred ♦ justinred's gravatar image

@justinred ifunbox -_-

(28 Mar '12, 03:31) Thequestioner Thequestioner's gravatar image

@thequstioner what would i have to do in ifunbox to get cydia back.

(28 Mar '12, 06:52) BallerE4Life BallerE4Life's gravatar image

Im sure this question was asked a few days ago, search for it. There is a way to fix this iirc.

link

answered 28 Mar '12, 03:17

FL23's gravatar image

FL23
2615

Here's a similar question but it just says to go on IRC, and the people who were available to help at that time probably aren't still on IRC. I'm not sure what solution they found there, so we can just hope that they will add comments here eventually.

(28 Mar '12, 07:21) britta ♦♦ britta's gravatar image

Do you remember which tweak you uninstalled? This behavior is generally a symptom of having uninstalled the Corona 5.0.1 Untether package from Cydia - it essentially means that you've uninstalled most of the jailbreak from your device. Since your device is in a weird in-between state where it has jailbreak-related files on the device but isn't booted jailbroken, it's stuck, and I don't know of a way to fix it. It sounds like people were discussing options on IRC though, so maybe @theiphoneguy will come by later and try to explain what they came up with there.

link

answered 28 Mar '12, 07:26

britta's gravatar image

britta ♦♦
23.9k105133

edited 28 Mar '12, 07:26

1

I had watched ih8sn0w do a fix, the fix doesn; apply to every 4s, but its essentially replacing launchd.conf from the cinject files. (its in cinject/payloads/data/ios/(build here, ie 9a405, 9a406), extract the corono.tgz and thats where the launchd conf is rebooting, then reinstalling mobile substrate in cydia. Does not apply to all 4s's with cydia issues

(28 Mar '12, 09:41) theiphoneguy ♦ theiphoneguy's gravatar image

@iphoneguy... can you explain a little more in detail on how to do this lol.

(28 Mar '12, 15:31) BallerE4Life BallerE4Life's gravatar image

Cant really explain more in depth what i saw done once, remotely at that

(28 Mar '12, 15:48) theiphoneguy ♦ theiphoneguy's gravatar image

This Probem is already fixed by ih8sn0w ^^ He fixed it with TeamViewer and iFunBox in 3 hours !!! :D

But thx anyway ;)

link

answered 28 Mar '12, 08:53

FuRCoM's gravatar image

FuRCoM
26224

Would you be able to point me in the directions how it was fixed... I have the same problem and there is no solution for me... Does ih8sn0w have some tutorials for similar problems... I used google so many times in the last couple weeks but no tutorial or any actual solution for this problem... Thanks....

(03 May '12, 00:08) digital4 digital4's gravatar image

This tutorial will only work on a Mac. Download redsn0w, click "Show Package Contents" and go to /Contents/MacOS/Cydia.tar.gz and extract the file. In the new folder the entire cydia files will be shown in the location they're supposed to be on iOS (for example, the folder /applications in Cydia.tar.gz represents all the files that are supposed to be in /applications on the phone), then copy the missing files to your phone with I-funnox. Cydia is supposed to be there after (don't forget any file or folder!)

link

answered 28 Mar '12, 09:24

itaiyz97's gravatar image

itaiyz97
5118224

I tried this for my 4s and cydia that can not start... it did not fix the problem... afted I copied all of the files and restarted the iphone nothing was changed... i was not able to start cydia...

(02 May '12, 21:44) digital4 digital4's gravatar image

Rejailbreak with redsn0w- it may work.

link

answered 03 May '12, 00:02

itaiyz97's gravatar image

itaiyz97
5118224

I already tried so many times but it does not work... :(

(03 May '12, 00:05) digital4 digital4's gravatar image

Try restoring to iOS 5.1.1 and download Absinthe 2.0 and jailbreak your device.

link

answered 26 Jun '12, 17:56

Biddlebaddleboo's gravatar image

Biddlebaddleboo
111

-2

@BallerE4Life. You can try going to jailbreakme.com from your Device's Safari app and try to Install Cydia. Also, try searching for "Cydia" in the spotlight. If still no luck then you gotta restore and then re-jailbreak. I know this isn't using ifunbox but if you want Cydia back here's the way to do it :) hope this helped !!!

link

answered 28 Mar '12, 07:00

Thequestioner's gravatar image

Thequestioner
615321

That won't work so well. JailbreakMe is not compatible with iOS 5.0.1 on any device, so it won't work to jailbreak the device. And if an iPhone 4S is restored, it will be updated to iOS 5.1, which does not have a jailbreak right now (and nobody knows when one will be released).

(28 Mar '12, 07:15) britta ♦♦ britta's gravatar image

Qnd looking for cydia in spotlight will work in searching cydia- not fixing cydia

(03 May '12, 00:08) itaiyz97 itaiyz97's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7,182
×3,786
×1,343
×937
×450
×55

Asked: 27 Mar '12, 14:42

Seen: 16,310 times

Last updated: 26 Jun '12, 17:56

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.