Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

On running the latest redsnow I get the following error

Certain operations (like the A5 Jailbreak) are disabled due to incomplete iTunes library. Please be sure the latest iTunes is installed Couldn't load Mobiledevice.dll

Now it goes without saying that I do have the latest iTunes installed. My google-fu failed me to come to a solution, I am hoping you guys can help.

I have tried reinstalling iTunes and Apple Mobile Devices

asked 13 Mar '12, 09:56

elvista's gravatar image

elvista
41115

closed 09 Oct '13, 17:40

spockers's gravatar image

spockers ♦♦
59.3k328249

The question has been closed for being "11 answers, about 10 too many, don't need moar" by spockers, 09 Oct '13, 17:40


12next »

I had the same mobiledevice.dll not found error when starting up redsn0w. I found a fix that worked for me after much search. Copy C/Program Files/Common Files/Apple/Apple Application Support/SQLite3.dll to the same folder as redsn0w. Run redsn0w! Hope this helps anyone else who has this problem. Tried with redsn0w 0.9.10b6.

link

answered 25 Apr '12, 22:10

shieha's gravatar image

shieha
11713

edited 25 Apr '12, 22:12

1

Worked perfect! Thank you very much ;)

(22 Jun '12, 18:19) jonezz007 jonezz007's gravatar image

Try a different computer if possible. Another user found many reported solutions like reinstalling itunes etc didn't do the trick. They tried on another computer and it worked fine. That's not to say the specific issue can't be solved, but saves a lengthy process of trial and elimination.

link

answered 13 Mar '12, 10:45

iphpwn4's gravatar image

iphpwn4 ♦
12.9k99

I just tried plugging it into another computer, worked fine over there :|

Here are some other details that might help developers/other users:

I used redsn0w to jailbreak my iPod 4.3.5 from the same computer (Computer 1) before, with no big changes. redsn0w failed to notice when I did connect to pwned DFU mode. I also tried jailbreaking through sn0wbreeze on Computer 1. Although it patched the IPSW file alright, it failed to connect through the pwned DFU mode. In Computer 2, I just plugged it in, tried sn0wbreeze, and worked. Didn't try redsn0w.

Ultimately I think it all comes down to not being able to detect pwned DFU mode because of not finding MobileDevice.dll. I am not sure why though, since I don't really mess around the computer to misplace files like that.

(13 Mar '12, 11:22) elvista elvista's gravatar image

Which version of Windows are you using on Computer 1? I wonder if that makes a difference - maybe redsn0w isn't quite working on some particular version.

(13 Mar '12, 16:46) britta ♦♦ britta's gravatar image

Windows 7 on both.

(14 Mar '12, 03:26) elvista elvista's gravatar image

I had same problem running 0.9.10b6 (Couldn't load Mobiledevice.dll)

Actually I thoroughly removed itunes 10.6 and related components and re-installed older versions, ensure my AV whitelisted redsn0w and firewall off, I was running with UAC disabled, relevant mobile support services running and other applications detected the phone fine.. spent about 20 min messing about and the error seemed to remain. It worked perfectly on other machines with similar setups

In the end I just extracted DLL's from older iTunes version into same folder as the redsn0w .exe..hardly an elegant solution but it seemed to do the trick. I don't think we're able to post links here so either search some random blocks of text in google such as: 0j0veou5u03zcru or copy relevant files manually from the following directories C:\Program Files\Common Files\Apple into the same folder as redsn0w.exe

link

answered 16 Mar '12, 23:25

gecko's gravatar image

gecko
368349

I experience this problem, but the solution is to copy all files from C:programs filesappleapple application support then paste in the redsn0w directory and it will work

link

answered 05 Sep '12, 11:29

develop3's gravatar image

develop3
2612119

Not sure of the exact nature of the fix (I did many things at once), but copying all .dll files from C:Program FilesCommon FilesAppleApple Application Support and C:Program FilesCommon FilesAppleMobile Device Support to the folder in which RedSn0w is located worked.

I was using WinXP so many fixes elsewhere didn't work (they were for Vista/Win7+). This did! I'm back down to Modem Firmware 05.13.04 before adding Whited00r!

link

answered 19 Jun '13, 20:49

iPhpwn's gravatar image

iPhpwn
263

I tried to vote down iphpwn4's response because that is not answer. It is passing the buck. I am having the same issue and because I am stuck on island 1400 miles from the US, I am not able to just "try another computer."

Like elvista, I am using Windows 7, and also like elvista I tried to uninstall and re-install itunes. This is my first try at trying to jailbreak my ipad2 and needless to say it has not been a pleasant one.

link

answered 16 Mar '12, 21:58

Elbrin's gravatar image

Elbrin
63

mobiledevice.dll is a file on the computer installed by itunes. Anything can interefere with it. Have a virus? Your firewall overprotective? Not running as admin? Antivirus overprotective?

(16 Mar '12, 22:29) theiphoneguy ♦ theiphoneguy's gravatar image
1

I understand my answer is not a solution to the driver issue, but as @theiphoneguy has commented, this problem can be caused by many things. My answer was to help achieve the jailbreak. I apologise if you didn't find my input helpful.

(16 Mar '12, 22:42) iphpwn4 ♦ iphpwn4's gravatar image

I'm also very new; how did you manipulate the redsn0w directory?

link

answered 10 May '12, 02:58

benbbp's gravatar image

benbbp
111

Go to My Computer C:/Program files/common files/apple/Apple Application Support, copy ASL.dll and paste it to the Redsn0w folder. Run redsn0w and it should work

link

answered 16 Aug '12, 18:31

elion631's gravatar image

elion631
112

edited 16 Aug '12, 18:34

Considering that redsn0w 0.9.10b6 is about 10 revisions old, and this thread is about 5 months old, the issue is probably solved.

(16 Aug '12, 19:54) spockers ♦♦ spockers's gravatar image

Hy, I installed new Itunes today, because redsnow said: "Be sure to have the newest version". But there wasn't even a C:/Program files/common files/apple/Apple Application Support folder.

But i just googled for the SQLite3.dll download, downloaded the ZIP, extracted inti redsnow 0.9.15b3 folder (for Iphone3GS 1.6.3 jailbreak) and redsnow now starts without error.

Thank you very much.

link

answered 11 Aug '13, 05:19

harrybear's gravatar image

harrybear
112

-1

Thanks for the replies. I was able to download iTunesMobileDevice.dll and put that in the redsn0w directory. The error upon openning redsn0w is now gone. I will try to use redsn0w tonight but I just found out that my iPad is an A-5 so my hopes are not high.

I am very new to the scene and I wish I had become more involved before I let iTUnes update my iOS to 5.1. Live and learn.

Thanks again.

link

answered 17 Mar '12, 20:07

Elbrin's gravatar image

Elbrin
63

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×233
×3

Asked: 13 Mar '12, 09:56

Seen: 42,835 times

Last updated: 09 Oct '13, 17:40

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.