Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I'm stuck on greenpoison initialized and I can't restore in iTunes because I get an error, I'm running 4.2.1 tethered.. any hints?

asked 03 Feb '11, 22:43

shamash's gravatar image

shamash
282119

closed 04 Feb '11, 17:02

conradev's gravatar image

conradev
63848

1

what error are you getting in itunes? if it's 1013, you just need to block the gs.apple line in the host file

(03 Feb '11, 23:57) JiXeR JiXeR's gravatar image
1

I don't remember the exact error in iTunes, and my phone is stuck on "greenpoison initialized" so I can't try the restore again right now, but I think it was something about the version?

I tried to sudo into the hosts to block the gs.apple line, and it wasn't listed there, only hosts from Adobe.

(04 Feb '11, 00:03) shamash shamash's gravatar image
3

if you don't have the line, then you should be fine, because it's just commenting it out anyway. as for the error, try it again and see what you come up with. also, you can reboot your phone if you're stuck on the 'initialized' line.

(04 Feb '11, 00:10) JiXeR JiXeR's gravatar image

The question has been closed for being "To protect the question from getting any more answers. (The issue at hand was resolved)" by conradev, 04 Feb '11, 17:02


1234next »

link

answered 04 Feb '11, 08:44

anananas's gravatar image

anananas
36427

edited 04 Feb '11, 11:10

2

anananas, I LOVE YOU

(06 Feb '11, 09:50) Pegasus_527 Pegasus_527's gravatar image

To clarify things (regarding this issue only):

  1. Running as root will not fix this, it is not a permissions issue. (it may coincide that running it as root was the one time it worked, however)
  2. Holding the home button longer to fix it is a myth
  3. The issue you experience when this happens is that the final kernelcache+iBSS are not being downloaded, patched, and then uploaded to the device, as they should be. Instead, greenpois0n sits there waiting on the iPhone, not receiving the needed files. It is unknown why greenpois0n on the computer doesn't send them.
  4. Retrying is the only known way to fix it - try going into DFU mode immediately after one attempt fails - so far this has worked for me.
link

answered 04 Feb '11, 01:48

conradev's gravatar image

conradev
63848

does this also apply to the iPad?

(04 Feb '11, 01:58) RMalayeri RMalayeri's gravatar image

Suggestion #4 finally did it for me. I went into DFU mode right after it failed and gp actually uploaded the kernelcache like it should :)

(04 Feb '11, 02:58) dcro2 dcro2's gravatar image

I believe the failure to download the kernalcache+iBSS may be a side effect of the servers being hammered.

So try, try, again, it eventually worked for me after experiencing this same issue.

(04 Feb '11, 03:27) gomanski gomanski's gravatar image

It actually downloads them from Apple's servers, so its not the server load.

(04 Feb '11, 06:33) conradev conradev's gravatar image
2

So I'm assuming every one by now is running around like chickens with their heads cut off, however I wanted to point out some things so you can all go to bed feeling better. About the "stuck at gp init" issue, it's completely random. It's a build problem. We'll release a fixed version soon. Be patient. -pod2g Basically it looks like they forgot to put in a GPIO Int to make it so the iBSS would run. People have been having success because the home key if spam fast enough on some devises or held down, can interupt the code to make it run the payload. Hopefully those worked for you.

(04 Feb '11, 07:02) Cassiel Cassiel's gravatar image

This one really Works, and just in case of colapse here is a mirror http://bit.ly/hxkrIv LongLife Chronic Dev Team

link

answered 04 Feb '11, 11:03

DjTarek's gravatar image

DjTarek
462

2

THIS WORKED! yay ily!

(05 Feb '11, 10:13) ihackmyi ihackmyi's gravatar image

Here is what worked for me: 1. Backup your phone 2. Restore and update to 4.2.1 3. Don't sync it yet 4. Open terminal (applications/utilities/terminal) type in 'sudo open ' (space after open), and then drag greenpois0n app onto the terminal window. 5. press enter and greenpois0n will open. run it. 6. Follow directions, continue to hold home button until you see a wall of text. You'll know when it happens. *Note: Whether Greenpoin0n says its complete on your computer or not is irrelevant. Just wait for a bit before deciding it failed.

link

answered 04 Feb '11, 00:20

cj022's gravatar image

cj022
91113

2

Sudo worked like a charm! Looks like I was having a permissions issue. You'll know that things are working if you have a firewall (like LittleSnitch) installed and it tells you that GP is looking to access the internet. After the app says complete, just LEAVE everything alone. The bar will go a few more times, and then the big wall o text will happen. It will be GLORIOUS.

(04 Feb '11, 03:03) graye graye's gravatar image

i restored my phone to factory then synced to get my files back then jailbroke again and it took 2 times.. i am stuck on the loader page not having cydia but if that happens just keep trying untill it shows up.. server probs i guess

link

answered 04 Feb '11, 00:06

Ch3fm1c's gravatar image

Ch3fm1c
901

OK, Greenpois0n DOES WORK! Restore your iPhone to 4.2.1 Using iTunes If you're having restore issues go to terminal, then type "sudo nano /etc/hosts" (without the quotes) make sure that lines with "gs.apple.com" are commented out with a "#" (no quotes) at the beginning of the line.

Next: Go to terminal and type "sudo open" (without quotes) and drag greenpois0n.app to the terminal hit enter and you should be asked for your password. Follow the directions in the app but DONT LET GO OF THE HOME BUTTON until you see the white flash on your iPhone screen.

FOR USERS WITH LITTLE SNITCH: Make sure that you allow greenpois0n.app access when the pop-up shows up. You may have to run the app again in order for it to work properly.

I hope this helps! - Spyt3

link

answered 04 Feb '11, 00:26

spyt3's gravatar image

spyt3
302

Here's what kept killing my attempts: One of the times I tried to run GreenPois0n, it crashed and I had to re-start. From that point on, I just kept getting stuck with about 5 lines of code and then "Greenpois0n initialized" on my screen. I tried the SUDO command and noticed something about an iBSS package. I noticed there was an iBSS file in my home folder and decided to delete it and try again. Huzzah! The next time I ran Greenpois0n from terminal using SUDO, there were far more lines of code, and everything went off without a hitch.

So, try deleting the iBSS.n90ap file out of your home directory, and try again.

link

answered 04 Feb '11, 00:30

drbarber's gravatar image

drbarber
451

Deleted iBSS.n90ap and emptied recycling bin, then ran with sudo, still stuck at initialized...

(04 Feb '11, 01:52) shamash shamash's gravatar image

Hi!

I had jailbroken 4.1, updated to stock 4.2.1 (I did not restore). Tried to run gp and for the first time it showed me the verbose mode with all this loading text but it got stock ("not at unable to mount" thing). I waited about 10 minutes and then I decided to restart the iPhone. Of course iPhone was not jailbroken.
So I tried to run gp again but this time it didnt even starts to jailbreak my iPhone. So I tried it few times, it crashed few times, ...
Then I kept holding home button and the verbose mode did show up again (finally) but got stuck on "unable to mount..." and "greenpois0n initialized".

What I did to make it work was:
a.) Deleted "iBSS.n90ap" file from my Macintosh HD.
b.) Restarted computer!, did not open any apps.
c.) I changed my USB port on Mac (I think it didn't matter but..)
d.) open up Terminal.app and wrote: sudo open /path/to/greenpois0n.app (I put it on my DESKTOP)
e.) Click on "Jailbreak", follow the procedure and KEEP holding the HOME button for whole time even when the greenpois0n initialized showed up, I still kept holding HOME button.
f.) Scrolling text appeared and iPhone restarts, took some time but now it's jailbroken!!

P.S: Also got Mac OS Developer Tools and Macports installed. Mac OS X 10.6.6, MacBook Air

Hope it helps some of you. s33m0n

link

answered 04 Feb '11, 04:12

s33m0n's gravatar image

s33m0n
152

edited 04 Feb '11, 04:16

Had the same stuck at "greenpois0n initialized" problem............tried it thrice..........worked perfectly the fourth time.

What I was doing wrong was not following the hold/release sequence accurately..........especially the last part.........release the home button immediately when the last instruction goes from bold to normal.

Just wanted to share....maybe you would wanna give it a try.

:)

link

answered 04 Feb '11, 05:10

fatehbajwa's gravatar image

fatehbajwa
163

Deleted "iBSS.n90ap" file from the user folder, worked for me.

Thanks Everyone for the Jailbreak. It was long awaited.

link

answered 04 Feb '11, 06:38

hammered24's gravatar image

hammered24
162

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,847

Asked: 03 Feb '11, 22:43

Seen: 32,690 times

Last updated: 06 Feb '11, 09:50

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.