Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

3
1

Can Some1 please help me I have deleted cydia and can't get it back I have tryed jailbreak me and the install button it not there in install please help thanx

asked 17 Feb '12, 17:55

Scottyss's gravatar image

Scottyss
56113

did you install the flux-capacitor? j/k what device and what firmware do you have?

(17 Feb '12, 18:10) Drewstone Drewstone's gravatar image
-1

You can't delete Cydia. Maybe it's on another page? What device, what firmware version, what jailbreak did you use?

(17 Feb '12, 18:13) http ♦ http's gravatar image
1

How exactly did you delete it? If you deleted the cydia installer package, you must restore and rejailbreak.

(18 Feb '12, 00:47) HeyMe HeyMe's gravatar image
2

I went to settings > Cydelete > turned off the cydia

And then I deleted the cydia.

Now I want to get it back .. also when I clicked on "Erase all content and settings", A loading wheel has been started ..and It didn't complete even in 12 hours, A whole night. (than battery got discharged and when I restarted the phone, only 2 apps got deleted.) I want to reset my device, I can't even do that.

(18 Apr '12, 07:06) prafullarora prafullarora's gravatar image
2

If you have a device compatible with redsn0w (such as iPhone 4, iPhone 3GS, iPad 1, and iPod touch 3rd/4th generation), you can often reinstall Cydia by running the latest version of redsn0w and clicking "Jailbreak" and then only checking "install Cydia".

But unfortunately using the "erase all content and settings" button on a jailbroken device messes up the system and makes it unable to boot properly, so you can no longer try that simple method with redsn0w. You'll need to restore your device using iTunes in order to fix it - make sure to restore using custom firmware if you need to preserve an unlockable baseband. Depending on your device, you may be able to jailbreak it again - see this guide to jailbreaking iOS 5.0.1 and 5.1 and see this guide to restoring a device to iOS 5.0.1.

(18 Apr '12, 07:29) britta ♦♦ britta's gravatar image

I have iPhone 4S 32 gigs.

:( ;-(

I dont know redsn0w will work on it or not ..

(18 Apr '12, 07:32) prafullarora prafullarora's gravatar image

Unfortunately redsn0w is not compatible with iPhone 4S. You'll have to restore your device using iTunes, and there is no jailbreak available for iOS 5.1, so you'll be stuck without a jailbreak until another one is released. You can follow the Dev Team Blog for reliable news on jailbreak releases.

(18 Apr '12, 07:33) britta ♦♦ britta's gravatar image

what should I do now according to you?

I think that Now I am totally screwed and cant do anything, so I should not do anything now, when the new jailbreak will arrive than I should jailbreak than.

And when the new jailbreak will arrive ? any expectations ???

(18 Apr '12, 07:38) prafullarora prafullarora's gravatar image
2

Also NEVER EVER use erase all when jailbroken. I suggest you install ResetAllKiller next time you jailbreak so that you don't forget those buttons are dangerous to use.

(18 Apr '12, 07:43) Lunatik Lunatik's gravatar image

when the new jailbreak will arrive ? any expectations ???

(18 Apr '12, 07:48) prafullarora prafullarora's gravatar image

If I "restore the device and update" through iTunes, will it download a new software ??? How large it would be in size????

(18 Apr '12, 07:50) prafullarora prafullarora's gravatar image

Nobody knows when a new jailbreak will be released. If you restore the device with iTunes, yes, it will probably need to download the new firmware file - usually around 700 MB.

(18 Apr '12, 18:01) britta ♦♦ britta's gravatar image

@britta: Thanks for the down-vote. Would you mind to explain how normal users can delete Cydia? You can break it, hide its icon with some tweaks and all that, but there's no easy way to simply delete it, right?

(18 Apr '12, 20:43) http ♦ http's gravatar image
1

Sorry for the downvote. It's actually pretty easy to delete Cydia - you can just uninstall the "Cydia Installer" package (it gives you a warning but lets you do it if you confirm that you want to). Cydelete, which is pretty popular, also lets you delete Cydia if you turn off the safety feature in Cydelete settings. :)

(18 Apr '12, 22:54) britta ♦♦ britta's gravatar image
1

Ok, with tools. You could also delete files in iFile or such things. But you cannot simply delete the app like any other app by waiting until it twiggles and click the delete button - it's like a system app. I would say the same to the built-it calculator - you cannot simply delete the calculator, but of course there are ways to do it. That's what I meant. But yes, you can break it or other stuff. And keep in mind that this was the first answer (together with the flux-capacitor reply). With your explanation the down-vote is ok.

(19 Apr '12, 16:53) http ♦ http's gravatar image
1

@knightz4u - I have a 3GS with 5.1 and 06.15.00. Had no desires for either, but long story, that's what I ended up with after some local "help."

My problem now - I've been able to get the phone back into what I believe is a jailbroken and unlocked state (the way it was before the help), but now I don't have access to Cydia although app icon is still there. Also Safari doesn't work, although the phone can still acess the internet through most Apps, and to the phone's email is blank (although the phone still tells me it is receiving emails).

When I dropped the Cydia debian file into the Cydia AutoInstall and rebooted, nothing appears to have changed.

Any additional suggestions?

(19 Apr '12, 17:11) Bustah Bustah's gravatar image
1

The jailbreak for iOS 5.1 on a new-bootrom iPhone 3GS (which is the majority of 3GSes) is a tethered jailbreak, which means that you need to "boot tethered" using redsn0w every time the device reboots, or else the device will boot up into a strange seemingly-non-jailbroken state like this. To boot tethered: open redsn0w, click Extras, click "Just boot". See here for more details about tethered jailbreaks.

(19 Apr '12, 17:41) britta ♦♦ britta's gravatar image
1

I have deleted my cydia .. Please someone suggest a way to get it back .. I have iPhone 4S I think that iFunBox can work in this situation. There is an autoinstall file of cydia.. I have pasted it on the correct path but it was not installed automatically after I rebooted my phone. Someone please help me !

(20 Apr '12, 09:42) prafullarora prafullarora's gravatar image

Thanks for the info - I knew I had to boot tethered, but didn't realize I had to do that everytime I ever turned power off as well. Total pain, but at least it's working correctly again. Appreciate the assistance!

(20 Apr '12, 15:23) Bustah Bustah's gravatar image
1

How did you delete Cydia? Did you follow the instructions @knightz4u provided? Do you have SSH access to your device? If you have SSH access and you've installed APT 0.6 or 0.7 (which are dependencies of various packages), you can SSH into your device as mobile, type "apt-get install cydia", type "uicache", and you should have Cydia again.

(20 Apr '12, 16:08) britta ♦♦ britta's gravatar image

I have gone in settings > cydelete > uncheck the cydia. and than deleted it .. I don't know what are SSH & APT... and all .. and I don't know what did you said there ! O__O

(23 Apr '12, 03:26) prafullarora prafullarora's gravatar image

I am sadly in the same sinking boat! I did exactly what prafullarora did. the onbly difference was that I did not wait 12 ours for the wheel to go on spinning! So now I am stuck with an iPhone 4 with iOS 5.0.1 and neither Cydia nor Installous on the phone. Perhaps the other option is to restore the phone via iTunes which I don't want to do as that will update my iOS to 5.1 which I then cannot jailbreak.

If I had the download of iOS 5.0.1 in my iTunes folder on my Windows Vista PC (in UsersusernameAppDataRoamingApple ComputeriTunesiPhone Software Updates) perhaps I could restore my iPhone 4 to the iOS 5.0.1 by pressing the "Shift" key when I click on restore. But I don't have 5.0.1 ipsw. Does anyone know where I can get it? How feasible is this option? Could I just drop a 5.0.1 ipsw file in to the location (UsersusernameAppDataRoamingApple ComputeriTunesiPhone Software Updates)and then restore my iPhone while it is not connected to the internet?

I did not realise jailbreaking would transfer some files to another partition. Trouble is I saw the youtube video on how to remove cydia with cydelete. My quickoffice was not allowing me to drag and drop files with iOS 5.0.1 so I wanted to reset the device it.

(28 Apr '12, 20:40) docj docj's gravatar image

dont spam it please

(28 Apr '12, 20:44) theiphoneguy ♦ theiphoneguy's gravatar image

First, grateful thanks to all of you here ! I have fixed my iPhone 4 and learnt new things. I have managed to get Cydia and Installous back on my iPhone 4 iOS 5.0.1 back again.

I followed the advice of knightz4u above. I downloaded "Cydia debian file" and "i-FunBox" from the links provided. I ran i-FunBox and connected the iPhone 4 and saw the "Folder view". Under "raw file system" in "Folder view" I found the place/folder to deposit the "debian file" that I had downloaded, which was "/var/root/Media/Cydia/AutoInstall" I then rebooted to get Cydia installed. Nothing happened.

I disconnected the iPhone 4 and reconnected it again once more opening the Folder view in i-FunBox. I checked that the "Cydia debian file" was still in "/var/root/Media/Cydia/AutoInstall" and then deposited another copy of the "Cydia debian file" in the "Cydia App Install" folder which was in the folder view. Then I turned off the iPhone 4 and restarted it. And there was the Cydia app icon on the iPhone 4 screen! I have since then installed appsync and then rebooted and then installed Hackulous and then installed QuickOffice 4.1.0. Now all is working fine but note that now, the "Cydia debian file" is no longer in either "raw/var/root/Media/Cydia/AutoInstall" or "Cydia App Install" Perhaps it is meant to be this way after the installation.

In the meantime, if anyone knows the answer to my question above about dropping 5.0.1.ipsw into the folder "Users/username/AppData/Roaming/AppleComputer/iTunes/iPhone/Software Updates" in Vista, I shall be grateful for the info.

Thanks again, everyone.

(29 Apr '12, 09:32) docj docj's gravatar image
1

How do you get back cydia on your iPad 2 5.1.1 of you accidentally uninstall it?

(13 Aug '12, 09:46) Eyesly Eyesly's gravatar image

you restore and rejailbreak

(13 Aug '12, 12:52) theiphoneguy ♦ theiphoneguy's gravatar image
1

Accidentally do some reading before you go accidentally deleting things. I keep accidentally falling on my wife, now she's preggers again.

(13 Aug '12, 16:52) spockers ♦ spockers's gravatar image

Still lost...!! I think I did exactly what you said, I uninstalled the "Cydia Installer" package. I still have no clue how all this stuff works or what I'm doing, so I apologize for my ignorance in advance. I don't have an SSH on my phone, and don't think I would know what to do with it if I did. I read the post about "ifunbox", so I downloaded that on my laptop, but If I'm understanding this correctly, I have to be able to transfer the correct root file to my phone, which requires the SSH correct?? I looked at the "Autoinstaller" option mentioned earlier in the thread, "Diskaid", but I don't want to spend 30 bucks on it if I don't know how exactly how to use it, and I'm not sure that it will work anyways. Like I said, no clue what I'm doing. Any help would be greatly appreciated.

(10 Apr '13, 19:58) cowens75 cowens75's gravatar image
1

@cowens75 Post a separate question of your own, instead of adding to an already overly long, dusty old thread, please.

(10 Apr '13, 20:43) spockers ♦ spockers's gravatar image

Just to update this question for anyone finding this question via Google, you can reinstall Cydia in a few ways - see this FAQ answer:

Use redsn0w: Usually the easiest way to reinstall Cydia is to download and open the latest version of redsn0w, click "Jailbreak", make sure that "Install Cydia" is the only checkbox checked, and let that process complete.

Use iFile: If that doesn't work (such as if redsn0w gives you error messages), another easy option is to use iFile, if you already have it installed on your device. In Mobile Safari, go to this URL: http://apt.saurik.com/debs/cydia_1.1.8_iphoneos-arm.deb - and use iFile's option to install it.

Use the command line: Or if you prefer a more elegant method, you may be able to SSH into your device and reinstall Cydia. You need to already have OpenSSH installed on your device, along with APT 0.6 or 0.7 (which are dependencies of various packages including CyDelete). After SSHing into your device: type apt-get install cydia and then type su mobile -c uicache (or reboot your device) and you should have Cydia again.

link

answered 17 Jan '13, 01:21

britta's gravatar image

britta ♦♦
23.4k104933

edited 10 Apr '13, 20:46

An iPhone has two partitions, for the Jailbreak to work some of the system partition files/applications are moved to the other partition, when you hit the "Erase all content and settings" button it deletes those files among the other content and settings files, so its amazing that your iPhone still functions (i have never actually had my iPhone in this situation).

Anyhow, since your iPhone is still functioning, you may be able to reinstall Cydia by placing its debian file in the AutoInstall folder using an iPhone file explorer software like iFunBox.

The Cydia debian file download link is here http://apt.saurik.com/debs/cydia_1.1.6_iphoneos-arm.deb, use iFunBox from here http://i-funbox.com/ and use it to place the debian file in the iPhone folder /var/root/Media/Cydia/AutoInstall and then reboot your iPhone to get Cydia installed.

link

answered 18 Apr '12, 07:59

knightz4u's gravatar image

knightz4u
4.9k91228

I went through the whole process ... nothing happened .. :(

any other suggestion ???? PLEASE :( :(

(18 Apr '12, 08:47) prafullarora prafullarora's gravatar image

Since you've already hit "erase all content and settings" and gotten stuck on the Apple logo while booting, you can't use this method - you need to restore.

(18 Apr '12, 18:02) britta ♦♦ britta's gravatar image

@britta: He/she said that after the battery drainage the device rebooted again normally with only two apps deleted. So it's worth a try. I would also restore such a device, but having to decide between a broken device and no jailbreak, not everyone decides to have it fixed.

(18 Apr '12, 20:39) http ♦ http's gravatar image

Oh hmm, you're right, I missed the bit noting that it managed to boot up - agreeing with @knightz4u about the strangeness of this. The AutoInstall method was a good suggestion - I don't know if there are any other options if that didn't work.

(18 Apr '12, 23:00) britta ♦♦ britta's gravatar image

I have the same problem and tried the above solution but there was no Cydia folder in my phone after /var/root/Media

Any advice please?

(14 Jun '13, 07:30) Droodroid Droodroid's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,713

Asked: 17 Feb '12, 17:55

Seen: 61,494 times

Last updated: 14 Jun '13, 07:30

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.