Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

Okay, so here's the deal. I just upgraded to iOS 5.0.1 on my iPhone 3GS, I was waiting for the untethered jailbreak to upgrade. I upgraded and got everything back the way it was, and now I can't install any app updates from the appstore. I tried updating from the phone, and I tried updating them on my computer and resyncing them. Both methods it says "This app could not be installed at this time." Any idea what would cause this? And is there a fix other than restoring my phone again?

asked 08 Jan '12, 22:08

Maxwell's gravatar image

Maxwell
11113

closed 04 Dec '13, 04:51

theiphoneguy's gravatar image

theiphoneguy ♦
37.4k54918

The question has been closed for being "Other - old" by theiphoneguy, 04 Dec '13, 04:51


Did you buy these apps from the appstore?

link

answered 08 Jan '12, 22:13

justinred's gravatar image

justinred ♦
46.1k74116

Yes, the ones that are being updated are free and ones I paid for.

(08 Jan '12, 22:24) Maxwell Maxwell's gravatar image
2

Download AppInfo from cydia. Run it and in appstore tab, tap action, choose detailed list, copy paste everything here. Let's have a look see which apps are give you issues.

(09 Jan '12, 10:15) justinred ♦ justinred's gravatar image

@justinred well played sir

(10 Jan '12, 01:14) JuergenWest ♦ JuergenWest's gravatar image

(For a little more explanation, the reason we're asking about App Store apps is that we've seen piracy tools can cause syncing issues and related problems. I don't imagine that a normal App Store app could cause this issue. There could be something else causing the problem though.)

(10 Jan '12, 03:59) britta ♦♦ britta's gravatar image

It's pretty much every app that needs to be updated via the appstore. Not just specific apps. Right now, I've been trying to update the WordPress app. And it's free, but it won't work. I'm thinking about just restoring my phone and trying again. And if it does it again, I just won't jailbreak it again.

(10 Jan '12, 21:52) Maxwell Maxwell's gravatar image

Do you have anything installed like iBooks "fix" packages, or other things that might rearrange the filesystem?

link

answered 08 Jan '12, 22:35

britta's gravatar image

britta ♦♦
24.0k115134

Not that I know of. I just have a few tweaks installed through cydia. Mainly FolderEnhancer, SBSettings, Barrel, and a few Winterboard themes.

(09 Jan '12, 00:30) Maxwell Maxwell's gravatar image

Maybe try putting your device in Safe Mode (using SBSettings) and seeing if you can sync? I don't think a tweak could be causing this issue, but Safe Mode could help eliminate that possibility anyway.

(09 Jan '12, 02:02) britta ♦♦ britta's gravatar image

Okay, I'll try that. But dumb question, how do I do that? I've only had it go into safe mode by itself.

(09 Jan '12, 02:17) Maxwell Maxwell's gravatar image

Sorry, I should have explained! In SBSettings, tap "Power" and then tap "Safe Mode".

(09 Jan '12, 02:21) britta ♦♦ britta's gravatar image

Ohh okay. I'll try that now.

(09 Jan '12, 02:22) Maxwell Maxwell's gravatar image

Nope, still does the same thing. Could the jailbreak be doing it? Does anyone else have the same issue? My sister suggested it could be the jailbreak since she doesn't jailbreak hers and hers works fine. But I never had any problems with a jailbreak before now.

(09 Jan '12, 02:25) Maxwell Maxwell's gravatar image

The jailbreak probably isn't causing this issue, since I haven't heard of anyone else with a jailbroken device having a similar issue. I don't know what the problem is though. :(

(09 Jan '12, 08:44) britta ♦♦ britta's gravatar image

Try rebooting.

link

answered 08 Jan '12, 22:11

JonSeals's gravatar image

JonSeals ♦
15.8k471763

I tried that. I even tried a hard reboot. Still does the same thing.

(08 Jan '12, 22:13) Maxwell Maxwell's gravatar image

:(

(08 Jan '12, 22:14) JonSeals ♦ JonSeals's gravatar image

Did you also check for the time and date settings on your iPhone, make sure they are correct and try again.

link

answered 10 Jan '12, 04:12

knightz4u's gravatar image

knightz4u
4.9k91328

Sounds like you installed Spire?

I know I've had a couple of conflicts with it, installing it, no apps would open, uninstalling it, then bam, everything worked. If you do have Spire installed, please try uninstalling it, check if everything works, and eventually install it again. I installed it again and don't have any issues now.

link

answered 10 Jan '12, 16:52

J0n3zz's gravatar image

J0n3zz
20425932

Nope. I don't even know what that is, to be honest. I haven't changed anything since before I upgraded to iOS 5.0.1. It was jailbroken on 4.3.3 and everything was working fine. I didn't install any new cydia apps or tweaks after upgrading. Just restored the ones I had via AptBackup from the BigBoss repo.

(10 Jan '12, 21:54) Maxwell Maxwell's gravatar image
1

Don't use Aptbackup after a restore to different iOS version (iOS4 to iOS5). Some cydia apps are not yet iOS5 compatible and may cause stability issues.

(10 Jan '12, 22:00) justinred ♦ justinred's gravatar image

Doing a restore fixed this issue for me.

link

answered 17 Mar '12, 09:22

paddude's gravatar image

paddude
517312

Really? Oh crud, I can't do that right now as Apple stopped signing iOS 5.0.1 and the jailbreak wouldn't work. Can anybody veryfy if restoring fixes the problem?

(18 Mar '12, 06:00) jakobim jakobim's gravatar image

Restoring will fix the problem. The SAME exact thing happened on my iPad 2 last night on iOS 5.0.1. I restored and it is back to normal... BUT I can't jailbreak it now :(

(20 Mar '12, 21:36) Jfazyankees13 Jfazyankees13's gravatar image

Oh no! Next time, post a question here before restoring and we'll try to come up with alternate ways to solve the problem, to see if there's any possible way to avoid restoring.

(21 Mar '12, 03:01) britta ♦♦ britta's gravatar image

@Jfazyankees13:

Sorry to hear that. Don't worry to much though, as I read they already jailbroke the iPad 3, so it should only be a matter of time before we can jailbreak iOS 5.1.

Sorry to say this, but your current situation does not prove if restoring (really) fixes the problem, as you have no jailbreak on you iPad, which could prove to be a completely different constellation.

@britta:

Ehmm...help! I'm exactly in the situation Jfazyankees13 was in and I'm asking for help in order to not be in the situation he is now in. I really tried everthing and am at the end of my wits!

(24 Mar '12, 07:45) jakobim jakobim's gravatar image

if u modify any part of the os manualy ie sliders or slide text u get this problem i have had this before

link

answered 18 Mar '12, 07:15

Crowie85's gravatar image

Crowie85
349128

"Modify" in what way? Like through a tweak / .deb, then the Apps should be working in Safe Mode, which isn't the case.

If you mean "modify" as in manually manipulating files of the OS, could you describe it more precisely, please? Also, what exactly was your problem and how did you solve it?

(19 Mar '12, 12:32) jakobim jakobim's gravatar image

as in change the slider.png for one u have modified the color of

(20 Mar '12, 08:18) Crowie85 Crowie85's gravatar image

i copied the slider .png to my pc and changed the color of it and then copied it back I did this to avoid winterboard but since ios 5 if u do this u cant install anything from the appstore even if u put the original file back. the only way i found to fix was to restore

(20 Mar '12, 08:22) Crowie85 Crowie85's gravatar image

@Crowie85 did you set the permissions and ownership correctly after copying the .png file?

(20 Mar '12, 08:26) knightz4u knightz4u's gravatar image

This theory sounds quite interessting: By intentionally (like Crowie85 did) or unintentionally (e.g. a tweak manipulates something we don't know of) working on OS files and/or folders, it could screw up permissions of the OS, which would lead to the behaviour I / we described.

After hearing these theories I think this will most probably be the problem, as:

1.: Safe Mode (all tweaks diabled) doesn't make a difference

2.: Restoring (resetting everthing, also permissions) seem to solve the problem

Question is, how can I find out where a permission went wrong and solve the whole matter without a restore?

@Crowie85: Could you please try what knightz4u suggested and verify if the theory is correct?

@knightz4u: I don't think I can ask this of you, but could manually change the permission on an OS file/folder (e.g. the Slider image Crowie85 described) an see if you get the same behaviour we described?

(24 Mar '12, 07:33) jakobim jakobim's gravatar image

I would try, but I couldn't locate the slider.png file mentioned above.

(24 Mar '12, 08:05) knightz4u knightz4u's gravatar image

@knightz4u: Would you really try it? I don't want you to screw up your phone, too. If you are sure you want to do it (which would be a BIG help) I found the slider under

/System/Library/PrivateFrameworks/TelephonyUI.framework/

and it is called

bottombarknobgray@2x~iphone.png

(24 Mar '12, 09:08) jakobim jakobim's gravatar image

Any news so far?

(31 Mar '12, 03:49) jakobim jakobim's gravatar image

Sorry for being late on this, i have tried deleting the png file alltogether, rebooted and the slider arrow is invisible :-), this however doesn't affect my App Store activity, i'm able to purchase and install new Apps. I will now put it back the way it was. This was tested on 4S @ 5.0.1.

(31 Mar '12, 06:11) knightz4u knightz4u's gravatar image

No problem and thank you very much for trying. Hmmm ... so this is no solution either ... seems like I really have to wait for a new jailbreak / possibility to downgrade in order to restore my iPhone.

(31 Mar '12, 06:41) jakobim jakobim's gravatar image

Erm, editing/removing does not mess up the MobileInstall part of iOS as they run separately, as @knightz4u can testify. You can try fixing the permissions in SBSettings.

(31 Mar '12, 08:38) caughtinflux caughtinflux's gravatar image

@CaughtInFlux: This really got my hopes up, but sadly it also made no difference. I tried fixing the dir permissions in all imaginable combinations with rebooting/respringing/installing an "official" app, but it still closes right after I open it.

(01 Apr '12, 06:31) jakobim jakobim's gravatar image

help!!!is it normal for my jailbroken device not to have cydia nor an App Store?

link

answered 05 Jan '13, 09:39

bananalama's gravatar image

bananalama
111

-1

Hello people!

I can't believe it, I have exactely the same problem as Maxwell! I tried to install "official" apps from the iTunes app store, the installation also succeeds, but as soon as I open the app, it closes right away. Just for you to know, I download the apps in iTunes but sync them with iFunBox. But that shouldn't matter, as Maxwell is also having trouble with iTunes. Oh, and I also tried syncing in Safe Mode, but it didn't make a difference. For the time beeing, I had to pirate some apps i really need :C But I don't wanna pirate them, I wanna buy them! Please help me / us! Is there any solution yet?

link

answered 17 Mar '12, 04:35

jakobim's gravatar image

jakobim
13

solve the problem, dont pirate

(17 Mar '12, 05:06) theiphoneguy ♦ theiphoneguy's gravatar image

As I wrote that's exactly what I'm trying to do! But as I can't solve it myself, I'm asking for help. That's the whole point: As soon as it works, I throw away all the pirated apps (along with that stupid AppSync) an will give the developers their well(!) deserved money!

(18 Mar '12, 05:11) jakobim jakobim's gravatar image

Do you happen to have anything like Spire installed? Spire is known to cause App Store apps to crash. You can also try putting your device in Safe Mode (using the "Power" button in SBSettings) - this disables all tweaks. If installing apps and using apps seems fine in Safe Mode, try temporarily uninstalling some of your tweaks to find the problematic ones through process of elimination.

(18 Mar '12, 16:17) britta ♦♦ britta's gravatar image

But I already wrote that I tried syncing and starting iTunes Apps in Safe Mode without any success. So starting to uninstall Apps (or in this case to be more precise .deb's) won't make a difference, as the iTunes Apps won't work in Safe Mode, right? And just like Maxwell I also don't have Spire installed.

Is it possible, that an Apps is causing the trouble? That can't be, as I try to start the iTunes Apps without anything running in the background. Am I correct?

(19 Mar '12, 12:28) jakobim jakobim's gravatar image
-3

Hi, I have the same problem but after I had upgraded to ios 5.0.1 redsnow-b3 I restored my ipod apps using itunes. I've already unistalled all the cydia packs that I've installed before, but it didn't fix the problem. please i need help

link

answered 11 Jan '12, 18:43

ratatrampa's gravatar image

ratatrampa
-191

I forgot it, I have another issues like I can't use the cover flow cause when i do it the ipod takes me out to the springboard and stops the music, so you tell me what to do, but i think that the best solution is to do a clean format without restoring the apps. piracy goes great.

(11 Jan '12, 18:50) ratatrampa ratatrampa's gravatar image

please do not pirate apps, it will mess up your device and hurts the community. thumbs down brah

(11 Jan '12, 22:25) therealcmac therealcmac's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7,225
×589
×516
×182

Asked: 08 Jan '12, 22:08

Seen: 21,067 times

Last updated: 04 Dec '13, 04:51

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.