Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

Hello everyone,

I am not sure if this is the right place to ask this kind of question. If you're not allowed to ask this kind of questions here then i'm sorry.

So let me explain - i have a problem with the Spire app of chpwn. Got it installed and setup with a proxy and it's working fine. Thanks for this app btw.

But the problem is that other apps like facebook, twitter and some other app store apps simply won't load anymore. They get stuck at the loading screen and then crashs.

Anyone got a solution for this?

Thanks, cenbuz

asked 29 Dec '11, 08:27

cenbuz's gravatar image

cenbuz
25216

closed 26 Nov '13, 04:19

theiphoneguy's gravatar image

theiphoneguy ♦
36.5k54618

i had the exact same problem. no apps would load. i just uninstalled spire for now. too buggy for my liking.

(31 Dec '11, 17:05) pargoff pargoff's gravatar image

I installed Spire on a fresh 5.0.1 and was able to use it without issue for about a day. It appears to be mobile substrate addons that interfere with it.

The straw that broke the camel's back was "Pull to Refresh for Safari" for me. Many app store apps (Tweetbot, Mint, Facebook, etc.) would not load for me, each getting exception 0x8badf00d.

Removing the mentioned addon did not bring back app store app functionality. Only once I removed Spire was I able to use these apps again. Here's hoping chpwn gets a chance to take a look at this.

I have tried removing Spire, reinstalling MS, and reinstalling Spire to no avail.

(02 Jan '12, 22:43) rethaw rethaw's gravatar image

The question has been closed for being "Other - old" by theiphoneguy, 26 Nov '13, 04:19


12next »

I actually found that Copic is the culprit of crashing Facebook and Twitter.

try uninstalling that..

link

answered 29 Dec '11, 17:44

jkister's gravatar image

jkister
266271137

i dont think so copic is doing anything since it works fine without spire installed

(29 Dec '11, 19:14) cooldude911 cooldude911's gravatar image

oh, okay, so you're saying that you tried it and that wasn't your problem.

im my case, it was the problem.

i'm glad you gave it a shot. because coming to forums to ask for help, finding a gem and ignoring it would be silly.

(29 Dec '11, 20:03) jkister jkister's gravatar image

@jkister were you only facing problems with facebook and twitter only ?

(29 Dec '11, 20:12) cooldude911 cooldude911's gravatar image

Thank you jkister.

This really works. I removed COPIC and now everything is working perfectly fine.

Again, thank you very much! :)

(29 Dec '11, 20:34) cenbuz cenbuz's gravatar image

Strange, I just installed and activated Copic on my 5.0.1 iPhone 4, and my Facebook and Twitter apps still work fine. I don't have Spire installed though. Does Copic only crash apps if you also have Spire installed? Can you guys provide crash logs for Facebook and Twitter?

(29 Dec '11, 22:36) britta ♦♦ britta's gravatar image

only if you have spire installed. copic works fine w/o spire.

(29 Dec '11, 23:01) cenbuz cenbuz's gravatar image

i can confirm that disabling the SIRI addons in MobileSubstrate is not enough to get things happy with Copic. i did not try uninstalling Spire and keeping Copic.

  1. twitter crash
  2. facebook crash
(29 Dec '11, 23:57) jkister jkister's gravatar image

Thanks, you're right, the problem happens with both Copic and Spire installed. The author of Spire knows about this now, but I'm not sure whether the problem is the fault of Copic or Spire, or if/when there will be a fix for having both installed...

(30 Dec '11, 05:13) britta ♦♦ britta's gravatar image

i have just removed copic everything that did not work before does so far and still have spire. but dont have a working proxy server yet does anyone have one i could us.

(30 Dec '11, 06:37) robsonmeg robsonmeg's gravatar image
1

Cyntact got updated to work with iOS 5.0.1 so there is no need for copic anymore :)

atleast for me

(30 Dec '11, 09:50) cenbuz cenbuz's gravatar image

http://pastebin.com/JW7zWHW0

(30 Dec '11, 13:33) cenbuz cenbuz's gravatar image
1

IArrays has released Copic 2.0-2-beta-4 which appears to have solved the problem. Since it's still beta it's not in the main repository yet; just add http://iarrays.com/apt/ to your list of Cydia repos and install from there.

(31 Dec '11, 17:28) jkister jkister's gravatar image

I dont have copic or cyntact installed and spire still caused app problems.

(31 Dec '11, 19:58) pargoff pargoff's gravatar image

Hi All ! here The solution to fix this problem with all apps crashes and it works for me !!!!

Just reboot your idevice with redsnow /extras/just boot (tethered right now) Hope it work 4 U

link

answered 04 Jan '12, 04:12

Nicolas1er's gravatar image

Nicolas1er
413

edited 04 Jan '12, 04:12

This worked for me :) I suppose using a tethered boot with Corona also installed is good enough for now. At least if I reboot my phone i wont be stuck until i redsn0w tether boot again... :)

(04 Jan '12, 09:44) kantlivelong kantlivelong's gravatar image

Yes this works, thanks!

(04 Jan '12, 15:31) rethaw rethaw's gravatar image

New Copic is working great now with spire so go and get it

link

answered 31 Dec '11, 17:42

robsonmeg's gravatar image

robsonmeg
1623

This is an OK question, since it's about a legitimate Cydia package. See this similar question for some potential answers and tips.

link

answered 29 Dec '11, 08:33

britta's gravatar image

britta ♦♦
23.4k104933

Thank you for the link britta.

I tried following things now (twitter app):

  • reinstall twitter
  • uninstall, reboot, install
  • free up memory
  • uninstall both (twitter and spire), install twitter then spire

nothing got it working.

appreciate any other input :)

(29 Dec '11, 08:37) cenbuz cenbuz's gravatar image

I'm not sure, really. It sounds like this is a common problem with Spire, if you search Twitter for "spire" and "crash". Posting app crash logs might be useful if somebody reads this thread later who knows how to interpret crash logs. Get Crash Reporter from Cydia for that, paste them into pastie.org, and paste the link here.

(29 Dec '11, 08:48) britta ♦♦ britta's gravatar image

http://pastebin.com/JW7zWHW0

(29 Dec '11, 08:56) cenbuz cenbuz's gravatar image

hope this helps :)

(29 Dec '11, 08:57) cenbuz cenbuz's gravatar image
2

Plus, it's by one of the guys in the footer. :P

(30 Dec '11, 00:18) spockers ♦ spockers's gravatar image

if you have other 3rd party non endorsed siri or siri like tweaks installed that may be causeing your issues

link

answered 29 Dec '11, 08:38

SkOODaT's gravatar image

SkOODaT
11615221

where ya find the siri proxy your own im guessing lol :) wish some paid rental ones would pop up lol

(29 Dec '11, 08:41) SkOODaT SkOODaT's gravatar image

Hey Sk00Dat,

i forgot to mention that i have no other siri like applications installed.

Following cydia apps/tweaks are installed:

-Activator -AdBlocker -Barrel -biteSMS -Copic -IconRenamer -iFile -Infinidock -IntelliScreenX -ManualCorrect -MobileVolumeSound -NoBookmarks -NowPlayingDetailInfo -OpenSSH -SBSettings -Unified Ipod for IOS 5 -Veency -Zephyr

(29 Dec '11, 08:44) cenbuz cenbuz's gravatar image

that's correct. a friend of mine owns an iphone 4s so i was able to setup a proxy.

(29 Dec '11, 08:49) cenbuz cenbuz's gravatar image

Note: Installing FIX for MobileSubstrate doesn't work either.

(29 Dec '11, 14:10) cenbuz cenbuz's gravatar image

Do you mean installing the latest version of Mobile Substrate?

(29 Dec '11, 14:11) britta ♦♦ britta's gravatar image

I read this on the dev team blog:

"The b3 version of redsn0w fixes a problem where re-running redsn0w over an existing jailbreak would cause MobileSubstrate-based apps to stop running until MS was installed again. Now you can re-run the redsn0w jailbreak step without worrying about that (but still remember to de-select the “Install Cydia” option if it’s already installed)."

So yea i did that :)

(29 Dec '11, 14:19) cenbuz cenbuz's gravatar image

I see. Yeah, that wouldn't fix this. Your best bet is to try maximizing the amount of memory available on the device (by closing backgrounded applications).

(29 Dec '11, 14:24) britta ♦♦ britta's gravatar image

already tried that.

  • deleting all apps in switcher bar
  • freeing up memory using sbsettings process option
(29 Dec '11, 14:59) cenbuz cenbuz's gravatar image

Thank you jkister.

This really works. I removed COPIC and now everything is working perfectly fine.

Again, thank you very much! :)

link

answered 29 Dec '11, 20:34

cenbuz's gravatar image

cenbuz
25216

1

Also: I switched from Copic to Cyntact(saurik's app)

So now i am also having nice pictures of my contacts in my phoneapp plus i am able to use siri. AWESOME :)

(29 Dec '11, 20:35) cenbuz cenbuz's gravatar image

I still face problems when i unintall copic and install siri

(30 Dec '11, 01:50) cooldude911 cooldude911's gravatar image

Another user reports (on IRC) that uninstalling My3G helped fix app crashing issues with Spire.

link

answered 30 Dec '11, 17:51

britta's gravatar image

britta ♦♦
23.4k104933

I was plagued with the same issue - what worked for me was to disable the My3G MobileSubstrate addons. App Store apps seem to be work fine now.

Best advice is to keep disabling MS addons until you find the one that is causing the crashes.

Hope this helps!

(15 Jan '12, 21:34) sharepointalex sharepointalex's gravatar image

uninstalled my3g and never had copic....apps still crashing with spire installed. if many apps that use mobilesubstrate are the problem, it seems the real problem is spire - something needs to be fixed

link

answered 30 Dec '11, 18:32

organik's gravatar image

organik
3613

edited 30 Dec '11, 18:32

same here .. didnt have my3G and still facing problems

(30 Dec '11, 20:16) cooldude911 cooldude911's gravatar image

Try disabling the MS addon for winterboard and see if that helps ;)

link

answered 30 Dec '11, 20:12

tehh4ck3r's gravatar image

tehh4ck3r
56325

My fix was to remove my3g, respring, reinstall mobile substrate, respring and now everything works fine. Before, google search and GTA 3 weren't working. Tried them now and all is well.

link

answered 31 Dec '11, 11:59

Fr0sTy's gravatar image

Fr0sTy
211

I did that on my iPhone but now iHeartradio still doesn't work.

(02 Jan '12, 23:43) Jacob61916 Jacob61916's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×201
×42

Asked: 29 Dec '11, 08:27

Seen: 14,835 times

Last updated: 26 Nov '13, 04:19

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.