Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

2
1

Hello.

After I updated thru Cydia TODAY:

  • Mobile Substrate from 0.9.3901 to 0.9.3993
  • UIKIT Tools from 1.1.0 to 1.1.3
  • Cydia from 1.1.1 to 1.1.3

After a Respring (asked by Cydia), my device was very slow. I rebooted. So, from that point, stays on Apple Boot Logo forever, and after some time reboots again.

So, how do I DOWNGRADE all the updates above? Or just Mobile Substrate? Without a restore.

I tried by SSH, nothing. I tried i-FunBox, nothing (it doesnt recognizes my device).

Please help. Thank you!

asked 28 Dec '11, 01:14

Camilo%20Rodrigues's gravatar image

Camilo Rodrigues
57115

closed 24 Nov '13, 22:10

spockers's gravatar image

spockers ♦♦
59.3k328249

rather than downgrading why dont you just update to 5.0.1 is it a untethered jailbreak afterall and everything will work fine

(28 Dec '11, 01:42) InevitableDJ InevitableDJ's gravatar image

The problem come from "Mobile Substrate 0.9.3993" if you can find the older version of it, just reinstall it though ssh, mine, i just re-install Mobile Substrate 0.9.3901, and the problem is gone..

(28 Dec '11, 08:58) bwings bwings's gravatar image

Hello. bwings.

Yes, I got the previous version on apt.saurik.com.

So now, how do I SSH int the device? It's frozen on Apple Boot Logo. I know how SSH works, but I can't connect, even via USB. How did you manage it?

Thank you!

(28 Dec '11, 09:03) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

Hey Atonned

I've been trying for 2 days. Even with RAMDISK SSH I coudn't (disabling Mobile Substrate).

I didn't finish yet before doing a restore.

THIS SUCKS

(29 Dec '11, 10:01) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Meaning i wud have to do a restore too? and i dont know Ramdisk SSH ,,can u tell? perhaps it might work here.

(29 Dec '11, 10:18) Atonned Atonned's gravatar image

Not yet.

If it works, I explain to you.

(29 Dec '11, 10:20) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

Can you verify for me that you actually succeeded in "disabling Mobile Substrate" using your ramdisk?

(29 Dec '11, 14:14) saurik ♦♦ saurik's gravatar image

@britta

i have the same issues. is it possible to kick my device out of logo loop without updating to 5.0.1? i don't want to lose my jailbreak in 4.3.3. thanks!

(06 Jan '12, 11:44) m3inard m3inard's gravatar image

same prob also here. Deleting launchd.conf boots the device in safe mode, sbsettings installed but not functional. Has somebody come up with a solution without restore?

(06 Jan '12, 19:07) mindovermedia mindovermedia's gravatar image

@mindovermedia

what device are you using? how did get into safe mo?

(06 Jan '12, 23:47) m3inard m3inard's gravatar image

4.3.3 (8J2) Iphone 4 jb

(07 Jan '12, 06:13) mindovermedia mindovermedia's gravatar image

if you have saved shsh files you wont lost the jb :) (include ipad 2 3g)

(07 Jan '12, 06:38) kralle kralle's gravatar image

The question has been closed for being "Solved" by spockers, 24 Nov '13, 22:10


12next »

For new people reading this thread, here is a solution that may help you boot up your iPhone:

In Mobile Substrate version 0.9.3997 (released on April 16, 2012), there is a new feature I would recommend trying:

As of version 0.9.3997, you can now disable Substrate entirely by holding down Volume Up as the device boots.

This feature allows you to bypass horribly broken extensions (ones that prevent the device from starting up at all) that you may have installed so you can open Cydia and uninstall them.

In other words, just force a reboot (by holding down the power and home buttons) and then immediately hold down the Volume Up button as the device boots up. Hopefully it'll help you get into Cydia and uninstall the tweak that caused the problem. Also check this guide in the JailbreakQA FAQ for more advice on fixing devices that won't boot up properly.

If you haven't updated Mobile Substrate yet, or if you just want to try this older method covered in this thread, here is a expansion of saurik's instructions below. It should work for both Mac and Windows users:

  1. Download a stock (unmodified) copy of redsn0w for Mac or Windows. (On Windows, don't forget to set compatibility modes.)

  2. Select "Jailbreak". When you get to the step involving "Install Cydia", uncheck all boxes, but then select "Install Custom Bundle".

  3. Download http://cache.saurik.com/jailbreakqa/cb-399x-1.tgz and select it (it will replace /etc/launchd.conf with an empty file). [If your device was jailbroken with JailbreakMe, use this file instead: http://cache.saurik.com/jailbreakqa/cb-399x-3.tgz ] Don't unzip the file, just use it.

  4. Run this copy of redsn0w, select Jailbreak, and then do what you normally would do. This will deactivate Substrate and Corona.

  5. Reboot your device the way you normally would, taking into account that Corona will be uninstalled. As far as I know, other untethers will not be affected by this process, but Corona will definitely stop working.

  6. Go into Cydia and uninstall problematic extensions, and then try booting your device again, possibly going through these steps again if you still encounter a boot loop.

link

answered 30 Dec '11, 06:43

britta's gravatar image

britta ♦♦
23.9k105133

edited 18 Apr '12, 02:34

@britta pleaseeeeeeeeee add windows solution :( I'm stuck on bootloop after update MobileSubstrate from 3993 to 3995 :(

(30 Dec '11, 07:27) BitSin BitSin's gravatar image

Are you on an iPad 2 or an iPhone 4?

(30 Dec '11, 07:39) britta ♦♦ britta's gravatar image

@britta iPhone 4, 4.3.3

(30 Dec '11, 07:48) BitSin BitSin's gravatar image

@britta Could you please replace rd.tar with rd-399x-2.tar and create new package for me ?

(30 Dec '11, 08:02) BitSin BitSin's gravatar image
1

@BitSin Wait, you are saying 3993 worked, but 3995 does not?! That is really weird. :(

(30 Dec '11, 08:23) saurik ♦♦ saurik's gravatar image

@saurik unfortunately YES ! :( Yesterday I installed 3993 but it end up with SAFE MODE, then I removed it and respring, then re-install it and everything goes well again. Today, I updated to 3995 and Cydia asked for reboot and it goes to bootloop ! :( Could you please show me any solution, so I can boot it and backup my Data ? Can't use rd.tar - I'm on Win OS.

(30 Dec '11, 08:33) BitSin BitSin's gravatar image

Check this answer - I updated it with saurik's Windows instructions.

(30 Dec '11, 08:35) britta ♦♦ britta's gravatar image

@saurik and @britta cb-399x-1.tgz didn't help. :( Still stock on bootloop !

(30 Dec '11, 12:18) BitSin BitSin's gravatar image
1

@BitSin: What device, firmware, and jailbreak is this device?

(30 Dec '11, 12:23) saurik ♦♦ saurik's gravatar image

@saurik iPhone 4 - 4.3.3 - jailbreakme.com - After on bootloop tried with redsn0w 0.9.10b3 What are my options to at least backup somefiles ?

(30 Dec '11, 12:33) BitSin BitSin's gravatar image
2

@BitSin Ah, ok, that makes more sense. The issue there is that JailbreakMe 3.0 Saffron is "broken", in that it applies "too late" in the boot process (using dirhelper, instead of launchd.conf), so Substrate is not able to use its fancy new injection system. This is why 0.9.3993 "worked": it wasn't really hooking that much; maybe you installed it, it didn't require a reboot, whatever daemon you have that is dying was never restarted, and so you "were good". If you had rebooted, you'd still be "good", excepting that Substrate would simply not work (as it would start before Saffron). However, 0.9.3995 detects Saffron and switches back to the old injection system used in 0.9.390x. This old injection scheme requires a reboot, which you obliged, and the now working old injector got broken by some extension while the device rebooted. This also means that, because you aren't using the new injector, cb-399x-1.tgz will not uninstall Substrate. I have uploaded a new file: http://cache.saurik.com/jailbreakqa/cb-399x-2.tgz. This one overwrites the LaunchDaemon configuration plists for the services affected by Substrate on 4.3 with their original versions.

(30 Dec '11, 13:01) saurik ♦♦ saurik's gravatar image

@saurik Used cb-399x-2.tgz and nothing changed :( Still stuck bootloop. IMPORTANT : many thanks to you and I really appreciate all efforts and times you spending on my problem. :)

(30 Dec '11, 13:31) BitSin BitSin's gravatar image
1

@BinSin FWIW, I now understand why -2.tgz did not work. JailbreakMe 3.0 used unionfs instead of stashing, and Substrate was atomic file operations to overwrite the LaunchDaemons, so the result is that the launch daemon configuration is on the second partition. I am looking into how I can overwrite them.

(30 Dec '11, 14:00) saurik ♦♦ saurik's gravatar image

IDK how to say Thank you. Hope it is possible and you find it dude :)

(30 Dec '11, 14:15) BitSin BitSin's gravatar image
3

@BinSin OK, that, or "-2.tgz was actually a .tar with the wrong extension" ;P. I doubt that that was the problem, though, as you likely would have gotten an error somewhere, and tar on the device is actually pretty good about autodetecting. Regardless: http://cache.saurik.com/jailbreakqa/cb-399x-3.tgz should downgrade the LaunchDaemons on /var/null as well, which should work for JailbreakMe 3.0 installations. (Also, I saw you on IRC.)

(30 Dec '11, 14:15) saurik ♦♦ saurik's gravatar image

@saurik Thankssssssss dude :) you're a life saver ! I went 1 step forward; The device is recognized and I can hear DING SOUND as I connect it via USB. But the only problem remains is Device is not completely booted. I see Apple Logo and a spin over it and now DING SOUND is on loop ! On Device Manager, USB isn't reconnect but I hear the sound about every 2 mins ( as we normaly hear it when we respring or reboot iDevice and connect it via USB (Charging too)).
Edit: Should I install 0.9.3993 now ? So I can see SB ?

(30 Dec '11, 14:42) BitSin BitSin's gravatar image
1

@BinSin If you have OpenSSH installed you can probably SSH in at this point and get a syslog from the device, which can be used to determine what is still broken with it. If not, you could install libimobile device from http://www.libimobiledevice.org/, which has a "remote syslog" feature; given how far your device is now booting, it is likely that you can see the syslog now over USB.

(30 Dec '11, 15:16) saurik ♦♦ saurik's gravatar image

@saurik Should I send syslog public or private ?

(30 Dec '11, 16:19) BitSin BitSin's gravatar image

Do what I did: create a RAMDISK SSH, mount the partitions and then erase or rename /etc/launchd.conf and reboot (kill 1). that's it. Here is the instructions: http://msftguy.blogspot.com/2010/11/booting-ssh-ramdisk-on-new-devices.html follow it.

(30 Dec '11, 16:49) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

@Camilo: It turns out that @BitSin's problem could not be solved by that, as he had JailbreakMe 3.0 Saffron, which means that Substrate was using the old injection vector; that's why I needed a more complex ramdisk. Once that was fixed, the device still did not boot, however, and it turned out to be because he ran redsn0w over the device without a custom bundle in it while trying to figure out what my rd*.tar files were, which caused a second unrelated jailbreak process to be performed on his device. Most of the jailbreaks people release are reasonably similar to each other, but JailbreakMe 3.0 was "something special": it had a unionfs layer that bifurcated the filesystem in ways that makes it really difficult to fix/edit, and it also had an irritatingly late deployment (which is why Substrate now considers it "buggy" and uses its older injection routine for it). This run of redsn0w on the JailbreakMe device performed a "stashing" step, which pretty much ruined the filesystem organization. I tried to fix it with a launchd.conf for him in another custom bundle, but I'm guessing that something else on the device was changed by redsn0w, such as the installation of a second untether, as a step that was supposed to do /nothing/ seems to have made the situation even worse than it has been. I am now telling him he should try to find an SSH ramdisk.

(30 Dec '11, 20:11) saurik ♦♦ saurik's gravatar image

Got it Saurik. Thanks for the explanation!

(31 Dec '11, 17:16) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Thank you saurik and all so much for this guide. I finally made it through and have my iPhone back, without losing any files, pics, videos, calendars, emails etc... I will be quick to make a full backup now.

What I did was just as explained in this guide, Redsnow, Jailbreak, Custom Bundle, Select your gz. file, bite your nails and jump from the floor once you see your screen back :)

Thank you all so much. I had a frustrating day, because I had updated all Cydia apps, and incidentally, among the updates it was also SAM from bingner repo, which proves to be erroneous and blocked my iphone.

(25 Jan '12, 13:16) albozer albozer's gravatar image

here's my solution iphone 3gs 4.3.3 i kept uikit 1.1.3 removed mobile substrate 3995 and installed the old one 3991

sbsetting is working finally

link

answered 18 Jan '12, 12:03

nikorba's gravatar image

nikorba
-425

Hi Saurik,

I do fresh install after crashing because of update Mobile Substrate from 0.9.3901 to 0.9.399. I restore with my custom IPSW made with sn0wbreeze for my iPhone 3GS (factory lock). because I must software unlock to activate my iPhone. I install SAM from cydia, when installing this also install mobile substrate(package dependencies) after this the phone crash again and only apple boot loop which happen. need your solution for this, ihope you can fix the mobile substrate, because now icant use my phone.

best regard

link

answered 24 Jan '12, 15:26

258cupu's gravatar image

258cupu
262

WOW britta.... your explanation and how to guide really2 put me out of my missery state.... and all the tweaks and data is there.. thanks a lot britta...

(02 Mar '12, 21:17) Iyo Iyo's gravatar image

But even on recovey mode, how do you manage to UPDATE?

I only option that I have on recovey mode is RESTORE.

link

answered 29 Dec '11, 11:27

Camilo%20Rodrigues's gravatar image

Camilo Rodrigues
57115

A restore with iTunes will automatically update your device to the latest firmware available from Apple.

(29 Dec '11, 11:35) britta ♦♦ britta's gravatar image

I know, but I don't want to loose all my stuff!!!!

(29 Dec '11, 11:36) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

I managed using RAMDISK SSH to get all my stuff.

What I'm trying now is to boot the device

(29 Dec '11, 11:37) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Camilo plz do tell how to do that RAMDISK Ssh.. altleast i can get my stuff from it

(29 Dec '11, 11:49) Atonned Atonned's gravatar image

I cant do step B. when i press enter on ".itunnel_mux --lport 9990 --iport 22" cmd says not program or batch file.

(29 Dec '11, 12:01) Atonned Atonned's gravatar image

follow itunnel on the other guide.

(29 Dec '11, 12:15) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Ok,i got i tunnel to run, but its stuck on [INFO] waiting for device

(29 Dec '11, 14:05) Atonned Atonned's gravatar image

Does it apply for Iphone 4 running 4.3.3? Thanks saurik

(29 Dec '11, 14:46) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

Camilo, Yes. I actually used these instructions myself on a 4.0 device that I had gotten stuck in a bootloop due to stupid tests I was running for Corona (I didn't have a 5.x device on me at the time, so I was testing some of my installation scripts on my 4.0 primary phone). This ramdisk is a very very simplistic modification of redsn0w: it should work for any firmware version redsn0w supports (and even those it doesn't, as I had to select a 4.1 IPSW in redsn0w to fix my 4.0 iPhone 4).

(29 Dec '11, 14:51) saurik ♦♦ saurik's gravatar image

Perfect. I will do this tonight. THANK YOU!

(29 Dec '11, 14:57) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Tnx Saurik; I'm on 4.3.3 and stuck on bootlogo after update MobileSubstrate 0.9.3993 to 0.9.3995 :( How to use rd-399x-2.tar if i'm on Windows ? Can I use "Add Bundle" to use rd*.tar file ? Hope to find working solution soon :(

(30 Dec '11, 02:52) BitSin BitSin's gravatar image

Do you have afc2add installed?

link

answered 29 Dec '11, 12:08

kokhean's gravatar image

kokhean
34420527

Hello.

I cant. It's stuck on Apple Logo Boot and I dont want to loose everything.

I know that if I downgrade at least Mobile Substrate the phone will boot again.

(28 Dec '11, 01:52) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

I have the exact same problem.. how do we reinstall old mobile substrate??

(29 Dec '11, 09:58) Atonned Atonned's gravatar image

used to got the same problem :/ i didnt found any other way than putting device in recovery mode, upgrading via itunes to 5.0.1, rejailbreak.. and resynch etc... ;/ i'm sure i've lost some of my sources/tweaks settings :-(

(29 Dec '11, 11:23) stone51 stone51's gravatar image

on iphone ? yes. of course

(29 Dec '11, 12:10) Atonned Atonned's gravatar image

Try using iPhone folders (http://iphonefolders.com/) to put in the older MobileSubstrate. Does your phone connect to your computer after a few moments or so? Try downloading a deb of the older MobileSubstrate and unzipping it. You will be able to figure out the locations of where to place the respective files. I'm not sure if this will work but do try this or SSH. If not, I'm afraid a restore is your only solution.

(29 Dec '11, 12:15) kokhean kokhean's gravatar image

Phone gets connected,but itunes or ifun box etc doesnt pick it up.. i have a deb of mobile substrate, i cant SSh ,, thats the problem. the link u gave FAST SSH with usb itunnel mux doesnt run on cmd.?

(29 Dec '11, 12:24) Atonned Atonned's gravatar image

iPhone 4 on 4.3.3...

I also had a bootlogo loop after upgrading Cydia Installer, UIKIT Tools, and Mobile Substrate.

I ended up restoring to 4.3.3 and re-jailbreaking. I did a restore of packages by PkgBackup and apps by iTunes, and it got stuck at some point in a bootlogo loop again.

I re-did a restore to 4.3.3 and re-jailbroke, and now installing all apps and packages one by one as I write.

I didn't want to upgrade to 5.0.1 because there are packages and themes I like that do not work on 5.0.1.

It was a long night and still going through a long day (and night).

Some updates are better left alone. :-(

link

answered 29 Dec '11, 12:30

nmdelrio's gravatar image

nmdelrio
21519624

Yeah!!!! Exacly!!!

Britta, please contact Saurik. There is a problem on that updates!!!

And please tell us what to do instead a simple restore.

(29 Dec '11, 12:31) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Do you know which version of Mobile Substrate caused the problem? saurik just released an update (0.9.3995) that should fix some problems - but it's unclear why this problem happened for a few people, so it's unclear whether 0.9.3995 will fix it. We're working on this, it's just hard to get good data about why the boot loop happened. A syslog would be helpful, if you guys could manage to grab one before restoring.

(29 Dec '11, 12:34) britta ♦♦ britta's gravatar image
2

0) Accept my apologies for any trouble you have experienced. :( 1) Download redsn0w 0.9.10b1 for Mac. 2) Download http://cache.saurik.com/jailbreakqa/rd-399x-2.tar and replace redsn0w.app/Contents/MacOS/rd.tar with that file. 3) Run this copy of redsn0w, select Jailbreak, and then do what you normally would do. This will deactivate Substrate and Corona. 4) Reboot your device the way you normally would, taking into account that Corona will be uninstalled (so you may have to "boot tethered" using an unmodified copy of redsn0w). AFAIK, other untethers will not be affected by this process, but Corona will definitely stop working. 5) Give me a syslog of what happened, as there is some extension out there that is incompatible with Substrate, and we need to figure out what it is.

(29 Dec '11, 14:24) saurik ♦♦ saurik's gravatar image
1

I did not make any changes to Substrate that would affect a "bootlogo loop": I currently have no information that would help guide debugging such a thing. Problems like that are normally caused by a broken extension: one that either makes poor assumptions about what processes it is being injected into, or which simply provides no guidance (missing a plist file). For example, MyWi caused a bunch of boot loops during the initial testing of Substrate 399x a couple months ago, because of an incorrect assumption in IntelliStatusBarIcons, a package/extension it used to add notification icons. This bug was fixed in MyWi, and Substrate now lists in its package metadata the versions of MyWi that cause the issue so Cydia will not allow the incompatible state. However, there are tons of developers out there, and tons of opportunities for someone to screw something up. Every release of Substrate we see a few of these, but this time we pretty much got it "all at once" (as every single daemon that someone may have made a bad assumption about got added in a single all-powerful go, now that Substrate is no longer neutered by LaunchDaemon files). Any issue arising this week, however, would have arisen at some point in the future anyway. :(

(29 Dec '11, 14:28) saurik ♦♦ saurik's gravatar image

The Mobile Substrate that caused the problem was 0.9.3993, from 2 days ago. I was running an Iphone 4 with 4.3.3 jailbroken with redsn0w a long time ago. THanks

(29 Dec '11, 14:48) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Ok. So I will try do disable all the Mobile Substrate extensions using the RAMDISK SSH. THank you!

(29 Dec '11, 14:49) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

Camilo, please read the instructions in the answer above (where I start with "0)").

(29 Dec '11, 14:49) saurik ♦♦ saurik's gravatar image

Saurik, I will. Thank you very much for getting involved and sorry about the tweet this morning. @msft_guy is being helping me.

(29 Dec '11, 14:56) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

I have actually come up with a theory now that /would/ support the same bug that I had to fix in 0.9.3995 having caused a bootloop on devices that were running iOS 4.3 that were /not/ using JailbreakMe 3.0 Saffron. However, it still doesn't quite fit the evidence. It does, however, mean that I find it almost likely that a test of 0.9.3995 after 0.9.3993 is deleted will work.

(29 Dec '11, 15:25) saurik ♦♦ saurik's gravatar image

Perfect. As soon I get this device running, I will install the new MS

Thank you

(29 Dec '11, 16:29) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Im doing right btw

(29 Dec '11, 16:30) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Saurik, im sending an email to you with the syslog BEFORE doing the (0) steps. Ok? Thanks.

(29 Dec '11, 16:38) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Remember: i tried to disable MS removing EnviromnetVariables from every plist on /LaunchDeamons using plutil ok?

(29 Dec '11, 16:39) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

DONE! I just removed /etc/launchd.conf and booted!!!!

(29 Dec '11, 16:49) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

It booted!!!!!

Just remove /etc/launchd.conf if you have acess to it via RAMDISK SSH or just do what saurik asked.

Thank you all! time to backup everything and update to 5.0.1

(29 Dec '11, 17:12) Camilo Rodrigues Camilo%20Rodrigues's gravatar image
1

Congrats!

(29 Dec '11, 17:16) kokhean kokhean's gravatar image
1

Yeah: Substrate no longer uses EnvironmentVariables in the plist files. Now, it is all controlled by a single file: launchd.conf. As for the syslog, this is really fascinating... Substrate actually seemed to work on your system, but then things died horribly much later. Did you try 0.9.3995?

(29 Dec '11, 22:14) saurik ♦♦ saurik's gravatar image

can i please get help? i cant figure out how to use ramdisk

iamlouiemaldonado@yahoo.com if this is ok.

(29 Dec '11, 22:42) exmurderblah exmurderblah's gravatar image
1

@exmurderblah: Read the instructions I posted a little earlier in this thread.

(29 Dec '11, 22:48) saurik ♦♦ saurik's gravatar image

sorry but still dont get it

(29 Dec '11, 23:23) exmurderblah exmurderblah's gravatar image

I didn't know Sbstrate didn't use EnvironmentVariables anymore. That's why removing it the phone still was on boot loop. After removing launchd.conf, the phone booted and after installed MS 0.9.3995 everything is back to normal again... Thanks for asking!

(30 Dec '11, 03:11) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Camilo, how you boot your device ? how to remove /etc/launchd.conf and boot ?

(30 Dec '11, 03:23) BitSin BitSin's gravatar image
1

@exmurderblah: If you can explain which part is confusing, I might be able to help explain it in more detail. Look up the thread to where saurik starts with "0) Accept my apologies" and follow those directions. If you're on a Mac, you can look inside the redsn0w application to replace the "rd.tar" file by holding down the control key while clicking the redsn0w application on your desktop, and then clicking the option that says "Show Package Contents". If you're on a Windows computer, let us know and we'll have to figure out alternate instructions...

(30 Dec '11, 04:51) britta ♦♦ britta's gravatar image
1

@britta, I'm on win and want solution exactly same as what saurik said.

(30 Dec '11, 04:56) BitSin BitSin's gravatar image
2

I have an iphone 4 with ios 4.3.3 and recently update the latest mobilesubstrate which now caused a problem and my mobile is stuck on a boot loop. My pc is a windows os.

(30 Dec '11, 06:21) jimiphone jimiphone's gravatar image

Saurik is the boss :D

(30 Dec '11, 06:23) kokhean kokhean's gravatar image
1

It turns out there is a much easier way of doing exactly this same thing with redsn0w "custom bundles". With a stock (unmodified) copy of redsn0w, select "Jailbreak". When you get to the step involving "Install Cydia", uncheck all boxes, but then select "Install Custom Bundle". Download and select http://cache.saurik.com/jailbreakqa/cb-399x-1.tgz, which will have almost the exact same effect as my custom rd.tar (it will not delete /etc/launchd.conf, but will replace it with an empty file). Again, this will also disable Corona, so you may need to boot your device after this change using redsn0w.

(30 Dec '11, 08:14) saurik ♦♦ saurik's gravatar image

SO should we incase, reinstall 0.9.399x THAT didnt had any conflict with extensions. Btw i was on [[REDACTED - please don't talk about pirate repositories here]] repo, and was just going thru ,and reinstalling my previous packages(i had to restore). I was queuing them up. (i did lockdown, LSrotator,mail enhancer,mobile terminal,Mobishield, multiIconMover,) When i rebooted, The phone didnt reboot., SO their might be conflict btw one of these and Mobile Substrate.

(30 Dec '11, 14:00) Atonned Atonned's gravatar image

Go to this link: follow every instruction (create a RAMDISK, etc etc)

http://msftguy.blogspot.com/2010/11/booting-ssh-ramdisk-on-new-devices.html

(30 Dec '11, 16:52) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

nice.... thank you

(30 Dec '11, 16:53) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Today, I updated my iPad 2 on 4.3.3 (via jailbreakme) with mobile substrate/ui kit and am having the exact same prob...nothing but bootlogo. Never a prob before today. saurik, I read your 0-5 above and it doesn't apply to me. I'm trying to save 500 photos that haven't been backed up. Does anyone have any ideas on how to get in? I'm trying to try the /etc/launchd.conf thing or maybe reinstall an earlier MS.

link

answered 29 Dec '11, 23:43

robobob's gravatar image

robobob
111

can you email me rob

(29 Dec '11, 23:59) exmurderblah exmurderblah's gravatar image

redsn0w isn't compatible with iPad 2 so I'm not sure there's any solution if you can't connect to the device over SSH (or over USB with iExplorer). :(

(30 Dec '11, 08:45) britta ♦♦ britta's gravatar image

Thanks for your response britta. Please if you don't mind....... 1. Do you see any reason that this ramdisk ssh WOULDN'T work with my ipad ? http://modmyi.com/forums/general/758778-emergency-ssh-access-using-pwnd-dfu-mode-ramdisk.html 2. IF it doesn't..I have the shsh's and blobs from earlier (don't know how they work, but I'll find out)..can I somehow install these in the condition it's in?.. If I must start over I will. I just need to get this device started somehow, but I still would like it to be jailbroken.

(30 Dec '11, 10:11) robobob robobob's gravatar image

I don't think that method works with A5 devices. If you have SHSH for 4.3.3 for your iPad, you may be able to restore. Here's a guide to using SHSH blobs - the thing is that this will only work on a WiFi-only iPad 2, and it might not work even then. For an iPad 2 GSM/CDMA, you can try using TinyCFW.

(30 Dec '11, 10:38) britta ♦♦ britta's gravatar image

Thanks kindly britta..I'll try both when I get home.

(30 Dec '11, 10:43) robobob robobob's gravatar image

Hello. Just found this, would it be at all helpful if I posted a list of my installed tweaks that rely on MS? I have an IPT4, 4.3.3 JB W/ RS 0.9.6rc16, and I'm not experiencing any issues.

At the very least, it could isolate things that aren't the issue...

(30 Dec '11, 12:42) 3l3tric 3l3tric's gravatar image

ipad2 and Iphone 4S are not vunerable to limera1n exploit, so you cant do a RAMDISK SSH to access your device and erase launchd.conf.

Unfortunelly, in your case, I think a restore is the solution. Sorry.

I have an ipad2 4.3.3 and I updated to Mobile Substrate 0.9.3995. No problems at all. The problem was 0.9.3993

(31 Dec '11, 17:19) Camilo Rodrigues Camilo%20Rodrigues's gravatar image

Hello, I had the same problem, I updated the cydia "essentials" and now im stuck at the apple logo, my iphone 4 is jailbraked using the website jailbreakme.com. I am having a really hard time understanding how to fix it,I do not want to restore and update :S

Some people are saying something about "RAMDISK SSH", some about "redsnow" im really confused as I am not good at software stuff, I tried using the redsnow step but when i get to the screen I cannot click the "next" button despite the iphone being turned off and plugged in, and after I do the DFU method is not doing anything either. I wish someone could help me, or explain in more detail?

Thanks in advance, I appreciate your help

link

answered 30 Dec '11, 16:40

quewea's gravatar image

quewea
111

(On IRC, we fixed this initial problem with the "Next" button being greyed out by setting the right compatibility mode for redsn0w as described on this page. The device successfully booted up after following the instructions.)

(30 Dec '11, 17:18) britta ♦♦ britta's gravatar image

After a long process of elimination, we figured out that the "OS7" Dreamboard theme was probably causing this problem.

(30 Dec '11, 19:46) britta ♦♦ britta's gravatar image

Hi,

is it necessary to update mobile subtrate from 0.9.3901 to 0.9.3995 if I am on a ipod touch with 4.3.3 jb redsn0w 0.9.6rc15? Does it improve anything if I am on 4.3.3 and not iOS 5? After hearing about all those problems I am not sure if I should update to 3995.

sry for bad english

link

answered 05 Jan '12, 12:28

Freaxx's gravatar image

Freaxx
112

edited 05 Jan '12, 12:37

Hello...

I updated my Cydia Packages yesterday, (Cydia Installer, MobileSubstrate and 3 other), rebooted my device and now It's stuck on Apple Boot Logo for Hours, tried Hard Reset 4 times ;( No results...

I Have an iPad 2 64 GB Wi-Fi, running on 4.3.3 with Jailbreakme 3.0.

I figured out I cant use any of the Methods above (The saurik's one with Redsn0w and Camilio's one with RAMDISK) because I have a A5 CHIP.

I can't afford to loose my data, and I dont have any Backup. But I can restore once I get my data back and wait for 5.0.1 Jailbreak.

I need help guys.

Thank You

link

answered 07 Jan '12, 07:56

lunatik88's gravatar image

lunatik88
111

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×472
×295
×220

Asked: 28 Dec '11, 01:14

Seen: 26,592 times

Last updated: 24 Nov '13, 22:10

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.