Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.0-8.1 is released (instructions) - see /r/jailbreak on Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

Getting "memory exhausted" error messgae (window popu) during curtom ios 5.0.1 ipsw creation (for iPhone 4 gsm) via redsn0w 0.9.10b1. what is that?

alt text

asked 27 Dec '11, 07:52

syler's gravatar image

syler
717212


Have you closed all other programs to see if this works for you. Sounds like you don't have enough RAM.

link

answered 27 Dec '11, 19:52

Phatknugz's gravatar image

Phatknugz
9611418

I am getting the same error. Using XP. Quadcore /w 10GB ram and disabled all unnecessary processes/ Rebooted many time. Same error.

(28 Dec '11, 08:55) beenie beenie's gravatar image

I am also getting this error. Beta 2 version of redsn0w does the exact same thing. I am wondering if it could be a corrupt IPSW file. Maybe the stock IPSW didn't download properly and became corrupted. I don't have time at the moment to re-download. Have you tried re-downloaded the stock IPSW? Give it a shot and let me know if it works. Thanks.

link

answered 28 Dec '11, 09:51

caracasmc's gravatar image

caracasmc
111

I found solution. I "shortened" path to redsnow.exe and this fixed the issue

link

answered 28 Dec '11, 09:54

syler's gravatar image

syler
717212

what do you mean you shortened the path?

(28 Dec '11, 09:56) Phatknugz Phatknugz's gravatar image

@Phatknugz the path to this file was very long: smth like C:\Users\user\Desktop\redsnow 0.9.10b\redsnow\redsnow.exe And the ipsw was in C:\Users\user\Desktop\ I don't know how this related with error message, but when I moved all contents to C:\Users\user\Desktop\redsnow it fixed problem.

(28 Dec '11, 10:03) syler syler's gravatar image

I had to use a different computer and it worked. Try putting all the files into one folder. Put the folder on the desktop.

(28 Dec '11, 10:36) caracasmc caracasmc's gravatar image

:O it worked! Thank you syler! :D

(24 Jun '12, 13:16) CoreyD97 CoreyD97's gravatar image

I ended up using Sn0wbreeze to do the custom IPSW to preserve my baseband. Then I booted tethered, added Corona, then added Ultrasn0w. I'm now working perfectly fine.

link

answered 28 Dec '11, 23:46

Beastmaster's gravatar image

Beastmaster
1

That is a good way to do it. I used a different solution. First I tried to compile the file using my work pc, which also uses xp. I got the exact same error: memory exhausted. I then tried it on somene's windows 7 pc, and it compiled without a problem. Using a memory stock I transferred the new file back to my old pc and completed the upgrade. Everything is working now except for knowing all of the Cydia programs that HAD been installed. The most imortant ones I remember but some handy ones are gone now.

link

answered 29 Dec '11, 06:39

beenie's gravatar image

beenie
111

I had the same problem. Redsn0w seems to have compatibility with (some?) XP systems. Didn't have access to a Windows 7 machine, so I installed a Win 7 30 day trial in a virtual machine, created the custom IPSW in the VM, then returned to XP for the install.

BTW, Memory Exhausted is nearly always a bug; corrupt program or compatibility issue, not a shortage of RAM - unless you've played with the Page File settings, you usually have several GB of virtual mem.

link

answered 24 Jun '12, 17:25

mikewsw17's gravatar image

mikewsw17
1.7k26938

edited 24 Jun '12, 17:26

This was my solution to the problem. Fist I closed all the programs I had opened then restarted the computer, after the computer rebooted I only opened redsn0w, went into "Extras" and selected "Custom IPSW". Also when I searched for the file it looked like this: "iPhone3,1_5.0.1_9A405_Restore (2)". So what I did was delete"(2)" and then it looked like this: "iPhone3,1_5.0.1_9A405_Restore". The process started and took a very long time from about 1/2 an hour to 1 hour. By the way I have an acer aspire one, windows 7, 32 bit.

link

answered 17 Aug '12, 17:37

eluzi's gravatar image

eluzi
111

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,492
×1,560
×517
×73

Asked: 27 Dec '11, 07:52

Seen: 24,007 times

Last updated: 17 Aug '12, 17:37

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.