Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Today my JB Iphone 4 froze up on me at work. So when I got home, I had to do a restore through Itunes and unfortunately am now running 5.0.1. I think I bumbled my way through JBing it successfully with Redsnow 9.9. It says it's operating under 5.0.1 in the settings, but I do have the Cydia app on there. The problem now is that it flashes when I try to open it. I recall when I originally JB'd the phone in IOS 5.0 that I had to run the tethered boot and that solved the flashing Cydia icon problem. When I try to do that now, it comepletes it's course but at the end I get a message in Redsnow saying it's an 'unrecognized build.' Is there any way to work around this? Thanks in advance...I am following the instructions on JBing the 5.0.1, but this last hurdle makes it all unusable if I can't open Cydia.

asked 16 Nov '11, 21:35

MeredithJL's gravatar image


edited 16 Nov '11, 21:57

britta's gravatar image


Make sure you specify the 5.0 IPSW, not the 5.0.1 IPSW.


answered 16 Nov '11, 21:37

lambo_man_r2's gravatar image


I did that when I specified the IPSW for it to reference while it was running the jailbreak. It goes through all that fine. It's when I click on 'just boot tethered' that I run into problems at the end, with the 'unrecognized build' notice....

(16 Nov '11, 21:50) MeredithJL MeredithJL's gravatar image

Are you using the latest version of redsn0w from here (redsn0w 0.9.9b8)?

(16 Nov '11, 21:56) britta britta's gravatar image

Yes I am. I think I have solved it. I had specified the IPSW the first time to run the JB, but I didn't realize I needed to also specify it the second time before I clicked on 'just tether.' I just tried it again and specified 5.0 for the tether boot, and Cydia opens now. Thanks for prodding me to think this through a little more clearly, Lambo man :)

(16 Nov '11, 22:03) MeredithJL MeredithJL's gravatar image

It is also possible that you are not using redsn0w 0.9.9b8 but a previous one. Make sure you are using ios 5.0 (in Select IPSW).


answered 17 Nov '11, 07:11

pdnked's gravatar image


sorry but i am confused, i am using iOS 5.0.1 and i am trying to jailbreak with redsn0w 9.9b8... should i download 5.0 and select that? because i keep getting the error mentioned above, and i cant open cydia or safari


answered 18 Nov '11, 13:54

brad511's gravatar image


Please help same story jus bit different my phone is on ios5.0.1 and is stuck on the activation setup it's locked to a network not from my country when I try to jail break I get " unrecognised build fingerprint error in redsnow and when I point to firmware iOS 5.0.1 it says this version of redsnow does not support 5.0.1 I'm using redsnow 9.9.b8


answered 23 Nov '11, 15:23

Konvict_'s gravatar image


You need to point redsn0w at the 5.0 IPSW to jailbreak 5.0.1

(23 Nov '11, 15:42) cybr1d ♦ cybr1d's gravatar image

@konvict_ well i got through with mine. your using the correct redsn0w, but when selecting the ipsw file, select 5.0, run red snow -> select the just boot option -> enter DFU mode -> shortly after you should hear the connect noise it makes then you'd see the pineapple logo. let it load up and your all set

make sure the phone is off before attempting it.


answered 23 Nov '11, 15:51

brad511's gravatar image


Hey so I have an iPhone 4 with 5.0.1 and I seemed to have been able to download cydia but I can't use it yet because it's locked to rogers and my sim card is fido therefore I don't have internet connection until I unlock it..but I can't unlock it until I launch cydia. does anyone know how to get around this?

Thank you in advance!


answered 26 Dec '11, 16:44

11ad22's gravatar image


  1. You can connect using wifi instead of mobile internet.

  2. If you restored using stock 5.0.1, there is no unlock.

  3. Contact rogers to inquire about official unlocking.

  4. Next time, create a new thread if you have a question.

(26 Dec '11, 18:26) justinred ♦ justinred's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 16 Nov '11, 21:35

Seen: 35,266 times

Last updated: 16 Feb '12, 16:55

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.