Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I used greenpois0n to jailbreak my 3GS on 4.2.1, and backed up my sources and packages with PKGbackup. When I went to restore this data, it said everything was restored, and almost all of my apps were restored to my springboard. However, when I went into Cydia trying to download another tweak, all of my packages and sources were gone, and they won't reappear by clicking reload sources (well, because there aren't any to refresh). I tried re-installing my sources, but when I did, cydia crashed out to the springboard.

I have already tried respringing, rebooting, and rejailbreaking with a newer version of greenpois0n. None of these solutions have worked. I have found several people on different forums and no one I have talked to can figure it out.

How can I fix this problem? Is there any way?

asked 07 Feb '11, 20:36

daniellivsey's gravatar image

daniellivsey
55339

edited 07 Feb '11, 20:57


According to @saurik, the guy behind Cydia, this tweet explains how you should fix a "blank" Cydia:

@saurik: Ok, and ZodTTD now has fixed it /again/. If your Cydia is "blank" just go to Changes, click Refresh, and then restart Cydia: no big deal. :(

link

answered 08 Feb '11, 14:47

gomanski's gravatar image

gomanski
2.3k78

I would try restarting first if that does not work, restore then rejailbreak

link

answered 07 Feb '11, 20:47

Awmusic12635's gravatar image

Awmusic12635
1.8k9618

Try, restoring then rejailbreaking then installing Cydia with the newest redsn0w from HERE

link

answered 07 Feb '11, 21:00

Awmusic12635's gravatar image

Awmusic12635
1.8k9618

I figured it out. I just reinstalled with the most recent version, and instead of viewing as a user, I set the settings to developer. I don't know why this would change anything, or if I just got lucky, but everything is working great for me now!

link

answered 14 Feb '11, 17:37

daniellivsey's gravatar image

daniellivsey
55339

Delete all files in /var/lib/dpkg/updates You must have resprung when Cydia was installing/downloading, or stuck.

link

answered 14 Feb '11, 18:52

daveamato's gravatar image

daveamato
318411

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,351
×1,847
×1,010
×181

Asked: 07 Feb '11, 20:36

Seen: 7,943 times

Last updated: 14 Feb '11, 18:52

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.