Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

There is no jailbreak for iOS 8 yet. How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

So about a week ago i jail-broke my iPhone 4 running on ios5 with redsn0w everything went well into i started to install cydia apps such as sbsettings, bytafont, unlimtones, bitesms beta, all these apps download but there usually a white icon ? i have to keep respringing into they go back to normal ? Today my friend updated to ios5 at my house and same issue , any one else having this problem ? Or any fixes or something ?

asked 06 Nov '11, 23:10

odhigh's gravatar image

odhigh
361531560

Also, do either or both of you have semitether installed?

(07 Nov '11, 03:25) britta ♦♦ britta's gravatar image

Yes both of us have semitether installed

(10 Nov '11, 02:57) odhigh odhigh's gravatar image

12next »

This is a cache issue - usually respringing or rebooting fixes it. I think this is a bug with some package; I forget which one; it'll probably be updated soon. See this question for another similar experience.

link

answered 06 Nov '11, 23:37

britta's gravatar image

britta ♦♦
24.0k115134

edited 06 Nov '11, 23:37

For anyone with odhigh's white apps problem, it may be helpful for finding the source of the problem if you guys answer a few questions:

Have you installed the semitether package from BigBoss? Did the white apps happen before or after you installed semitether?

Can you open up Cydia and search for "UIKit Tools" and tell me what version you have installed? (This is listed on top of the package page - for example, mine says 1.1.1.) Have you updated it since you had the white apps issue, and if you have updated it, is the issue still happening?

link

answered 09 Nov '11, 21:14

britta's gravatar image

britta ♦♦
24.0k115134

edited 09 Nov '11, 21:14

I just restored my phone last night but before that I did get these mysterious white apps. The ones affected seem to be random, spanning from stock Apple apps to downloaded and Cydia apps. A respring always fixed em.

I had no beta sources (semi tether, intelliscreen etc) installed, with UIKit Tools version 1.1.0.

Since restoring [only 20 hours ago] I haven't seen it happen yet. (Though my current UIKit Tools version is still 1.1 with no Cydia offering no update)

(09 Nov '11, 21:42) cybr1d ♦ cybr1d's gravatar image

Um well i have a few sources more than a few i would say , and yes both of us do have semi-tethered installed from bigboss i don't recall if it was before or after , my UIKIT TOOLS IS version " 1.1.2 " and into now i still have the white icons problem good thing is i get my iphone 4S soon so when i jailbreak i won't install semi-tethered and see if I'm still having that issue

(10 Nov '11, 03:00) odhigh odhigh's gravatar image

I'm running 5.0.1 on a iphone 4 and the only jailbreak app with an icon is cydia. SBSettings, Activator, Semitether, iFile and xBackup shows only a white icon. UIKit Tools version ist 1.1.2. A fix or work around would be nice... :)

(12 Nov '11, 07:46) MrWGT MrWGT's gravatar image

@MrWGT this is an icon cache problem probably related to the UIKit Tools package from Semitether. One way to fix the issue temporarily is by installing and using an app from the BigBoss repo called "Respring".

(12 Nov '11, 11:28) Leslien Leslien's gravatar image

Same problem here with white icons. I do not have semitether installed, running 5.0.1 on an iPhone 4. Only the Cydia installed apps are doing it. Pdanet, Wififofum, etc.. I have about six of them all white icons, Cydia only packages. I noticed this when I installed 5.0, that it started doing this. 5.0.1 is doing the same thing. I was on 4.3.5 with no white icon issues. A reboot sometimes fixes the problem but it always ends up going back to white Cydia icons after awhile.

(12 Nov '11, 20:13) Maverick3837 Maverick3837's gravatar image

Make sure you are booting tethered.

link

answered 06 Nov '11, 23:23

JonSeals's gravatar image

JonSeals ♦
15.9k471763

(I think they are booting tethered, since if they had these installed and weren't booting tethered, they'd be stuck at the Apple logo...and they say that respringing eventually gets the icons back to normal.)

(06 Nov '11, 23:39) britta ♦♦ britta's gravatar image

Yes i am booting tether if i wasn't cydia wouldn't open duh , and i see some of the icons stay normal like activator and the sbsettings icon other's go on and off as there please but eh hope they fix this problem really annoying >.<

(06 Nov '11, 23:43) odhigh odhigh's gravatar image

Semi tethered icon was white though I boot tethered it so I just respiring and BAMPUESHAMWHOOHOO fixed.

link

answered 07 Nov '11, 00:36

sfiq12's gravatar image

sfiq12
4929717108

Wow thank gawd i'm not alone.. I just got the same problem.. my cydia app is all white.

I have a iphone 4 iOS 5 windows OS, used redsn0w_win_0.9.9b7. The jailbreak went through perfectly but cant open cydia.. its been 2 years since i last jail broke my iphone 3g so im a bit rusty..

link

answered 07 Nov '11, 07:33

mykeeX's gravatar image

mykeeX
1

I fixed it... pretty much rebooting in DFU mode fixes it...

(07 Nov '11, 07:55) mykeeX mykeeX's gravatar image

You need to boot tethered using redsn0w.

(07 Nov '11, 08:51) britta ♦♦ britta's gravatar image

Yep.. Britta thats what i did.. I went into cydia and went through all the updates... Then installed a app which required my phone to boot.. and was sitting at the white apple screen for like 45 mins.. couldn't power my phone off.. so i went through the steps again to boot in tethered mode, with my phone on and it worked.. however it booted in safe mode... Kinda not looking forward in rebooting my phone again to get out of safe mode... my luck it will melt in my hand..

(07 Nov '11, 09:03) mykeeX mykeeX's gravatar image

You usually don't need to reboot to get rid of Safe Mode - just respring and hope for the best. If it persists, try uninstalling any recently-installed extensions, since they might be causing the problem.

(07 Nov '11, 16:53) britta ♦♦ britta's gravatar image

respringing usally fixes it, booting tethered does nothing every app you dl from cydia i get is a white icon and the next page i get these icons with names " diagnostic " and the sb setting icon and other shit that shouldn't appear and respringing fixes it FML .

(08 Nov '11, 02:56) odhigh odhigh's gravatar image

odhigh: Your problem and mykeeX's problem are different - you have a white apps issue while they have a tethered boot issue. :)

(09 Nov '11, 21:03) britta ♦♦ britta's gravatar image

Go to Cydia go to manage, packages, then make sure it says expert at the top right corner if not press the button that says simple and then it should say expert. Then find and reinstall the package "UIKit Tools" Then exit Cydia and respring.

link

answered 23 Nov '11, 20:03

dpelletier360's gravatar image

dpelletier360
422

Tried it and it did not work. Some (always different icons) or all icons are white after a respring.

(24 Nov '11, 13:06) MrWGT MrWGT's gravatar image

Reading these comments seems to indicate the issue is related to device model and/or what apps are installed. The fix may include reinstalling/updating UIKit Tools, respringing or rebooting (semi-tethered). Or simply refreshing the icon cache.

1 - Search for 'cache' in Cydia (enable expert mode first), see what usefull tools you find. ("gUiCache", for example...)

2 - While in Cydia, reinstall UiKit Tools.

3 - (install Aptitude) Open a terminal (on your iDevice, MobileTerminal, for example) and type:

aptitude update

uicache update

4 - Respring (i use Activator: "On Home Screen" > "Icon Spread")

link

answered 14 Dec '11, 18:01

lolbob's gravatar image

lolbob
112

edited 14 Dec '11, 19:26

First, log into the command-line as mobile user with the following:

  • ssh mobile@<your_device_ip>
  • Just open MobileTerminal. No typing su

Secondly, run the command uicache. This is what might happen:

  • No matching processes... -- Your cache is already refreshed. Things should be fine. If not, post a comment;
  • No output -- The cache just got refreshed. Things should be fine. If not, post a comment;
  • (insert other message here) -- Something bad occured, try rebooting!

You can skip all of these steps by respringing with BigBoss's Respring app, or via SBSettings. They automatically refresh the cache.

link

answered 14 Dec '11, 18:48

matoetheiostream's gravatar image

matoetheiostream
73340652

no piracy please

link

answered 14 Dec '11, 20:53

ZiG's gravatar image

ZiG
61

edited 14 Dec '11, 22:50

theiphoneguy's gravatar image

theiphoneguy ♦
37.6k55018

Download "respring" from cydia which worked for me.

link

answered 25 Dec '11, 06:14

chandannalam's gravatar image

chandannalam
111

I tried it some time ago but it did not work for me.

But after some of the last updates installed from cydia the problem disappeared. Don't know if it was a "special app" but i think it was after a activator update?!?

(25 Dec '11, 09:24) MrWGT MrWGT's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,837
×595

Asked: 06 Nov '11, 23:10

Seen: 34,861 times

Last updated: 14 Mar '12, 03:51

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.