Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

Basically the title says it all. I keep getting an itunes error 2001 when trying to restore to a stock 5.0 ipsw on a 3GS. Sometimes i get error 1611 if im in DFU. Any advice?

asked 03 Nov '11, 22:05

ChaoticMayhem65's gravatar image

ChaoticMayhem65
14117422

edited 05 Nov '11, 18:13

britta's gravatar image

britta ♦♦
23.6k104933


Just check the iphonewiki and see if that helps you. Scroll down to '20xx errors' and have a read

link

answered 03 Nov '11, 22:55

venusanann's gravatar image

venusanann
13.3k11618

it didn't

(04 Nov '11, 00:32) ChaoticMayhem65 ChaoticMayhem65's gravatar image

thats the first place i always check with itunes errors

(04 Nov '11, 00:33) ChaoticMayhem65 ChaoticMayhem65's gravatar image

First reboot the computer. Then if it still fails, reinstall itunes, thats a DFU driver error (drivers provided with itunes)

link

answered 04 Nov '11, 00:50

theiphoneguy's gravatar image

theiphoneguy ♦
36.9k54718

yea ive tried on many computers already. A couple windows 7 machines, a windows xp machine, a hackintosh snow leopard machine and my trusty Mac book air. and all error out the same.

(04 Nov '11, 02:01) ChaoticMayhem65 ChaoticMayhem65's gravatar image

And by the way this 3GS came from a friend of mine who works at apple. It was a warranty exchange.

(04 Nov '11, 02:03) ChaoticMayhem65 ChaoticMayhem65's gravatar image

Have you tried installing the ipad baseband at any point? If so and you cant get into settings>general>about, pop the sim tray out. Has the serial number on the sim tray. What is just the first FIVE of the serial?

(04 Nov '11, 11:56) theiphoneguy ♦ theiphoneguy's gravatar image

To be honest with you i dont know the history of the phone because i got it from a buddy of mine who works at apple and it was a warranty exchange. The phone has been in recovery mode every since we have had it.

(04 Nov '11, 14:09) ChaoticMayhem65 ChaoticMayhem65's gravatar image

So i dont know if it ever was flashed with the ipad baseband. Those were my first thoughts also.

(04 Nov '11, 14:09) ChaoticMayhem65 ChaoticMayhem65's gravatar image

So any ideas anyone? Or is this thing permanently bricked? Im starting to lean toward the permanently bricked conclusion.

(05 Nov '11, 15:10) ChaoticMayhem65 ChaoticMayhem65's gravatar image

Try restoring to custom ipsw in Pwned dfu mode

(05 Nov '11, 15:17) venusanann venusanann's gravatar image

Tried that but i forgot what error code it gave me. It might have been 1611. Does the Redsnow 9.9B5 custom IPSW count?

(05 Nov '11, 15:29) ChaoticMayhem65 ChaoticMayhem65's gravatar image

Im sorry i mean Redsnow 9.9B8

(05 Nov '11, 15:32) ChaoticMayhem65 ChaoticMayhem65's gravatar image

whats the actual state of the iphone now?

(05 Nov '11, 15:37) venusanann venusanann's gravatar image

Its in recovery

(05 Nov '11, 15:45) ChaoticMayhem65 ChaoticMayhem65's gravatar image

ok my mistake. Custom 5.0 IPSW created with redsnow9.9B8 in Pwned DFU immediatly errors out with 2001.

(05 Nov '11, 15:49) ChaoticMayhem65 ChaoticMayhem65's gravatar image

And a custom Built snowbreeze 4.1 IPSW in Pwned DFU throws a 1611

(05 Nov '11, 16:12) ChaoticMayhem65 ChaoticMayhem65's gravatar image

is the stock ipsw from a reliable source?

(05 Nov '11, 16:18) venusanann venusanann's gravatar image

Yup. Directly from apple

(05 Nov '11, 18:08) ChaoticMayhem65 ChaoticMayhem65's gravatar image

2001 error is a DFU boot error. Easiest fix for 2001 error is one of two things. Exploit the device, unplug after stage 1 before stage 2 and restore the device with CUSTOM FIRMWARE or put the device into custom DFU then start a restore, the moment the screen goes white kill iTunes process and relaunch and restore the firmware with CUSTOM FIRMWARE.

-Yoda

link

answered 01 Mar '12, 02:57

JailbrokenJedi's gravatar image

JailbrokenJedi
112

Interesting. So this error has been resolved, or seen before? I will have to try this soon. Now the hard part will be to find exactly which logicboard was giving me this error again (I have a few).

(02 Mar '12, 22:38) ChaoticMayhem65 ChaoticMayhem65's gravatar image

Sorry but this is still a no go and i still get error 2001

(05 Mar '12, 00:16) ChaoticMayhem65 ChaoticMayhem65's gravatar image

Your custom firmware must have the blobs and apticket stitched to it then pop into pwned dfu and restore ios 5 and up requires this

link

answered 03 Mar '12, 07:35

Crowie85's gravatar image

Crowie85
349128

Since no one else mentioned it, will throw this in there: Try restoring to iOS 5.0.1 (while you can.. this week). Either use stock ipsw as provided by Apple, or if you need to for unlocking purposes or wish to protect your baseband (modem firmware), build a custom ipsw using sn0wbreeze for pc or pwnage tool for mac.

You can get everything you will need here: http://jailbreakqa.com/links

Your errors are more than likely caused by not being in pwn'd DFU. Start with fresh DFU and then proceed to pwn'd DFU, then shift (or option on mac) + restore, select desired (custom) ipsw.

link

answered 05 Mar '12, 02:10

JuergenWest's gravatar image

JuergenWest ♦
11.1k352344

Well thanks for your input but its not because im not in DFU or pwned DFU, i know how to get into both easily. I've tried stock ipsw's, custom ipsw's, you name it and ive tried it. I think this board is toast. But i think i knew this a long time ago.I was just board so i thought id give it another go.

(05 Mar '12, 11:43) ChaoticMayhem65 ChaoticMayhem65's gravatar image

A common troubleshooting mistake is that there are several possible modes that report as DFU, and that the phone started in the wrong one.

Did you try the suggestion above? eg iOS 5.0.1? (as opposed to 5.0).

If you did in fact try all this then yes, I would agree you have a board level error. However rule out everything else first, eg dock connector, usb cable, usb port, different computer, ipsw 5.0.1, etc

(05 Mar '12, 15:19) JuergenWest ♦ JuergenWest's gravatar image

Yes i have tried 5.0.1. and ive swapped the board into a fully functional 3gs, resulting in the same error.

(05 Mar '12, 18:04) ChaoticMayhem65 ChaoticMayhem65's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×907
×721
×584
×53

Asked: 03 Nov '11, 22:05

Seen: 17,186 times

Last updated: 05 Mar '12, 18:04

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.