Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.x is released but Cydia Substrate is not updated for it - see Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

I used RedSn0w 0.9.8b7b to jailbreak (tethered), tried restoring from backup (from my previous ipod) in itunes, although it didn't do a full restore, it managed to transfer most of my settings, but not all. I also restored cydia with backup with success. The jailbreak seemed to have worked.

Then my ipod shut down randomly and has not been able to boot up since. When I plug it in to my computer, I get the 'in recovery, needs to be updated' message. but, sometimes it's profile will show up in itunes.

so far, I've tried:

  • using Redsn0w to boot tethered.
  • using Redsn0w to put in pwned dfu.
  • RecBoot to try and kick it out of recovery mode. tinyumbrella to try and kick it out.
  • restoring using clean 4.3.5 ipsw in itunes.
  • hard reset.
  • pressing home button while plugging into computer.
  • restarted computer & itunes.
  • regular dfu mode.
  • restoring using other computers.

all with no success. I'm stumped. ?_?

just recently tried to restore using 5.0 firmware and even that didn't work. also tried downgrading itunes to 10.4 and restoring with it.

I still have warranty left, but I can't take it in jailbroken- obviously. I am able to ssh into it still… would I be able to clear the jb out that way at all?


Place in DFU mode and restore to 5.0. Set up as new device. Jailbreak using redsn0w 9.9b7. Just boot tethered on every restart.

link

answered 27 Oct '11, 23:20

justinred's gravatar image

justinred ♦
46.6k74217

do as @justinred says but before you do make sure that you open up tinyumbrella, uncheck "set hosts to cydia on exit" and "request shsh from cydia" then close tinyumbrella.

link

answered 27 Oct '11, 23:23

therealcmac's gravatar image

therealcmac
590221032

I'm assuming it's already in DFU mode-- black screen, but is recognized in itunes. when I've tried to put it in pwned dfu mode via redsn0w, I get 'unexpected error'. I've tried a clean restore to 5.0 and it gets rejected... and with tinyumbrella server running I get error 1600.

(27 Oct '11, 23:29) n-senada n-senada's gravatar image
1

as therealcmac said, clean your host file and close timyumbrella when restoring to 5.0 since apple is still signing 5.0. You dont need pwned dfu when restoring to 5.0 ofw. Just regular dfu will do especially when device is not recognized by computer.

(27 Oct '11, 23:37) justinred ♦ justinred's gravatar image
1

oh wow, success! after thinking I exhausted every option... all I ended up doing was opening up tinyumbrella, made sure the two boxes were unchecked, closed, back to itunes and it was able to restore to 5.0. thanks a lot guys!

(27 Oct '11, 23:43) n-senada n-senada's gravatar image
1

no problemo

(27 Oct '11, 23:46) therealcmac therealcmac's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,555
×1,365
×1,001
×597
×516
×269
×106
×105
×49
×10

Asked: 27 Oct '11, 23:15

Seen: 6,304 times

Last updated: 27 Oct '11, 23:46

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.