Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.x is released, still early stage, mostly for developers - see Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

iPhone 4 4.3.3 stock

I want to FIX recovery using redsn0w... but just that! I want to jailbreak using jailbreakme.

I DONT want to hacktivate and it is not OK for redsn0w doing so and having me to undo it and so. No hacktivation for me. Nor installing Cydia or doing anything this time. Just fixing recovery. Not that big deal I think? This time, all I want to use redsn0w for is fixing recovery loop, NOTHING else is allowed.

Is this the proper way to do so?

/Applications/redsn0w.app/Contents/MacOS/redsn0w -n -K -S -U

???

Just fixing recovery, NOTHING ELSE!

(I like redsn0w but this time I only want to fix recovery and theres no such simple tool that only does that)

update: Doing this in DFU mode... my iPhone seems to freeze with this nerdy command-line mode... lines are not moving nor is recovery fixed...

What to do? I want to jailbreak using jailbreakme!!

I dont want to have my filesystem "stashed" or even touched by this means, I want to purely use jailbreakme!! Why isn't there a simple tool that doesn't do anything else than fixing recovery!!

UPDATE I tried fixrecovery43 -- unfortunately it didnt work. Its known that its usually not working

asked 10 Sep '11, 11:31

deleteme2's gravatar image

deleteme2
(suspended)

closed 28 Nov '13, 01:35

spockers's gravatar image

spockers ♦♦
60.7k348751

The question has been closed for being "urgent no longer" by spockers, 28 Nov '13, 01:35


It just occured to me that you havn't mentioned simply plugging it into Tiny Umbrella http://cache.firmwareumbrella.com/downloads/tinyumbrella-5.00.10.exe and using it's "exit recovery" and then "fix recovery" option. That is usually the most cooperative for me.


OR, you could try reinstalling your firmware and preventing the recovery loop from occurring in the first place but following this method:

Use iFaith to create a completely individualised firmwarepackage using your 4.3.3 shsh blobs and a stock download of 4.3.3 firmware: http://www.limera1n.cc/2011/05/ios-433-firmware-ipsw-download-iphone.html. At this point open up Tiny Umbrella, start the TSS server and leave it running in the background.

Then the tricky part starts, follow the steps in Redsnow 0.9.6rc16 https://sites.google.com/a/iphone-dev.com/files/home/redsn0w_win_0.9.6rc16.zip?attredirects=0&d=1 - to put your phone into PWND DFU using the STOCK firmware you initially downloaded, AND THEN shift+restore in iTunes selecting that CUSTOM firmware package you made with iFaith. So long as your host file wasn't as messed as the last girl I saw, u shouldn't get any errors here... :)

When iTunes finishes You may need to reboot, but afterwards you'll be able to run your freshly installed firmware through jailbreakme.com and have it install your cydia as desired.

This may be more than what you want, but it's an option.

link

answered 12 Sep '11, 04:50

christalic's gravatar image

christalic
13613

wikified 26 Sep '11, 08:18

There is such a tool, it's called iREB.

link

answered 10 Sep '11, 12:02

spockers's gravatar image

spockers ♦♦
60.7k348751

iREB has "autoboot true" stuff, thats like "exiting" recovery instead of fixing it. It wouldn't work on 4.3.x I guess so.

(10 Sep '11, 13:18) deleteme2 deleteme2's gravatar image

Not sure if iReb would work at 4.3.3, you can also try FixRecovery43 from here for windows http://cache.firmwareumbrella.com/downloads/fixrecovery-win.zip or here for Mac http://cache.firmwareumbrella.com/downloads/fixrecovery-osx.zip

link

answered 10 Sep '11, 13:09

knightz4u's gravatar image

knightz4u
4.9k91328

I tried it, but unfortunately fixrecovery43 didnt work. iReb seems to have the standard "autoboot true" stuff, thats for exiting recovery, not fixing it, so basically it wouldnt work 4.2.1 and above (and on 4.3.3 of course)

thx anywayz

(10 Sep '11, 13:16) deleteme2 deleteme2's gravatar image

Can we know how you arrived at the recovery loop at 4.3.3 and what you're trying to accomplish, we might be able to give some good ideas.

(10 Sep '11, 13:34) knightz4u knightz4u's gravatar image

Well. I just did a restore to a stock 4.3.3 firmware, and I used SHSH (TinyUmbrella), that's why I got in recovery loop. I solved this using a custom firmware, but I'm wondering if there would be a way to fix recovery so I could try jailbreakme, instead of a custom firmware.

Until that I'm using a cfw because I'm fine with that I just would like to try out jailbreakme... if I can...

(10 Sep '11, 14:39) deleteme2 deleteme2's gravatar image

Lol build a custom with iFaith and then use JMB3

(10 Sep '11, 14:59) cybr1d ♦ cybr1d's gravatar image

Well. I'm not sure if that's a good idea. If I use jailbreakme, I want my iPhone to be purely unionfs, so not using stashfs (custom firmware and other jb tools use that)

I would like to just try that out.

By the way I'm ok with a cfw... I'm just interested in jbme, too. I just need to figure out a working way to fix recovery on 4.3.3. SERIOUSLY!!! All the fixrecovery methods are broken on 4.3.x... I CANT fix it without hacktivating it or stashing it...

(10 Sep '11, 15:13) deleteme2 deleteme2's gravatar image

IFaith firmware is stock, u should be fine. And I just used fixrecovery43 on 4.3.3 not too long ago. I know it works it may just take a few tries

(10 Sep '11, 15:40) cybr1d ♦ cybr1d's gravatar image

are you getting the "recovery loop" due to 06.15 baseband?

(10 Sep '11, 15:44) therealcmac therealcmac's gravatar image

No. I'm on iPhone 4, and I'm getting the recovery loop due to standard downgrade (TinyUmbrella prevented touching the baseband etc...) bb is same (04.10.01)

(10 Sep '11, 15:47) deleteme2 deleteme2's gravatar image

Use the 'update iPhone 4 bb' option in a TU to avoid that

(10 Sep '11, 15:49) cybr1d ♦ cybr1d's gravatar image

I did that on my previous iPhone 4 (which have been replaced for other reasons (hardware problems)) Even though I don't think that caused the problem since the baseband wasn't updated (it was all the samed) I won't ever use that option again. It was already a refurbished iPhone so who knows what (or who) caused the hardware problem. It's replaced again but I'll want to avoid tinyumbrella's "update baseband" feature.

On the other part --, using it multiples times? That's an interesting thing, I'll see... thanks...

(10 Sep '11, 16:10) deleteme2 deleteme2's gravatar image

ok well it is probably the only way to bypass the 1015 much like custom firmware. but i hear you on being carefull lol

(10 Sep '11, 16:21) therealcmac therealcmac's gravatar image

The update baseband option has nothing to with any failures, it's actually allowing (not hindering) something that it used to. It should only be used by people who do not need an unlock though.

(10 Sep '11, 21:38) knightz4u knightz4u's gravatar image

Which he obviously doesn't since he's already on 4.10.01

(10 Sep '11, 21:48) cybr1d ♦ cybr1d's gravatar image

did you try the downgrade again using the update baseband feature checked? and sometimes you have to use fixrecovery43 a couple times before it works with the 1015 error

link

answered 10 Sep '11, 15:50

therealcmac's gravatar image

therealcmac
590221032

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,479
×1,557
×473
×339

Asked: 10 Sep '11, 11:31

Seen: 16,721 times

Last updated: 28 Nov '13, 01:38

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.