Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Hi. I have been trying to upgrade the baseband of my iphone 3gs (currently running iOS 4.3.3 with baseband 5.16.02) to the iPad 6.15.02 without any success (I know the possible loss of the GPS functionality, but this would not be an issue). I have been trying several tools both on mac and windows (namely PwnageTool 4.1.3 Unlock Edition, PwnageTool 4.3.3, Sn0wbreeze v2.7.3, redsn0w_mac_0.9-1.6rc19). No matter what I do, the result is always that I cannot restore to a custom firmware. I also tried using iReb, but the result was the same (error 1015, if I recall it correctly). And when I tried to use iReb again, the iPhone just restarted normally as nothing had happened.

Actually the first two times I used PwnageTool 4.1.3 Unlock Edition I could restore to a custom firmware with the iPad baseband, but somehow the baseband was not altered and I am still running with 5.16.02.

I am trying to read all the info I can find, but I could not find anything similar to my case. Any idea on what else to try?

asked 30 Jul '11, 01:30

shuusaku's gravatar image


edited 30 Jul '11, 05:00

PS: of course all the proper SHSH blobs are correctly saved both with Cydia and TinyUmbrella.

(30 Jul '11, 01:31) shuusaku shuusaku's gravatar image

Just download Redsnow rc 18 and select only "install ipad baseband" that is assuming you are already jailbroken if not you can also select install cydia, sometimes doing both at the same time does not work so do the jailbreak first and then run redsnow again and just check install ipad baseband. you will need a copy of your 4.3.3 firmware which you can get here if you dont have it yet


answered 30 Jul '11, 01:34

therealcmac's gravatar image


edited 30 Jul '11, 01:36

thanks for the quick reply. Does the phone need to be jailbroken with redsn0w, or it is sufficient to use comex's jailbreakme?

(30 Jul '11, 01:51) shuusaku shuusaku's gravatar image is fine, just run Redsn0w and select ONLY install ipad baseband then, you will then need to download ultrasnow from cydia and install it for service. Make you should think about using iFaith to make a presinged ipsw of 4.3.3 in case you have to restore to 4.3.3 for any reason :)

(30 Jul '11, 01:55) therealcmac therealcmac's gravatar image

Thanks. Unfortunately it seems it is not working, as the iPhone now is stuck with a white screen, and redsn0w is "waiting for reboot"

(30 Jul '11, 02:06) shuusaku shuusaku's gravatar image

(after a manual reboot the iphone is working, but the baseband is still 05.16.02... :( )

(30 Jul '11, 02:10) shuusaku shuusaku's gravatar image

ok, did you already jailbreak with jailbreakme? are you on pc or mac?

(30 Jul '11, 02:10) therealcmac therealcmac's gravatar image

iPhone already jailbroken with jailbreakme (iOS 4.3.3) - I had it jailbroken several months ago with limera1n but after the last restore I preferred jailbreakme.

This time I used redsn0w on mac, but I also have windows running (my previous attempts with sn0wbreeze and iReb were on windows)

(30 Jul '11, 02:15) shuusaku shuusaku's gravatar image

ok no problem, you are on a pc? Make sure you have downloaded the proper ipsw, can you tell me what it says? Also,right click on the redsnow exe file, go to properties, then compatibility mode and check it to run in windows xp service pack 2 mode, then when you start up redsnow RUN IT AS ADMINISTRATOR, try it again

(30 Jul '11, 02:17) therealcmac therealcmac's gravatar image

lol we are typing at the same time :P

(30 Jul '11, 02:18) therealcmac therealcmac's gravatar image

are you using windows for redsn0w?

(30 Jul '11, 02:19) therealcmac therealcmac's gravatar image

Thanks for the replies and for your time. In the meantime I tried the simplest solution: redsn0w once more (on mac, though).

It seemed it had worked (nice running pineapple logo, progress bar, and so on), but right now it is stuck on the white apple logo while rebooting so I do not know whether it actually worked or not.

To answer your questions, I used iPhone2,1_4.3.3_8J2_Restore.ipsw together with iPad1,1_3.2.2_7B500_Restore (pwnage tool; redsn0w is downloading the ipad baseband by itself).

I will wait a little bit longer to see whether the iPhone will properly reboot. If not, I guess I'll try again with redsn0w, this time from Windows.

(30 Jul '11, 02:37) shuusaku shuusaku's gravatar image

ok, ya redsnow will fetch the baseband for you, and on mac you don't need to do anything should go all according to plan. Dont know why it would be stuck on the apple though.

(30 Jul '11, 02:39) therealcmac therealcmac's gravatar image

And snowbreeze or pwnagetool wont work unless you have your 4.3.3 shsh saved and have Tinyumbrella running its TSS server since apple does not sign 4.3.3 anymore

(30 Jul '11, 02:44) therealcmac therealcmac's gravatar image

No idea :-) it is the first time for me too.

Anyhow, I am trying to put the phone in recovery mode, and then kick it out with tinyumbrella or similar tool. I'll let you know.

Eventually I'll try to jailbreak it directly with redsn0w.

I'll keep you updated

(30 Jul '11, 02:44) shuusaku shuusaku's gravatar image

why recovery mode? did the phone boot after redsnow?

(30 Jul '11, 02:46) therealcmac therealcmac's gravatar image

are you selecting the proper bootrom version?

(30 Jul '11, 02:48) therealcmac therealcmac's gravatar image

that's the problem; it did not reboot (It got stuck with the apple white logo after redsn0w)

Now there is a new problem: after using "fix recovery" in tinyumbrella, the iphone almost rebooted with greenp0ison (which I had done long time ago, I guess); however it gave 4 errors (unable to find gBdevList, fs_mount, fs_umount, fs_load_file) and stopped.

I might need a new phone :-)

(30 Jul '11, 02:52) shuusaku shuusaku's gravatar image

proper bootrom version? as far as I know, yes.

(30 Jul '11, 02:53) shuusaku shuusaku's gravatar image

no. ok lets start again, are you able to just boot the phone up to normal usagae? hold home and power till it shuts off then back on. let me know

(30 Jul '11, 02:55) therealcmac therealcmac's gravatar image

after the few minutes with the white apple logo the screen became completely black but the phone is not working :(

(30 Jul '11, 02:56) shuusaku shuusaku's gravatar image

did you hold home and power until the phone boots up? (at least 30 seconds)

(30 Jul '11, 02:59) therealcmac therealcmac's gravatar image

yes. the iphone restarts but it gets stuck to the white apple logo. Maybe I need to rerun pwnage tool or redsnow... I'll try again

(30 Jul '11, 03:05) shuusaku shuusaku's gravatar image

@venusanann has a good suggestion down below, it is a good idea to just start over since you have used a number of different tools here...check that out. To restore back to 4.3.3 though you will have to use tinyumbrella, start posting down below..

(30 Jul '11, 03:09) therealcmac therealcmac's gravatar image

Just restore the iphone back to 4.3.3 and start again using one tool for everything i.e. Redsn0w0.9.6rc18, you cannot use the unlock edition of Pwnage as the firmware bundles it contains are for 4.1

Have you approached the official provider about an official unlock, is that a possibility for you?


answered 30 Jul '11, 02:58

venusanann's gravatar image


edited 30 Jul '11, 03:00

thanks for the reply. Yes, I did it with Redsn0w0.9.6rc18 as suggested by therealcmac but I am having troubles with the reboot (i.e. it is not rebooting). I will try to restore directly from redsnow instead of using jailbreakme as I did before; maybe this is the cause of the problem.

Unfortunately an official unlock is not an option :(

(30 Jul '11, 03:07) shuusaku shuusaku's gravatar image

If you're wording is wrong then maybe your understanding is also wrong, you don't restore directly from Redsn0w, you restore using itunes/TSS server/shsh's and then you jailbreak with Redsn0w.

(30 Jul '11, 03:18) venusanann venusanann's gravatar image

make sure you are not doing a stock restore or you will update your firmware and not be able to use 06.15. you can build a custom 4.3.3 with snowbreeze and select the ipad baseband in expert mode>unlocks. But you will have to pull your 4.3.3 shsh from cydia with tinyumbrella and then run the TSS server while restoring to the custom firmware, this as an alternative to restoring to 4.3.3 and using redsnow, either way you will need to use the TSS server to shift/restore to 4.3.3

(30 Jul '11, 03:23) therealcmac therealcmac's gravatar image

maybe i am confusing things here.....i will step back

(30 Jul '11, 03:27) therealcmac therealcmac's gravatar image

@venusanann sorry, as you correctly pointed out my wording was wrong (hopefully my understanding is not, but I still need to prove it) :-)

@therealcmac thanks for the help.

I am now trying to redo the process from scratch. I'll post an update as soon as I have some new result. Thank you both for your time and suggestions.

(30 Jul '11, 03:46) shuusaku shuusaku's gravatar image

Ok, problem solved!!! Many thanks @venusanann and @therealcmac for your hints and comments!

It might have been done in an easier way, but eventually I got what I wanted.

In short:

  1. I started from an iphone 3gs with iOS v4.3.3 and baseband 5.16.02, jailbroken with

  2. I used redsn0w rc 18 with the iPhone2,1_4.3.3_8J2_Restore.ipsw firmware, and selected the iPad baseband only option.

  3. it seemed that the new baseband was correctly installed, but the iPhone was not rebooting properly (got stuck on the apple white logo, and after a while - 3 minutes or so - reverted to the pwned dfu mode)

  4. I tried several things but nothing seemed to work.

    • For example. Re-running redsn0w (either rc18 or rc19) seemed to work but there was a "no successful firmware download after? 6000 ms" message which was not good at all.
  5. eventually, I created a custom firmware with Pwnage Tool without the iPad baseband and alt+restored in iTunes. It worked, and the iPhone started regularly.

Well, I hope this information can be helpful to someone else. Now it's time to check whether GPS is working or not ^_^


answered 30 Jul '11, 04:59

shuusaku's gravatar image


Glad you got it sorted out :)

(30 Jul '11, 05:15) therealcmac therealcmac's gravatar image

yeah, me too! :-)

(30 Jul '11, 05:19) shuusaku shuusaku's gravatar image

Good news: GPS is working, too :-)

(31 Jul '11, 06:21) shuusaku shuusaku's gravatar image

If GPS is working, you're very lucky. Likely it's just using WiFi or cellular triangulation, not GPS. The true GPS test is to disable 3g and WiFi and see if you can get a location.

(31 Jul '11, 09:53) spockers ♦♦ spockers's gravatar image

Hi spockers.

Of course you were right and I wrong: GPS is lost :(

The good news is that I have a good enough resolution with 3G + WiFi triangulation.

In any case thank you all again for the advices and suggestions.

(25 Sep '11, 08:23) shuusaku shuusaku's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 30 Jul '11, 01:30

Seen: 18,005 times

Last updated: 27 Dec '11, 22:31

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.