Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

my iPhone 3GS has a greyed out No Wi-Fi in settings.

Bluetooth still works fine, so I don't think it is a hardware problem seeing as both are combined in the same chip.

It is jailbroken on 4.3.3. Old Bootrom. Baseband 5.13.04. Unlocked.

When I ran nvram wifiaddr in terminal it output my wifi mac address, but in settings it said N/A.

I've tried just about everything from restoring to stock firmware to reflowing the wifi ic to the freezer trick.

Is there anything else i can do?

Is my baseband corrupt?

I've read something about a Wifi fixer released by musclenerd a while ago, not sure if that would help

asked 23 Jun '11, 03:59

bogdan18's gravatar image


closed 13 Mar '15, 16:35

theiphoneguy's gravatar image

theiphoneguy ♦

The wifi fixer I believe you a referring to is for the original iPhone (iPhone 2G). It requires a fakeblank enabled bootloader to run the serial payload (wifi fixer).

I wish I could help, but I don't have a good suggestion for you off-hand. I have an original iPhone with the same problem but the wifi fixer never worked.

Just wanted to let you know about the incompatibility...

(23 Jun '11, 23:57) orion023 orion023's gravatar image

The question has been closed for being "Other - old" by theiphoneguy, 13 Mar '15, 16:35

Have you tried to reset your network settings? And which baseband do you have? Also you should try restoring to a stock IPSW without restoring your backup.


answered 23 Jun '11, 05:13

raviraj%20jailbreak%20guru's gravatar image

raviraj jailbreak guru

I've tried reseting my network settings several times and neither time did it work. I have baseband 5.13.04 so i've tried restoring to 4.0 to keep my unlock and that didn't work either. The only thing that comes to mind is that the baseband is corrupt because thats the only thing that hasn't been updated.

(23 Jun '11, 13:20) bogdan18 bogdan18's gravatar image

why not just make a custom 4.3.3 IPSW and move to it. don't restore your backup

(23 Jun '11, 14:31) raviraj jailbreak guru raviraj%20jailbreak%20guru's gravatar image

I just did this and the problem is still there, a greyed out "no wifi." still unable to click on it

(23 Jun '11, 19:03) bogdan18 bogdan18's gravatar image

Please check the connection no 5 on your MB is properly connected. Is your wifi cable OK?

Also go to your wifi setting and select forget your existing wifi and then reselt and enter the password if there is one.


answered 23 Jun '11, 13:02

Rlamba's gravatar image


okay i checked the cable and it is alright and seems to be connected properly. I can't go to the wifi setting because it's grayed out and can't be pressed. It looks like this:

(23 Jun '11, 13:17) bogdan18 bogdan18's gravatar image

hmmm, did you try this, turn your iPhone into Airplane Mode, reboot it and then come out of airplane mode, see if that helps.


answered 24 Jun '11, 03:15

knightz4u's gravatar image


i just tried this and it didn't work, I got out of airplane mode and it said sim failure, probably because it's a tmobile sim card.

(24 Jun '11, 03:24) bogdan18 bogdan18's gravatar image

Ok can you remove the SIM card and redo the above steps. Then reset network settings. (all without putting your SIM card).

(24 Jun '11, 03:34) knightz4u knightz4u's gravatar image

okay i tried that as well and the problem still persists

(25 Jun '11, 19:55) bogdan18 bogdan18's gravatar image

well i sorta just googled this and i dont know if itl help (not my website) but

(25 Jun '11, 21:01) Aperson Aperson's gravatar image

@Aperson 23 is not special, other than the fact that it's not 42.

(25 Jun '11, 21:17) spockers ♦♦ spockers's gravatar image

@spockers you exited to breach the 10k barrier? :)

(25 Jun '11, 22:27) therealcmac therealcmac's gravatar image


1) Check the channel number on your pc router and select channel 1. Then try and see if you get wifi signal.

2) Make sure it is properly connected to I think No 4 or 5 connector.

3) Replace WIFI Antena cable. They are very cheap. Couple of USDs

4) Set up the wifi in iphone.

5) May be you need to reheat GPRS/EDGE chip

I had similar problem and after replacing the WIFI Antena cable it worked fine.


answered 26 Jun '11, 10:07

Rlamba's gravatar image


can you give me the link to the replacement cable?

(26 Jun '11, 15:41) bogdan18 bogdan18's gravatar image

Try this site from china

(26 Jun '11, 15:55) knightz4u knightz4u's gravatar image shows how to open up 3g but 3GS is also very similar. First look for the wifi antena on ebay so you know what it looks like.

Get a set of magnet small screw drivers, handy for puting back tiny screws.


answered 27 Jun '11, 15:23

Rlamba's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 23 Jun '11, 03:59

Seen: 10,007 times

Last updated: 13 Mar '15, 16:35

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.