Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I have seen this all over the net, but none of the solutions have worked for me. I have an iPhone 4 on 4.3.3 on BB 01.59.00 on T-Mobile. All of a sudden (seemingly) the Cellular Data Network menu is inaccessible to me. Not only do I use it for EDGE, but I also use it for MMS. Nothing I do brings the menu back.

I have tried restoring and erasing all content and settings. Have tried uninstalling and reinstalling ultrasn0w. Have tried installing a custom mobileconfig created from the iPhone Config Utility, but even though I could install the custom profile, I still couldn't connect to the EDGE network and there isn't any way I could see in the Config Utility to configure the MMS settings for T-Mobile. I have the picture icon in Messages and the capability to RECEIVE an MMS, but can't send. Can send and receive normal SMS fine. Also, phone calls work fine. Wifi works fine.

I have also tried various Cydia apps, such as APN Editor, T-Mobile MMS Fix and T-Mobile US MMS for for 4.0 from various repos, but none of them bring back the Cellular Data Network menu or allow me to connect to EDGE or send MMS. Help!

asked 17 Jun '11, 02:12

ifonevan's gravatar image

ifonevan
30438


Have you tried here

link

answered 17 Jun '11, 02:37

venusanann's gravatar image

venusanann
13.3k11618

Yes, but that also will not allow you to customize the MMS settings. Installing the custom profile from this website also did not allow me to connect to EDGE.

(17 Jun '11, 03:00) ifonevan ifonevan's gravatar image

Seems I had this happen tO me once, but a different situation, all I had to do was connect to iTunes and it updated my carrier settings which corrected this problem. Total shot in the dark though.

link

answered 17 Jun '11, 02:54

therealcmac's gravatar image

therealcmac
590221232

I synced with iTunes several times throughout the process, but the menu is still gone.

(17 Jun '11, 03:01) ifonevan ifonevan's gravatar image

Is there just a cellular data on/off slider where the menu access used to be? I'm just trying to picture where this menu is, I know in the older fir wares it was there but once I updated firmwares it was just replaced with on/off, or maybe the carrier updates did that....I am in Canada though so maybe it is different., then again I might not even know what yiu are talking about :p

(17 Jun '11, 03:11) therealcmac therealcmac's gravatar image

It usually is one of the choices under General > Network when you have a non-AT&T SIM card in the phone. I have a T-Mobile card in the phone (it is unlocked also) but the menu is not there.

(17 Jun '11, 11:35) ifonevan ifonevan's gravatar image

You've got 3G turned off.....right?, and are your current carrier settings for T-mobile, if so which version, maybe see if it's the latest version by searching the net

link

answered 17 Jun '11, 03:11

venusanann's gravatar image

venusanann
13.3k11618

edited 17 Jun '11, 03:13

3G is off. The phone is connected to T-Mobile's network (says "T-Mobile" in the top left). Latest version of what...?

(17 Jun '11, 11:36) ifonevan ifonevan's gravatar image

Check what version of carrier settings you have, settings/general/about, and then try some googling

(17 Jun '11, 11:37) venusanann venusanann's gravatar image

I had a similar problem once moving a T-Mobile SIM from a Blackberry device to a (jailbroken, unlocked) iPhone. Worked just fine on the T-Mobile network for voice - but couldn't get a data connection (the E for the EDGE network would not show up next to the carrier namme). A call to T-Mobile took care of it - I think they had to re-provision something on their network?

link

answered 17 Jun '11, 22:35

upgrader22's gravatar image

upgrader22
81227

I had the same issue as well as not being able to delete paired bluetooth devices. I found that if your in "safe mode" you can access cellular data menu and delete paired bluetooth devices. Hope this helps.

link

answered 13 Feb '14, 04:28

villahards's gravatar image

villahards
111

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×57

Asked: 17 Jun '11, 02:12

Seen: 9,882 times

Last updated: 13 Feb '14, 04:28

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.