Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

2
2

After having tried many times to jailbreak my iPhone 4, 4.2.1 Redsnowed with GP RC5 and RC5-2 on my Macbook Mini (Compaq netbook Hackintosh running SL 10.6.5) with no result but "Failed!", I was glad to find:

1) Instructions to get RC5-2 running on Leopard 10.5.x, so I could retry on my other Hackintosh, which handles USB much better (I believe there's now a RC5-3 with Leopard support)

2) A Windows version, so I could try it on my Windows computer which did everything iPhone fine up to now.

However, whatever I tried I kept getting the same behaviour (except on my 10.6.5 Hackintosh, which simply "Failed!" even after using all tips and tricks found here). The jailbreak got carried out, the iPhone rebooted at the "Greenpoison initializing" screen, rebooted again, I got the verbose boot, then the animated logo. After the final reboot, I always got stuck on the Apple logo (no animation) no matter what I tried. I could still reboot tethered with everything OK, but no untethered reboot for me.

Until I remembered that a few days ago I installed Recovery Guard from the pushfix repo, which was designed to block iTunes from unwanted recovery of the iPhone to a newer iOS. I realized that when RG could block iTunes, it might as well block GP. So I opened Cydia (I already told you that the iPhone was Redsnowed), removed RG and retried.

After the removal of RG, GP worked at first try! I've shut down and rebooted a few times, re-installed RG and rebooted a few times more and it's still working untethered.

So if you want to Greenpoison your already jailbroken (but tethered) iPhone and you installed Recovery Guard from the pushfix repo, REMOVE THAT FIRST. After successfully Greenpoisoning your iPhone, you can re-install it safely.

asked 06 Feb '11, 06:20

Squirrel61's gravatar image

Squirrel61
337135


YOU ROCK! This worked for me. Completely forgot I had RG installed and that it may block GreenPois0n too.

link

answered 06 Feb '11, 13:28

rowanzoo's gravatar image

rowanzoo
12

I agree! YOU ROCK!! This was absolutely the fix for my issue. Thanks for taking the time to share it!!

link

answered 06 Feb '11, 15:19

ithank's gravatar image

ithank
1

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×364
×181

Asked: 06 Feb '11, 06:20

Seen: 4,012 times

Last updated: 06 Feb '11, 15:19

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.