Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Im trying to update to jailbreak 4.2.1 and im using greenpois0n and everytime i follow the instructions on the count down, it says try again and the dfu failed. Idk what to do please help!

asked 06 May '11, 19:58

darkboy313's gravatar image


closed 31 Jan '13, 02:00

cybr1d's gravatar image

cybr1d ♦

its same here for me i have the exact same problem why is it please help

(07 May '11, 10:12) rayiou1 rayiou1's gravatar image

The question has been closed for being "too old" by cybr1d, 31 Jan '13, 02:00

Its not about timing exactly if you never had a MC model you don't know, it has something to do with the home button. DO NOT push the home button to hard just really lightly it worked right away when i tried it. Here is a video link to the solution to everyones problem:


answered 12 Nov '11, 12:26

and106's gravatar image


i have 2 iPods that are MC models, and really what you describe is not the normal case. Are you going to revive all old questions from May till now ;-))

(12 Nov '11, 12:42) knightz4u knightz4u's gravatar image

Well what is it if you can't get it in DFU mode, being retarded enough to not count right. I'm just helping people that might look at this forum, that are having problems. This is not just for you, if it doesn't work count out loud!

(12 Nov '11, 12:48) and106 and106's gravatar image

What i meant is that this a behavious of a bad home button and not the norm. No need to storm out at me!

(12 Nov '11, 12:54) knightz4u knightz4u's gravatar image

Well bad home button or not it should work if you press lightly on it. I jailbroken many MC models and none would go into DFU mode until you press lightly on it

(12 Nov '11, 13:05) and106 and106's gravatar image

It'a all about timing, take a look at our video tutorial here:


answered 06 May '11, 20:03

iphoneblogrcom's gravatar image


it takes a picture when i hold the home and power button and after 10 seconds nothing happens

(06 May '11, 20:07) darkboy313 darkboy313's gravatar image

Ya that means wither your power button or home button is malfunctioning, instead of registering a hold of the buttons its registering a press. Screenshot is what happens when you press power+home, but if you're holding them it should reboot the device, if it doesn't one of the two buttons is malfunctioning.

(06 May '11, 20:58) iphoneblogrcom iphoneblogrcom's gravatar image

actually what is supposed to happen is: connect device press and hold power for 3 seconds and slide to power off click prepare to jailbreak press and hold power for 2 seconds, then hold home and power for 10 seconds, then just release power and continue holding home whilest you click the jailbreak button


answered 06 May '11, 21:04

Aperson's gravatar image


i do that and nothing happens, it keeps going to the regular lock screen

(06 May '11, 21:11) darkboy313 darkboy313's gravatar image

hey man, i do a lot of jailbreak, and i had your problem once.

i mean in the same computer in the same day, i had two mc model ipod touch 2g. One can go DFU mode smoothly, and one can't.

in the end, my solution is downgrade to 3.1.3 , then go DFU mode (it succeed this time), then restore CUSTOM firmware (4.2.1 with cydia already built in). I use sn0wbreeze to built the custom firmware. Hope this helps :)

Btw my opinion is best for ipodtouch 2g is 3.1.3 for stability, but for gaming and apps compability is 4.2.1

you can always reach me at the site is in Indonesian, but you can always ask me what it means, or Google translate it :)



answered 06 May '11, 21:57

viper6's gravatar image


when i try to downgrade to 3.1.3 it says the software is not compatable

(07 May '11, 00:01) darkboy313 darkboy313's gravatar image

Software not compatible means you are using the wrong firmware?

(30 Jul '11, 22:31) viper6 viper6's gravatar image

just tried the holding of the home button very lightly worked first time on a ipod 2g mc model which I previously couldn't get into dfu mode and106 you are a genius


answered 27 Jan '12, 09:42

rjw22's gravatar image


Fantastic! Pressing the home button lightly worked! Thank you!!! I looked all over for a solution why I was not entering DFU mode. I guess I was getting tense and pressing too hard.


answered 14 Jul '12, 15:04

Cybergy's gravatar image


Try setting your compatibility mode to windows xp (service pack 2 or 3) and run as administrator. if it still doesn't work, try a different computer, it worked for me. If none of the computers in your house work, then try it at a friends house, be sure to use the settings above for any other computer you are using.

Do not resurrect dead threads. Do not add spam links - Moderator


answered 31 Jan '13, 01:59

dennyduke's gravatar image


edited 31 Jan '13, 21:06

cybr1d's gravatar image

cybr1d ♦

Please don't bump ancient threads.

(31 Jan '13, 02:00) cybr1d ♦ cybr1d's gravatar image

Couldn't find an older thread to resurrect?

(31 Jan '13, 02:01) spockers ♦♦ spockers's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 06 May '11, 19:58

Seen: 27,817 times

Last updated: 31 Jan '13, 21:06

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.