Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

I've been jailbreaking my own iPhones as well as family and friend's iPhones since the beginning. I know what I'm doing pretty well... The issue I'm having now is perplexing, though. This is the second time it has happened to me, and the only way I was able to fix it the first time was to have my iPhone 4 replaced at an Apple Store. Anyway...

What's happening is this: My (AT&T activated) phone was jailbroken on 4.2.1. Today I decided to upgrade to 4.3.3 with redsn0w 0.9.6rc15, so I started by doing a Restore in iTunes to 4.3.3, as I don't care about unlocking. The restore process went perfectly fine. After the reboot and reconnection to iTunes, the first thing it wants to do is activate the phone. Fine, I have my genuine AT&T SIM in the phone, but instead I get this message:


The SIM card inserted in this iPhone does not appear to be supported.

Only compatible SIM cards from a supported Carrier may be used to activate iPhone. Please insert the SIM card that came with your iPhone or visit supported Carrier’s store to receive a replacement SIM card.


This is exactly what happened last time I tried to update my old iPhone 4 to 4.2.1 and had to end up swapping phones at the store. I'm trying to avoid having to do that this time.

So, what I tried next was to use PwnageTool 4.3.3 to build a custom restore bundle with the "activated" flag set. This worked to get me past the activation issue in iTunes, but it also rendered my iPhone "phoneless"! It would no longer make calls and didn't even know it's own phone number, even after a restore from backup.

Right now I'm doing a complete "Erase All Content and Settings" on the phone before I try to restore again, but it's taking it's sweet time.

If anyone has seen this issue before and knows what the heck is going on, PLEASE let me know! Thanks!

asked 06 May '11, 16:55

falvesjr's gravatar image

falvesjr
1214

Could there be something wrong with the SIM? Have you tried swapping the SIM at the Apple store?

(06 May '11, 17:14) spockers ♦♦ spockers's gravatar image

I did the first time it happened a couple of months ago. It's not a problem with the sim. Even with a new sim from AT&T, I could not activate the phone. Luckily, there's an AT&T store down the hall from the Apple store at my local mall, so I went back to the Apple store and they swapped the phone. I suppose I can try that again, but there has to be a software solution to this problem...

(06 May '11, 17:25) falvesjr falvesjr's gravatar image

Surely this is between you, Apple & AT&T, if running stock restored firmware gives you this issue then that obviously cancels out anything jailbreak related. I wouldn't even waste my time trying to solve it with custom firmware, book an appointment with a genius and get them to restore it and activate it in front of you.

Also now you have hit 'reset all content and settings' while jailbroken, you will get stuck in a bootloop and have to restore to get out of it, I know you're gonna do that anyway, but you maybe wasting your time with the reset option.

link

answered 06 May '11, 17:46

venusanann's gravatar image

venusanann
13.3k11618

This doesn't sound like it's caused by the jaibreak, and someone already mentioned, there is no point in trying to use jailbreak tools to fix the problem. As much as it sounds like there should be a software fix for this, it's not one that will come from the JB community.

I would love to have an opportunity to swap my phone at the Apple store if i run unto a problem, but I need my 01.59.00 modem firmware to keep my unlock, and any replacement they give me will most definitely NOT have that old of a baseband.

link

answered 06 May '11, 18:02

AndreyCo's gravatar image

AndreyCo
76229

Hello OP,

I'm running into the same EXACT problem you are. I have a genuine AT&T sim card and cannot activate my phone, and was also previously jailbroken on 4.2.1 firmware. I tried to update to 4.3.3 normally through iTunes and I simply cannot activate it. I even tried using another Micro sim from my friend's iPhone 4. I also tried using Sn0wbreeze to in order to get it "hactivated" but it also rendered my phone useless. No bar, no signal, no calls. My question is:

Will they replace this for me at the Apple Store? You didn't (obviously) tell them it was previously jailbroken, did you? I purchased the phone several months ago (Jaunuary) and it's still under factory warranty...but will they still replace it if they think I tampered with custom firmware?

link

answered 07 May '11, 23:38

Shinjin's gravatar image

Shinjin
1

Your problem is that you updated instead of restoring. It's always best to start fresh when going to new firmware. It's tedious, but not nearly as tedious as troubleshooting the issue would be.

As far as warranty, just restore to stock firmware (restore not update) and all traces of jailbreaking will be gone.

(08 May '11, 00:38) spockers ♦♦ spockers's gravatar image

I don't know if Shinjin updated or restored, but I did a complete restore every time and the problem was still there. So yeah, at that point the phone was fully updated to 4.3.3, it just can't be activated. I ended up going back to the Apple store. They tried doing another restore, and it still wouldn't activate afterwards, so they gave me a new phone.

The new phone had 4.3 on it, so when I got home, I restored to 4.3.3 and all worked perfectly. I don't know if this issue has anything to do with jailbreaking, but it's a pretty big coincidence that this only happened to my iPhone 4s after they had been jailbroken... It could be an issue with the baseband updating process that somehow gets mangled by the JB, but I would expect that there would be a lot more cases of this problem if that were the case.

No, I didn't tell them that the phone had been jailbroken, but they also never asked. There was no problem getting a new phone after they confirmed the issue.

(08 May '11, 09:06) falvesjr falvesjr's gravatar image

Must of been something wrong with the iphone if they couldn't activate it in front of you I can't see it's anything to do with the jailbreak or it would be more common. Anyway, glad you got it sorted by whatever means.

(08 May '11, 09:13) venusanann venusanann's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×107

Asked: 06 May '11, 16:55

Seen: 35,998 times

Last updated: 08 May '11, 09:13

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.