Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Getting error 3194 when trying to update to 4.3.3 with Snowbreeze 2.7. Currently on iPhone 3G(S) J/B 4.2.1 w/ Greenpois0n. Any insight?

asked 06 May '11, 14:37

Robdizzle2711's gravatar image


12next »

Change your hosts file, click on this, if you don't see an Apple 404 page then your not pointing at Apple servers


answered 06 May '11, 14:38

venusanann's gravatar image


edited 06 May '11, 14:41

iPhone 4, current 4.3.1 going to 4.3.3 using sn0wbreeze 2.7 for windows.

Ive been messing with this myself for the past hour or so. It is for sure pointing to and when I ping it it pings that ip address. But I still continue to get this error 3194 on 2 separate computers even. Any other ideas fellas? :)



answered 06 May '11, 14:58

JJMAN's gravatar image


Could be the server is down

(06 May '11, 14:57) venusanann venusanann's gravatar image

well shizzle my nizzle badizzle. iPhone stuck in DFU mode also. iReb nor TU will break it free. weird stuff going on :)

(06 May '11, 14:58) JJMAN JJMAN's gravatar image

Check the link at the bottom of this thread


answered 06 May '11, 15:00

venusanann's gravatar image


Man I'll be without my phone at all till those suckahs come back up. Trying to preserve my baseband still and dont want to just do any update of the firmware. : Shes still stuck in DFU mode. First time I've had this much trouble with dfu mode.

(06 May '11, 15:08) JJMAN JJMAN's gravatar image

Won't holding both buttons reboot it

(06 May '11, 15:10) venusanann venusanann's gravatar image

You'd think so. and has in the past. Ive held those suckers down for 25 seconds. If its hooked up with the cable to a computer you can hear it connect and disconnect. but it wont come out of dfu for nothing.

(06 May '11, 15:11) JJMAN JJMAN's gravatar image

I can run tinyumbrella and start the server. Then iReb and then it verifies but get the 1600 error shortly afterwards. :\

(06 May '11, 15:14) JJMAN JJMAN's gravatar image

Holy crap I've never had a full out DFU mode lock before. But "finally" after trying multiple computers and cables, I got my sn0wbreeze to go and working fine. So anyone else haveing this kind of issue, Edit your host to not point to anything. Run your iReb and load your sn0wbreeze cooked 4.3.3 and then itunes and shift+restore and hopefully you can get it going. :)

Gooooood luck to anyone having the issues I was having today.



answered 06 May '11, 16:59

JJMAN's gravatar image


Sorry JJMAN, but I could never get rid of the dreaded 3194 error.

Alternately, I tried running redsn0w 0.9.6.rc15 with Tiny Umbrella running it's TSS Server in the background. this produced a 21 error. so no luck there either.

Any ideas ?!?


answered 07 May '11, 03:14

thevmax's gravatar image


In Sn0wbreeze, rebuild your ipsw using the "simple mode"

Also, unplug/replug your device after iREB puts it into pwned DFU, and make sure your hosts file doesn't have any entries for Tinyumbrella re-adds it every time I open it, so ping from a command prompt, if it doesn't say, manually edit the hosts file again.


answered 07 May '11, 03:44

JonSeals's gravatar image

JonSeals ♦

Yes try "exactly" what JS just posted. Also if you have another computer, try that if it still fails.

(07 May '11, 10:52) JJMAN JJMAN's gravatar image

TinyUmbrella always edits the hosts file when it's running. You should not have TU running when trying to go to 4.2.8/4.3.3 anyway, as there is no SHSH support yet. If you have "Request SHSH from cydia" UN-checked in TU, your hosts file will be corrected when you close TU.

(07 May '11, 13:22) spockers ♦♦ spockers's gravatar image

If u uncheck request shsh from cydia and set hosts to cydia on exit in tinyumbrella, make sure to hit apply changes this will put a # symbol in front of the ip address, and u should be ok to restore.


answered 07 May '11, 11:10

Bornsrvr's gravatar image



Locate the host file and move it to another directory or simple rename it, then open iTunes and do the restore with the custom firmware created by sn0wbreeze.

I recommend that you make a custom IPSW with expert mode in sn0wbreeze and check active the iPhone. It preserve the baseband.

When you finish move back the host file to the directory.


answered 07 May '11, 11:10

diegomolineaux's gravatar image


Just for everyones information all options in Snowbreeze preserve baseband he doesn't need to select activate iphone to preserve his baseband.


answered 07 May '11, 11:17

Bornsrvr's gravatar image


OK here we go. TinyUmbrella has been updated to support 4.2.8/4.3.3. Get the new TinyUmbrella 4.33.00, open it, click the Advanced tab, UN-check "Set hosts to cydia on exit" and UN-check "Request SHSH from cydia." Click "Apply changes." Select your device on the left, click "Save SHSH." Click the Log tab and verify that the 4.2.8/4.3.3 SHSH was saved. Click "Start TSS server." This will take Apple's servers completely out of the picture. Try the restore in iTunes now.


answered 07 May '11, 13:33

spockers's gravatar image

spockers ♦♦

I should have mentioned TU had a new release above^^^, I tried doing this ^^^^^on windows 7 before i posted and it definitley works.

(07 May '11, 13:47) Bornsrvr Bornsrvr's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported


Asked: 06 May '11, 14:37

Seen: 17,337 times

Last updated: 07 May '11, 14:31

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.