Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

My iPhone was originally working fine with at&t. But after restoring my iPhone 4, it gets no signal (that situation seems like i'm using a non-valued carrier sim like t-mobile and waiting for an unlock. But in fact, I was using an official at&t sim as usual) ! I was using the shift-left click method.

  • win7
  • iPhone 4 iOS 4.2.1 BB2.10.04 & 3.10.01
  • restore to iOS 4.2.1 (because I want a clean iPhone)
  • using an official at&t sim
  • never uses ultrasn0w at any point
  • tools w/ greenpois0n, redsn0w, sn0wbreeze, tinyumbrella. all in newest version

I've tried this on many iPhone 4s (at least 4 iPhones I believe) and only one survived (but I don't know why).

So basically, after restores, my phone seems like to be locked to another country (not US).... BUT i'm sure it works fine before restore....

Anyone? THX ;)

asked 05 May '11, 04:06

David11629's gravatar image

David11629
26226

edited 05 May '11, 04:28


I had a similar problem with no carrier after upgrading to 4.3.1. I hope this is the same thing you experience and that it works for you too.

The thing that I (and the tutorial I followed) had missed was that after upgrading to the original Apple 4.3.1 firmware (from 4.1) I should have synced (without applying old backup) and activated the phone BEFORE restoring the phone to the jailbroken 4.3.1 firmware.

So I had to restore to the original firmware first, sync and make sure I got a signal, restore to jailbroken firmware and finally restore the last backup.

Cheers Martin

link

answered 05 May '11, 05:18

Wictorsson's gravatar image

Wictorsson
412

That seems logical........ yeah, i think you r right. because right now i'm using is OS 4.2.1 w/ BB 2.10.04. and it works without any problem might because i had the backup before i restore it.. others didn't work might because i restore it w/out having backup!! thanks!

(05 May '11, 07:27) David11629 David11629's gravatar image

Thanks, i restored yesterday and it worked. Thanks a lot!

(09 May '11, 16:40) David11629 David11629's gravatar image

Glad to hear it worked! :-D

(10 May '11, 04:54) Wictorsson Wictorsson's gravatar image

Well if your iphone is running stock firmware and you have no signal then it's not jailbreak related, so you used Cydia or Local for the signing?, have you tried 'reset network settings' ? gotta ask why you're still on 4.2.1?

EDIT:- getting confusing now, where did this iphone come from?

link

answered 05 May '11, 04:25

venusanann's gravatar image

venusanann
13.3k11618

edited 05 May '11, 04:31

yea, so i tried both custom firmware and tinyumbrella, but still got the problem... and the reason I'm still on 4.2.1 is because i want to keep my bb on 2.10.04 so the unlock chance might be higher... but i'm afraid that if i use the restore again i'll lose my service

(05 May '11, 04:51) David11629 David11629's gravatar image

the phone is from ebay, but att works fine. and i repaired with apple store several times, but still got the problem

what i was saying was just an explanation to kind of giving you an idea what the problem would look like.... those are just my guessing

(05 May '11, 04:55) David11629 David11629's gravatar image

Well you do have a baseband/firmware mismatch, these are causing signal problems for preservers on higher firmware, but who knows, could be your issue. Is this issue cosmetic or are you unable to make calls?

link

answered 05 May '11, 05:58

venusanann's gravatar image

venusanann
13.3k11618

yes, so my phone right now is 4.2.1 w/ BB 2.10.04 on att..... i think Wictorsson was right. this one (and only one) works because i have the backup of it... that's why after i restore with tinyunbrella i can still get signal.

(05 May '11, 07:34) David11629 David11629's gravatar image

i can't even activate it after restore. i can only use redsn0w to sneak into it..

(05 May '11, 07:37) David11629 David11629's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,524
×105
×101

Asked: 05 May '11, 04:06

Seen: 7,554 times

Last updated: 10 May '11, 04:54

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.