Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.x is released, still early stage, mostly for developers - see Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

I have an iPhone 3G with iOS 4.2.1 and baseband 05.15.04. I want to upgrade baseband to iPad version 06.15.00, hence I can unlock it with Ultrasn0w.

  • Snowbreeze would keep the baseband.
  • RedSn0w exited silently during "downloading ipad baseband" step. However I can jailbreak my phone successfully without "install ipad baseband" option.
  • GreenPois0n cannot find my phone in DFU mode.

I have tried these methods on both Windows XP Pro SP2 32-bit and Windows 7 Ultimate 64-bit. I have tried "run as administrator" and "set affinity to 1", but with no luck.

For now, my iPhone becomes an iPod touch. I don't have a Mac, and I don't know what to do next. Any ideas?

asked 28 Apr '11, 08:17

axqd's gravatar image

axqd
6113

On windows 7 system did u run as admin and choose service pack 3 compatibility mode?on xp pro did u choose service pack 3 and run as admin this applies even if u have an admin account "affinity level"only applies to Vista

(28 Apr '11, 08:50) Bornsrvr Bornsrvr's gravatar image

@Bornsrvr Thanks for your reply. 1) The redsn0w version is 0.9.6rc14, which is the latest one. Can you suggest which version I should use instead? 2) yes, I've tried 'SP3 compatibility' on Win 7 system and run as 'Administrator' on Win XP.

(28 Apr '11, 10:00) axqd axqd's gravatar image

greenpois0n and sn0wbreeze will not install the iPad baseband for you, redsn0w is the only one that would, last time i did it was redsn0w rc0.9.6 rc9, but rc14 should also do the job. Note you need to be connected to the internet, sometimes proxies or firewalls may interfer, or if Apple server is down (unlikely). My advice is to keep trying.

(28 Apr '11, 12:51) knightz4u knightz4u's gravatar image

Sorry for my misleading comment about redsnow version, i was mixing up my JB's, apologies for any time wasted.

(28 Apr '11, 13:55) Bornsrvr Bornsrvr's gravatar image

@knightz4u - read about it here, PwnageTool 4.1.3 Unlock Edition contains an iphone 3G 4.2.1 bundle

link

answered 28 Apr '11, 13:11

venusanann's gravatar image

venusanann
13.3k11618

1

I created a custom ipsw package with PwnageTool 4.1.3 Unlock Edition on Mac OS X Snow Leopard in VMWare, and then I restored my iPhone with that ipsw package in iTunes on Windows 7. Baseband was successfully upgraded to 06.15.00. I also used redsn0w to enter DFU mode and deactive the phone for SAM.

(29 Apr '11, 07:13) axqd axqd's gravatar image

You are the man, well done for getting it done/working it out.

(29 Apr '11, 08:21) venusanann venusanann's gravatar image

@venusanann good catch, i see that now, i myself am not a PwnageTool user. However sn0wbreeze has added this feature (iPad BB) starting in versions 2.5 onwards, this covers iOS 4.3.x and so excludes iPhone 3G.

(30 Apr '11, 12:40) knightz4u knightz4u's gravatar image

I'm a Mac user, and have spent alot of time using Pwnage from day 1 to the present, as for Sn0wbreeze, hats to the dev, but I'm never gonna use it and so have no hands on experience of it. The SB ipad BB install was raised in the comments below, I'm not sure if people managed to find the install option though, maybe you can run them through it or stick it the FAQ

(30 Apr '11, 12:50) venusanann venusanann's gravatar image

You have to use Redsn0w to install the ipad baseband, 0.9.6rc14 is ok, or Pwnage (Mac), not sure if Sn0wbreeze supports the install or not, but hopefully you have weighed up the pros & cons of taking the ipad baseband i.e. total loss of GPS and no way back etc. I'm not sure why it fails on you at the stage it does, it looks as though you are running Redsn0w on windows as you should or you wouldn't be able to jailbreak it at all. Just keep trying or find a friend with a Mac to build you a 3G custom firmware to include the ipad baseband and the right selection on activation, failing that you're left with searching the net or sites you trust for a pre made 3G custom 4.2.1, then put your iphone into pwned DFU using Redsn0w and shift/restore to it, might be an idea to restore to stock 4.2.1 beforehand.

link

answered 28 Apr '11, 12:44

venusanann's gravatar image

venusanann
13.3k11618

Does Pwnage build a custom firmware with iPad baseband? i didn't know that! Do you have a link i would like to learn more about this.

(28 Apr '11, 12:52) knightz4u knightz4u's gravatar image

sn0wbreeze can install the ipad baseband.

(28 Apr '11, 12:54) raviraj jailbreak guru raviraj%20jailbreak%20guru's gravatar image

@raviraj as a matter of interest how do u install ipad baseband with snowbreeze?

(28 Apr '11, 15:35) Bornsrvr Bornsrvr's gravatar image

@venusanann Thanks for your answer. The problem only occurred when it tried to download ipad baseband. I hope redsn0w can let me choose to get the ipad baseband from the iPad-ipsw as PwnageTool does. I don't have a Mac, but I do have a Snow Leopard in my VMware. I don't know if I can use PwnageTool to generate an ipsw file and then restore it from iTunes on Windows.

(28 Apr '11, 23:20) axqd axqd's gravatar image

@raviraj I have the same question as Bornsrvr's. I don't see an option there to install the iPad baseband.

(28 Apr '11, 23:24) axqd axqd's gravatar image

@axqd - Redsn0w downloads what it needs with regard to ipad ipsw when prompted, Pwnage requires the ipad ipsw to already be on your comp, not sure on the vmware answer, maybe someone else can advise or you just can just try it.

(29 Apr '11, 02:48) venusanann venusanann's gravatar image

use sn0wbreeze on expert mode, under that it's under the 'unlocks' section.

(29 Apr '11, 02:54) raviraj jailbreak guru raviraj%20jailbreak%20guru's gravatar image

JB guru, please don't post links to that site, they will not get advertised here no more. Thanks dude.

(29 Apr '11, 03:08) venusanann venusanann's gravatar image

lol,sorry. just rectified that.

(29 Apr '11, 03:16) raviraj jailbreak guru raviraj%20jailbreak%20guru's gravatar image

@raviraj Sorry, but I still cannot find it in Expert Mode of Sn0wbreeze.

(29 Apr '11, 05:54) axqd axqd's gravatar image

yes sn0wbreeze with write a 6.15 bb if you want. remember to start out in pawned dfu mode not just dfu mode.

(29 Apr '11, 08:59) bobmutch bobmutch's gravatar image

@bobmutch i have snowbreeze running at moment trying to access ipad baseband option and in expert mode it wont give me the option to unlocks.How do i get to install ipad baseband through snowbreeze? Thanx

(29 Apr '11, 09:37) Bornsrvr Bornsrvr's gravatar image

@Bornsrvr what version of sb you using and I will fire it up and tell you.

(29 Apr '11, 09:45) bobmutch bobmutch's gravatar image

sb 2.2.1 for iOS 4.2.1 select a 4.2.1 IPSW, verified, expert mode, general... er weird, it ain't there no more. hrmm, must be dreaming. sorry.

(29 Apr '11, 09:53) bobmutch bobmutch's gravatar image

@bob mutch and @axqd thats whats weird i have it running in expert mode but the unlocks option wont highlight!!

(29 Apr '11, 12:40) Bornsrvr Bornsrvr's gravatar image

@axqd id really like to know how to run vmware on windows, so as to be able to have access to mac software and pwnage. According to @venusanan pwnage seems to be the most straight forward of them all.that was great work how u got around the issues u were having.

(29 Apr '11, 12:46) Bornsrvr Bornsrvr's gravatar image

Let me look at that, what ver of sb?

(29 Apr '11, 12:47) bobmutch bobmutch's gravatar image

@bobmutch sorry for delay getting back to u i had to pop out i have the ipsw file for 3g on 4.2.1 same as one @axqd had and the corresponding snowbreeze 2.2.1 for that firmware.But no matter what opwtion unlocks not available.

(29 Apr '11, 12:49) Bornsrvr Bornsrvr's gravatar image

you unlock after you restore the custom ipsw with ultrasn0w

(29 Apr '11, 13:03) bobmutch bobmutch's gravatar image

@Bornsrvr As for running Snow Leopard under vmware, your CPU has to support hardware virtualization, or it won't work. My core-2-duo doesn't support it, so I had to dedicate a spare hard drive to OS X, and boot to it. That's a better solution anyway, as it runs much faster natively than it does in VMWare. I can even run Lion, which has full-res output on my video card, plus it supports my HDTV, neither of which work under Snow Leopard.

(29 Apr '11, 13:17) spockers ♦♦ spockers's gravatar image

Thanx for that @spockers, could i do this on an external hard drive or the backup drive that windows 7 (factory drive)has on the system. Or how would i go about setting this up?(Thanks for your input on this)

(29 Apr '11, 14:04) Bornsrvr Bornsrvr's gravatar image

@Bornsrvr You can just google "windows 7 vmware snow leopard" and you can find all the info you need. BTW I cannot enable the unlock option in expert mode and I cannot find the 'upgrade to ipad baseband' option either. Hence I use Pwntool instead of Snowbreeze.

(29 Apr '11, 15:15) axqd axqd's gravatar image

@axqd good job, I too couldnt find it in snowbreeze, i didnt actually need it as im factory unlocked, but i was interested in finding out how u could do it.Thanx for the vmware info.

(29 Apr '11, 15:21) Bornsrvr Bornsrvr's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,845
×1,557
×634
×378

Asked: 28 Apr '11, 08:17

Seen: 14,911 times

Last updated: 30 Apr '11, 12:57

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.