Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I was using the PP Jailbreak (Chinese version) for iOS 9.3.3 on my iPhone 5S, which failed somehow and stopped re-jailbreaking after a reboot. For some reason the developer certificate became 'untrusted' and I couldn't trust it again! I was forced to wipe out and restore from an iTunes backup.

The funny thing is that every jailbreak tweak that had a springboard icon (Activator, BarMagnet, WifiPasswords, and Cydia) were NOT deleted. The icons were still there, although they couldn't run, of course.

Well, I was able to re-jailbreak after my restore with PP (Chinese), but Cydia did NOT reinstall. Instead the Cydia icon that was already there (actually, never deleted at all) would open, but files are missing so it won't actually work. Activator would also now open, but in some weird state where the app is completely blank. (But WifiPasswords and BarMagnet work just fine!)

Here is what I see when I open Cydia, and an image of Activator too in case it helps:

Cydia: https://drive.google.com/file/d/0B0ompHlRwPtkWDhlRXpJT2xOd1U/view

Activator: https://drive.google.com/file/d/0B0ompHlRwPtkVU90dnZ5X2xwZkk/view

Cydia just shows me an error that reads, "Could not open file /var/lib/dpkg/status - open (2: No such file or directory)" and "The package lists or status file could not be parsed or opened." If left open, those 2 message repeat over and over again.

I have been tearing my hair out! All the commonly suggested tools won't work. Cyberduck and iExplorer won't connect at all, while iFunBox and Macgo iPhone Explorer don't show that the phone is even jailbroken at all (even though PP worked and shows that the phone was re-jailbroken after reboot).

I even tried removing the Chinese trusted certificate and re-jailbroke again with the Pangu English version. Same thing! I cannot get Cydia to erase and reinstall, or just reinstall over the existing copy so it has all the files it needs!

I did NOT have iFile or OpenSSH installed before restoring, and none of the methods found online seem to work for me: Impactor works for some apps, but doesn't want to work with .deb files for installing iFile or OpenSSH. I've even tried converting the .deb files into .ipa files so that I could use them with Impactor, but I can't get InstaSign or iOS App Signer to work no matter how many different ways I configure my dev signing in Xcode. And when I Google how to re-jailbreak to get Cydia to re-install, I can only find tutorials on how to use the PP/Pangu semi-tether app to reactive the jailbreak after a reboot, not how to COMPLETELY reinstall Cydia from Scratch, or delete it so I can just wipe out my jailbreak and start again.

Please, please help me! There has to be SOME way to force Cydia to completely reinstall to replace whatever's missing so it loads when I open it. I don't want to have to go to iOS 10.x yet until there's a jailbreak. I appreciate all input.

Thank you in advance for your help.

asked 27 Sep '16, 08:10

Jragyn's gravatar image

Jragyn
267212


link

answered 10 Nov '16, 02:23

cracker's gravatar image

cracker
42910419

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,190
×4,404
×2,355
×534
×433
×17
×8
×6
×6

Asked: 27 Sep '16, 08:10

Seen: 3,335 times

Last updated: 10 Nov '16, 02:23

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.