Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I am trying to Jailbreak my iPad 4 on iOS 9.0.2. I updated from iOS 7 and then I restored my iPad so it started from a new slate. I have the latest version of Pangu which is V1.0.1. Every time I run the jailbreak, it stops at 90% and my iPad starts rebooting. After the reboot, Pangu restarts asking me to click Start again when my device is plugged in. At this point, my iPad is not jailbroken. I've ran Pangu in admin mode as well and that didn't work either.

It always reboots at 90%...

Any suggestions or advice would be great at this point!


asked 16 Oct '15, 13:40

DarkXShadowX21's gravatar image


Remove Pangu from Programs and Features, restore iPad, redownload Pangu from their site, try again. This should remove all software problems with Pangu and the iPad. Try using a different cable (if you have one) on a different port.

(16 Oct '15, 15:55) King Shoot King%20Shoot's gravatar image

Have you done an iTunes backup on the computer you're using to jailbreak?

(16 Oct '15, 16:44) spockers ♦♦ spockers's gravatar image

King Shoot,

I will give that a shot right now. I literally just restored my iPad to a fresh state. It should be good to go. Unless, you advise I should restore it again, I'll go ahead and do that as an extra added precaution.

I don't have another cable that I trust using. The other one has has electrical tape wrapped around it so many times I've lost track. Lol!


I haven't backed up my iPad because I don't really care to. It has nothing of any value on it which is why I'm starting it from a fresh slate via iTunes.

(16 Oct '15, 17:24) DarkXShadowX21 DarkXShadowX21's gravatar image

I followed all steps again. No passcode was turned on. Find my iPad is turned off.( Not even signed into iCloud. ) Airplane mode turned on before the jailbreak. After 1st reboot, Airplane mode was turned on again. I switched USB ports. I open up the Pangu app and accept the terms. Press OK for the pop up notification. I wait about 5 seconds and as soon as the percentage jumps from 85% to 90% my iPad reboots.

(16 Oct '15, 17:47) DarkXShadowX21 DarkXShadowX21's gravatar image

I tried it with my shotty cable and was hoping for the best. Unfortunately, it did not work like I was hoping it would. I even tried another USB port as well. It just reboots at 90% and doesn't successfully jailbreak my iPad 4.

(16 Oct '15, 18:08) DarkXShadowX21 DarkXShadowX21's gravatar image

I asked about the backup not out of concern for your data (that's your call obviously), but because from what I gather from reading other reports, if you haven't backed up on the computer used to jailbreak, it's more prone to fail. You don't need the backup, the jailbreak itself does.

(16 Oct '15, 18:37) spockers ♦♦ spockers's gravatar image

Ahhhhhhhh! Gotchya! I wasn't aware of that one mate. That's usually not something that has to be done for a fresh jailbreak. I'll give that a shot and see how it works. Thanks!

(16 Oct '15, 18:44) DarkXShadowX21 DarkXShadowX21's gravatar image

Yeah this one's a little odd. Good luck.

(16 Oct '15, 18:50) spockers ♦♦ spockers's gravatar image

I restored from a backup and it rebooted again at 90%. :/ This is starting to bum me out a bit. I just used the same tool to jailbreak my 6+ and I didn't have any issues with that. I didn't do a backup on it. I didn't restore it from a backup. I went straight into a jailbreak and it worked perfectly.

(16 Oct '15, 19:40) DarkXShadowX21 DarkXShadowX21's gravatar image

Try opening the photos app before you open the pangu app on the phone.


answered 16 Oct '15, 21:22

Acbrown's gravatar image


Should I leave the photos app open in the background before I open the Pangu app?

(17 Oct '15, 12:52) DarkXShadowX21 DarkXShadowX21's gravatar image


(17 Oct '15, 13:20) Acbrown Acbrown's gravatar image

I'll give that a shot today. I've been away for a little bit but I'll test it out today and come back with a response.

(20 Oct '15, 12:58) DarkXShadowX21 DarkXShadowX21's gravatar image

I tried performing the jailbreak with the photos app open. It didn't work.

(20 Oct '15, 14:03) DarkXShadowX21 DarkXShadowX21's gravatar image

Ive been having the same issue, but I found out if I restore the phone to factory then run pangu it works fine. If I restore the phone then restore my data pangu fails at 90%. If I try to restore my data after jailbreaking then my phone goes to the endless bootloop at the apple logo. I really wish I could keep my data and have a jailbreak.


answered 20 Oct '15, 19:48

Viper12003's gravatar image


I've done the restore plenty of times and ran Pangu immediately afterwards. I've tried restoring with and without restoring backed up data.

I've had no luck yet as of yet with my iPad to be successfully jailbroken.

(21 Oct '15, 10:10) DarkXShadowX21 DarkXShadowX21's gravatar image

Try using the latest Pangu tool (1.1) and the latest iTunes (12.3.1).

Get them from and


answered 21 Oct '15, 14:00

citrusui's gravatar image


I'll update everything and give it a shot. Thanks! I'll be back with an updated response on the matter soon.

(21 Oct '15, 14:23) DarkXShadowX21 DarkXShadowX21's gravatar image

I've been away on the road for a little bit. My apologies for the late response. I will be responding soon though with an update. Thanks again!

(28 Oct '15, 15:07) DarkXShadowX21 DarkXShadowX21's gravatar image

Once again, I've been away. Soon enough, I'll do this jailbreak and will proceed with an updated response. Thank you for not closing this question!

(18 Nov '15, 00:46) DarkXShadowX21 DarkXShadowX21's gravatar image

i have the same problem on my ipad mini 3 ios 9.0.2 get stuck on 90% of jailbreak and nothing happen..........


answered 22 Oct '15, 00:35

andy%20chen's gravatar image

andy chen

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 16 Oct '15, 13:40

Seen: 3,169 times

Last updated: 18 Nov '15, 00:46

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.