Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

iOS 9 and 8.4.1 do not have jailbreaks. You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
TaiG provides an iOS 8.4 and 8.3 untethered jailbreak. Check @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Alright, looks like I got another I was using my iPhone and opened the Facebook app. Seeing as mine doesn't work half the time, I decided to delete it and redownload it. So, I went into the app store and it started downloading. When it got to installing, it froze up on that part. So, I went to read a book in iBooks and while I was, I got a text message. I went to reply to the text (QuickReply) and when I hit reply, the phone froze. I have rebooted 3 or 4 times and it gets stuck on the boot logo that I have selected (AppDroid) right at the end of it. I'm on 4.2.1, greenpois0n jailbreak and like the title says, it's an iPhone 4. Let's see if my man, spockers, can help me out lol.

Right before I was about to post this, I had been waiting for the boot logo to unfreeze. After a bit of that, the iPhone rebooted itself. Great, just great. Now I'm in multiple reboot :(

asked 11 Apr '11, 23:23

C0BRA's gravatar image


closed 05 May '11, 00:04

spockers's gravatar image

spockers ♦♦

It sounds to me like AppDroid is the culprit. I never understood the fascination with boot logos, and I still don't. It's a hassle to get them working, and they obviously cause issues. Not worth it IMO.

(11 Apr '11, 23:28) spockers ♦♦ spockers's gravatar image

So.....what do I do?!

(11 Apr '11, 23:30) C0BRA C0BRA's gravatar image

If you're stuck in a boot loop, the only sure solution that I know of is a stock restore. Sucks, I know.

(11 Apr '11, 23:33) spockers ♦♦ spockers's gravatar image

Is there not some way to delete AppDroid and it go to the default BootLogo and turn on?

(11 Apr '11, 23:42) C0BRA C0BRA's gravatar image

Possibly, if you have OpenSSH installed and can connect to the device with WinSCP and run dpkg to uninstall it. Assuming you know the package/repo name. And your device's local IP on your LAN.

(11 Apr '11, 23:54) spockers ♦♦ spockers's gravatar image

Somehow, by magic, it turned back on into safe mode. Thank goodness. Now to go change the boot logo lol. Thanks though, spockers! You da man!

(11 Apr '11, 23:57) C0BRA C0BRA's gravatar image

LOL, you lucked out!

(12 Apr '11, 00:03) spockers ♦♦ spockers's gravatar image

Lol I think Jesus was having a sense of humor on my luck tonight

(12 Apr '11, 00:12) C0BRA C0BRA's gravatar image

The question has been closed for being "Solved 3 weeks ago" by spockers, 05 May '11, 00:04

Just Download tiny umbrella at and whe its opened conect your iphone 4 if it shows up click the kick out of recovery button. If it doesnt work put your iphone 4 in dfu conect it and then clikc the button that I just mentioned.


answered 04 May '11, 16:38

AG_darrular's gravatar image


This was solved over 3 weeks ago.

(04 May '11, 22:53) spockers ♦♦ spockers's gravatar image

hope this will help.

if your iphone got stucked. you can try to reboot, and you just need to wait, sometime it takes time. like 3-5 mins.. just leave it, it will successfully boot up. if you keep trying to reboot when your iphone is booting up, it only make it the system take longer to boot up. (based on my experience with this situation)

but if your phone stuck more than 5 mins, i think there is bigger problem. ;)


answered 04 May '11, 22:22

gudril's gravatar image


hold down the sleep button and home button for 10 secs, when screen turns black release all buttons!


answered 05 May '11, 00:02

vitalic's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 11 Apr '11, 23:23

Seen: 7,386 times

Last updated: 05 May '11, 00:04

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.