Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Here is the full paths I've taken.

Jailbroken iPhone 4s on 8.1

  1. Downloaded IPSW from ipsw.me
  2. Pressed 'Erase all content and settings' (ooops)
  3. Entered DFU mode tried to shift-restore, error 48 when the bar is at like 99% on the device
  4. Again, and again, same as 3
  5. Let iTunes download the IPSW from Apple
  6. Enter DFU and try with that one, no dice.
  7. Restart computer
  8. Try again, nothing, still error 48
  9. Download iTunes 12.0.1
  10. Enter DFU mode and try to restore... nothing
  11. ...
  12. Post for help here

http://i.imgur.com/v1PMFrU.png

Any idea? is it lost forever?

I don't have access to apple store, nor does it have warranty anymore.

:'(

asked 29 Jun '15, 08:05

damnyouerror48's gravatar image

damnyouerror48
11114


Doesn't look good.

link

answered 29 Jun '15, 08:40

spockers's gravatar image

spockers ♦♦
69.9k3911660

Ouch.

But it seems odd that it would be a hardware problem, the iphone/macbook/usb has worked flawless for years.

Oh and I don't care about loosing the jailbreak, the point was to update anyway.

(29 Jun '15, 08:44) damnyouerror48 damnyouerror48's gravatar image

They gotta go sometime. It appears to be a design flaw with the 4s.

(29 Jun '15, 08:46) spockers ♦♦ spockers's gravatar image

Somehow me thinks its related to the infamous 4s greyed out wifi after restore thing.

(29 Jun '15, 08:53) justinred ♦ justinred's gravatar image

I will try with a windows VM. Then new USB and later a different computer altogether. Will write down the success or fails.

(29 Jun '15, 09:05) damnyouerror48 damnyouerror48's gravatar image

Yes, please do, this one's a stumper.

(29 Jun '15, 09:32) spockers ♦♦ spockers's gravatar image

I just looked into it. It says it's a problem with the ipsw file. Try downloading the update strait from iTunes. See if that works

(29 Jun '15, 10:02) Shonc502 Shonc502's gravatar image

Shonc502, I already tried to download directly from Apple, as well as an IPSW from that ipsw.me. They both have md5: 51217942e98f854784f324a1833baa3b as it seems they should https://ipsw.me/iPhone4,1

Anyway, tried it with a virtual machine just now, same error. I will exhaust every option I can.

(29 Jun '15, 11:55) damnyouerror48 damnyouerror48's gravatar image

Tried on my mac now with a brand new cable. Same error.

(30 Jun '15, 04:24) damnyouerror48 damnyouerror48's gravatar image

Tried in VM again. Tried different port. Different macbook. Nothing. Just error 48.

(30 Jun '15, 06:22) damnyouerror48 damnyouerror48's gravatar image

Tried on mac with the new 8.4 release, nope.

(01 Jul '15, 00:04) damnyouerror48 damnyouerror48's gravatar image

Bummer. It has to be hardware then, that's crystal clear.

(01 Jul '15, 00:09) spockers ♦♦ spockers's gravatar image

Spockers, yeah it seems. I will continue to attempt it once in a while. I have another 4s, but now I am afraid to even update it if it is hardware related. Maybe I can go find some Apple store to do it for me, but there are none in my country.

(02 Jul '15, 05:36) damnyouerror48 damnyouerror48's gravatar image

According to this post, changing the battery worked. I might just give it a shot. http://forum.gsmhosting.com/vbb/f631/iphone-4s-restore-error-48-help-me-1954098/

(02 Jul '15, 05:44) damnyouerror48 damnyouerror48's gravatar image

I have the same problem, this is what i did:

  • Jailbreak vía 25PP on Mac
  • Worked great (tweaks, apps, etc).
  • Found out about Cydia Impactor (so you don't loose your jailbreak because apple stop signing with this version (8.4)).
  • Install it. Clear everything, Jailbreak again, Restore data from icloud.
  • Psswd not working (freak out).
  • Can't restore until Find my iphone is off (my lock button is not working so i couldnot enter recovery mode from buttons), so i thought i'll go one step back and restore from itunes again, so i erased data remotely. (!)
  • Got stuck with apple logo.
  • Found out about RecBoot. Enter recovery from RecBoot.
  • Now iphone ask me to plug to iTunes to update and restore.
  • Error 48

Now i'll try to enter DFU mode, i'll post results. Any idea of the problem so far? Thanks!

(21 Jul '15, 11:44) Toust Toust's gravatar image
1

Pls start your own thread and also use add a comment tab unless providing an answer to original question.

read full thread ... You asked what problem is ....it's hardware we can't fix hardware over the net. Could be any number of things.

(21 Jul '15, 12:22) Tilerone Tilerone's gravatar image

Ios 8.1 firmware signing window has been closed by the great apple inc. resore to 8.3 with itunes and use TaiG on the VM on your mac. Hope you had a icloud or itunes backup. If you saved the shsh blobs it could be a different story here. Get the blobs and stitch them to the 8.1 ipsw using a tool such as redsn0w and restore to it in itunes. Remember that blobs are device specific. You have them or you dont. Nothing you download off of google will change that.

link

answered 30 Jun '15, 04:51

D3ATHincarnate's gravatar image

D3ATHincarnate
-1914

Maybe I wasn't clear. My intention is to update to 8.3, I was just stating that the initial state was 8.1. The whole issue I have is that I can't restore to 8.3.

(30 Jun '15, 05:13) damnyouerror48 damnyouerror48's gravatar image
1

Don't worry, you were perfectly clear. :P

(01 Jul '15, 00:08) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,056
×1

Asked: 29 Jun '15, 08:05

Seen: 4,308 times

Last updated: 21 Jul '15, 12:25

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.