Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Details about device: iPad 4th Gen (Wi-Fi), iOS 7.1.2

The Problem: Sometimes when I open iFile the iPad gets stuck on the iFile splash screen and doesn't respond to any input except turning the screen off with the power button. In order to use the iPad again I have to force restart it by holding the power and home buttons.

The last time I did this my iPad rebooted in a safe mode-like state. It didn't come up with a notification telling me it's in safe mode, and it doesn't say safe mode in the status bar. I've tried rebooting at least 5 times. I can still use iFile and cydia, but it appears that all mobile substrate tweaks are disabled (No tweaks in the settings app either).

When I launch MobileTerminal it says "/usr/bin/loginL File does not exist /bin/login: File does not exist sh-4.0$"

I haven't installed or updated anything in cydia recently.

When I try to reinstall a tweak in cydia it returns "Sub-process /usr/bin/dpkg returned an error code (100)" I then click on restart springboard and it just says loading and the thing keeps spinning and it never resprings.

When I try to refresh sources in cydia, for each source it says "Could not execute '/usr/bin/gpgv' to verify signiture (is gpgv installed?)"

iCleaner force closes when I try to open it.

I don't really want to update to iOS 8 because I don't want my iPad to feel slower. I was thinking about trying semi-restore but I want to see if anyone might know how to fix the problem another way first incase semi-restore breaks something.

Any help would be great. Thank you.

asked 12 Jun '15, 21:24

gamerkonks's gravatar image

gamerkonks
1112

Did you search and delete anything using iFile? There is a documented bug with iFile that could be related to your issue.

(12 Jun '15, 21:47) justinred ♦ justinred's gravatar image

I've deleted things using iFile before, but not from the search function. I checked the iFile trash and nothing is there. All my apps seem to be working fine.

(12 Jun '15, 22:06) gamerkonks gamerkonks's gravatar image

can you reinstall cydia substrate?

(12 Jun '15, 23:26) justinred ♦ justinred's gravatar image

I can't reinstall anything in cydia. I get an error message "Sub-process /usr/bin/dpkg returned an error code (100)" Screenshot: http://imgur.com/TJoiGVA

(12 Jun '15, 23:31) gamerkonks gamerkonks's gravatar image

On another note, do you happen to have shsh blobs for 7.1.2 or any other iOS version? You'll soon be able to restore to those versions if you do. For the record, the iPad 4 (I have one) runs fine on iOS 8.

(12 Jun '15, 23:34) spockers ♦♦ spockers's gravatar image

I am grasping at straws but here is a previous posted fix by @britta that might help. Renaming instead of deleting would be better. Since offending tweak points to iFile, it may not work after this is done so I hope you have other ways for raw file access like openssh or afc2 installed.

(12 Jun '15, 23:42) justinred ♦ justinred's gravatar image

I can't find any of my SHSH blobs for my iPad unfortunately. I tried that fix, no noticeable change. iFile still works though, even after deleting the postinst file.

(13 Jun '15, 00:00) gamerkonks gamerkonks's gravatar image
Answer this question. (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,258
×711
×324
×128
×86

Asked: 12 Jun '15, 21:24

Seen: 994 times

Last updated: 13 Jun '15, 00:00

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.