Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i did a factory reset on my jailbroken iphone 4s running ios 8.1.2 and now its stuck on the "connect to itunes" screen whenever i try to boot it. i have tried restoring it using itunes but it didnt work. it says "unknown error 48" and fails.

plz help me fix this

asked 05 May '15, 07:20

rockprince's gravatar image


closed 20 Jun '15, 02:39

spockers's gravatar image

spockers ♦♦

Never ever reset/erase all whilst JAILBROKE. .

Put device in dfu mode and try restoring again .... Note you can only restore to 8.3

EASY DFU: Plug device into computer via USB. Don't look at the device, concentrate on the counting. Hold home+power for 10 seconds, then release power but keep holding home for 12 more seconds. Screen should be black.

(05 May '15, 07:28) Tilerone Tilerone's gravatar image

i tried restoring by putting into DFU mode but still didnt work .. got the same error

(05 May '15, 08:39) rockprince rockprince's gravatar image

i ma sure its Apple server problem, Only iPhone 4s users are now facing this error!

(04 Jul '15, 08:35) Shaeel Iqbal Shaeel%20Iqbal's gravatar image

The question has been closed for being "Comment button location assistance" by spockers, 20 Jun '15, 02:39

Delete the ipsw you are trying to use in iTunes. Quit iTunes then reopen it and let iTunes redownload the 8.3 ipsw and restore


answered 05 May '15, 11:28

Tilerone's gravatar image


I would recommend first to check the md5 or sha1 and compare with them here: [ ][1] (for iPhone 4s) and if it is the same there is no need to re-download(the problem might be something else), because re-download would mean 1.5G of wasted bandwith!

(05 May '15, 13:27) gdvkid gdvkid's gravatar image

You'll find it s the ipsw that's at fault or another error would have been given ...not error 48

(05 May '15, 13:38) Tilerone Tilerone's gravatar image

i checked the md5 for the ipsw and it was the same. i have tried deleting the ipsw used by itunes, exiting it, and redownloading it but still gives the same error.

(05 May '15, 22:27) rockprince rockprince's gravatar image

i tried all the above suggestions but it doesnt work ..

(05 May '15, 23:15) rockprince rockprince's gravatar image

I had the same problem earlier while restoring nonJB ipod touch (8.2). Try putting into recovery with RecBoot or ReiBoot and then restoring with itunes. That's what finally worked for me. If you want links, let me know.


answered 05 May '15, 14:15

Jailbreak82015's gravatar image


Take it to Apple store after Genius appointment, and let them Restore.

It appears to be hardware issue.


answered 06 May '15, 07:18

A08's gravatar image


I am sure this is not a hardware issue because i am experiencing the same exact problem. I have tried every options listed on forums including try to restore through MAC instead of windows but no success

(11 Jun '15, 07:32) cyborg7 cyborg7's gravatar image

@cyborg7 .... Your statement doesn't make sense that it's not hardware. I actual makes it point more to hardware issue given that you've tried everything.

Also please use the add a comment tab unless providing an answer to the original question.

(11 Jun '15, 08:10) Tilerone Tilerone's gravatar image

It doesn't make sense to assume that two people using the same device model can't both be experiencing hardware issues.

(11 Jun '15, 14:07) spockers ♦♦ spockers's gravatar image

@Tilerone .... that's my point, how come two people (may b there r more out there) with same device experiencing hardware issues soon after they factory reset a jailbroken iphone .

(11 Jun '15, 15:45) cyborg7 cyborg7's gravatar image

@cyborg7 The error has to be one of the following:

1. Software
2. Hardware

Since you've ruled out 1, then we have to at least consider 2, no? If I'm missing a third possibility, please let me know. Nothing reveals a hidden hardware issue like a restore, I've seen it many times. Example:

(11 Jun '15, 18:56) spockers ♦♦ spockers's gravatar image

NO NO NO and NO! You made a terrible mistake! You shouldn't try to restore because now you lost your jailbreak. You had to enter to recovery mode (Google it) and then download redsn0w (Google that to) and click on Recovery Loop Fix (or something like that). That should fix your problem. Now do not update your iPhone to iOS 8.4 (when it get released) until a iOS 8.3 jailbreak is released (in a couple of days).


answered 11 Jun '15, 09:22

JR2000's gravatar image


Dude, i have already tried those. No use :(

(11 Jun '15, 15:42) cyborg7 cyborg7's gravatar image

@JR2000... what do you mean by "Until a iOS 8.3 jailbreak is released (in a couple of days). For the time being, i don't want to jailbreak it but just want to restore/update to iOS8.3 which i can't because of error 48.

(11 Jun '15, 15:49) cyborg7 cyborg7's gravatar image

Almost done with all options given above, but still no luck with the 4s 48 error.. Isnt there a single genius here in this forum..


answered 19 Jun '15, 21:38

yuvirocks's gravatar image


Did you try restoring it on a Mac? Just throwing it out there.

(20 Jun '15, 00:01) Codyjd1 Codyjd1's gravatar image

Have you tried the option suggested by @A08?

(20 Jun '15, 02:40) spockers ♦♦ spockers's gravatar image

We are all genius here we are not magicians though and can not fix hardware issues over the net.

(20 Jun '15, 04:46) Tilerone Tilerone's gravatar image

@Tilerone - Didnt meant to be rude buddy. @Codyjd1- I have tried on my iMac & Macbook both, also used windows through parallel desktop, still the same 48 error. Also updated with the latest versions of itunes.

(20 Jun '15, 05:45) yuvirocks yuvirocks's gravatar image

See this thread. Error 48 is not listed in Apple's problem resolution.

Could be hardware issue.

(20 Jun '15, 09:57) A08 A08's gravatar image

Yup I agree with @A08 if restoring on both windows and a Mac didn't fix it then it's most defiantly hardware.

(20 Jun '15, 18:33) Codyjd1 Codyjd1's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 05 May '15, 07:20

Seen: 27,329 times

Last updated: 04 Jul '15, 08:35

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.