Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

In advance thanks for your patience. It isn't clear to mi this: My I4 is locked (usind gevey sim) 4.2.1/ 03.10.01, if I JB with sn0wbreeze or redsn0w will my BB upgrade too? will this FW update affect my chance to use the dev team unlock when/if available? I tried several times to use Pwnage tool, even received assistance here, but non of the help worked for me. I really would like to upgrade and jailbrake but don't want to screw up Thanks again!!

asked 07 Apr '11, 09:52

Rocketman's gravatar image

Rocketman
457211


Your current baseband will be presrved using either Pwnage/Sn0wbreeze and will have zero effect if DevTeam release updated unlock.

How did Pwnage fail for you?

link

answered 07 Apr '11, 10:00

venusanann's gravatar image

venusanann
13.3k11618

Did the custom FW build, entered succsssfully in DFU mode, but when trying to restore it didn't even started and a message appeared saying that could not connect to the server, try again later. Even though I'm connected, also tried with tinyumbrella but I think not doing ir right....

link

answered 07 Apr '11, 10:07

Rocketman's gravatar image

Rocketman
457211

Leave TU out of the process, you can do it easier with Pwnage, I'm wondering what your hosts file is pointing at, click on here gs.apple.com and post what you see.

(07 Apr '11, 11:10) venusanann venusanann's gravatar image

Index of /

Name    Last modified   Size    Description
TSS/    26-Mar-2011 04:01    -
TSS_/   11-May-2010 11:57    -

Apache/2.2.11 (Debian) DAV/2 SVN/1.5.1 mod_python/3.3.1 Python/2.5.5 mod_ssl/2.2.11 OpenSSL/0.9.8k mod_transform/0.6.0 Server at gs.apple.com Port 80

(07 Apr '11, 12:57) Rocketman Rocketman's gravatar image

Well your hosts file is not pointing at Apple and it needs to be, run TinyUmbrella and go to 'advanced' and look for 'set hosts to Cydia on exit' if it's selected deselect it, apply, exit, refresh browser and then click on the link ^^ again, you want to see an Apple 404 page, if you get that, try the restore again

(07 Apr '11, 13:03) venusanann venusanann's gravatar image

venusanann, did everything you told me, got the 404 error on the refresh, but after doing again the custom IPSW with Pwnage then when trying to restore with itunes, got the same error, not getting to connect to the apple restore server is there anything else? thanx

(07 Apr '11, 13:55) Rocketman Rocketman's gravatar image

Do you have active internet connection lol, what does itunes tell you if you connect your iphone to it, it must prompt you for 4.3.1 if you are on 4.2.1, if it offers to download (only) the 4.3.1 ipsw, let it do it to see if you at least connect to Apple servers.

Where did you get your 4.3.1 ipsw that you customised?

(07 Apr '11, 14:02) venusanann venusanann's gravatar image

Yes I do, is how I am communicating with you, it did prompt for 4.3.1 but I disabled it, is there any form I can download only this FW?, just to test if it gets connected to apple's server. I downloaded the ipsw from iclarified

(07 Apr '11, 14:13) Rocketman Rocketman's gravatar image

Well that's what I was trying to get you to do, download the 4.3.1 from Apple, try opening itunes/preferences/advanced and 'Reset Warnings' then restart itunes and reconnect your iphone and see if the box reappears. If it does just select 'Download Only'.

(07 Apr '11, 14:24) venusanann venusanann's gravatar image

Did all that, and finally yes its downloading, though its gonna take a while, once downloaded should customize again?

(07 Apr '11, 14:41) Rocketman Rocketman's gravatar image

Yep, start Pwnage in simple mode and it will auto find that 4.3.1 ipsw, once it shows up in the window you can select expert mode and move on from there, make sure to deselect 'activation' if you have an original carrier sim for activation, if not leave it checked. Finish the build, Pwnage DFU, alt - restore to custom ipsw and see what happens this time.

(07 Apr '11, 14:47) venusanann venusanann's gravatar image

I'm frustrated, done all that, and get the same error, :(

(07 Apr '11, 18:34) Rocketman Rocketman's gravatar image

Still can't connect to server?, might be worth manually looking at your hosts file, but I'm going offline in a bit (GMT) so if noone else helps you I'll catch you tomorrow.

(07 Apr '11, 18:39) venusanann venusanann's gravatar image

ok thanks for your help, should I continue my queries ?

(07 Apr '11, 19:07) Rocketman Rocketman's gravatar image

Open TinyUmbrella, click on the "Start TSS Server" button and leave it running while you restore.

(07 Apr '11, 19:22) spockers ♦♦ spockers's gravatar image

same thing, done it yesterday, done it again now, same result, I think I'm doing something wrong.....really frustrating

(07 Apr '11, 20:04) Rocketman Rocketman's gravatar image

If you're running the TSS server, it's just about impossible to not connect, it's connecting to your own computer. Do you have shsh's for 4.3.1 saved?

(07 Apr '11, 20:31) spockers ♦♦ spockers's gravatar image

yes should i mark that?

(07 Apr '11, 20:35) Rocketman Rocketman's gravatar image

Mark what? Just make sure you have 4.3.1 shsh's on your hard drive, then run TSS server, leave it running, shift-restore in iTunes.

(07 Apr '11, 21:03) spockers ♦♦ spockers's gravatar image

I've done exactly that, but still have the same result, cannot connect to restore server, try again later......I guess I'm frustrating you guys......

(07 Apr '11, 21:54) Rocketman Rocketman's gravatar image

Do you have a firewall running? That's the only thing that could prevent your computer from connecting to itself.

(07 Apr '11, 21:57) spockers ♦♦ spockers's gravatar image

no firewall that I know. The weird thing is that I downloaded 4.3.1 from itunes, but cant upgrade with itunes, also moved the custom ipsaw files and tried to restore with a pc (windows7) but gave me same result. Going offline now but gonna seek for help tomorrow, If somebody has something else just throw a lines, will continue tomorrow....thanks

(07 Apr '11, 23:01) Rocketman Rocketman's gravatar image

Is it possible that a sloppy JB on 4.2.1 could affect now? I rememeber that I did the JB with greenpoison and than redsnow. Would it help to do a fresh install of 4.2.1 and than go to 4.3.1?

(08 Apr '11, 08:40) Rocketman Rocketman's gravatar image

Alot of people done the GP/Redsn0w jailbreak combo for install of Cydia, so it can't be that, although anything is worth a try. I myself still reckon it's a host file problem because you can't connect to any servers, not even your own.

If you're still on the Mac, open finder and click on 'GO' in the menu bar ^^^, then select 'Go to Folder' and type /etc/ hit 'GO' and then double click hosts, it should open in TextEdit, and see what it contains, copy & paste it so we can see it

(08 Apr '11, 10:20) venusanann venusanann's gravatar image

##

# Host Database

#

# localhost is used to configure the loopback interface

# when the system is booting. Do not change this entry.

##

127.0.0.1 localhost

255.255.255.255 broadcasthost

::1 localhost

fe80::1%lo0 localhost

#74.208.10.249 gs.apple.com

#127.0.0.1 gs.apple.com

(08 Apr '11, 10:44) Rocketman Rocketman's gravatar image

I think Its something with the phone, I tried on windows and gave me 1016 error. Another detail that I mentioned before, is that I use the gevey sim interposer.....will try taking it out, and trying to restore. If you notice something with my host file please make me know. thanks

(08 Apr '11, 10:53) Rocketman Rocketman's gravatar image

No hashes (#) in front of those gs.apple ip addresses?, if not, either delete those two entries or add a # in front of each one and then save, have to drag/copy it to your desktop to do this then open it do the business, save and then drag it back to the /etc/ folder and replace the one that's there. Then try to the restore process again

(08 Apr '11, 10:54) venusanann venusanann's gravatar image

did that, and the same shit happened, gee don't know whats going on

(08 Apr '11, 11:14) Rocketman Rocketman's gravatar image

those hashes, should I delete them all? or only the ones in front of the addresses?

(08 Apr '11, 11:15) Rocketman Rocketman's gravatar image

We're only talking about the ones in front of the gs.apple addresses, leave the others alone, so if you have # in front of both of them, try starting the TSS server in TinyUmbrella, leave it running/open and then re open the hosts file and the # should be removed from the bottom one, just check that is happening.

EDIT:- You could also just delete both those gs.apple addresses and then restart Mac then try to restore again, without opening TU at all. Is itunes up to date, done a software update lately?

Also in the /etc/ folder scroll down to find hosts.umbrella file and select to move to trash and enter password, then try the restore again, but do not open TU as it will recreate that file. These are all things that I have done before when I had restore problems myself, albeit not identical to yours.

(08 Apr '11, 11:26) venusanann venusanann's gravatar image

took only those, I will try again with TSS open

(08 Apr '11, 11:29) Rocketman Rocketman's gravatar image

itunes is 10.2.1 but my OSX not (im on 10.6.6). From your edit: do you mean to erase at all both apple addresses?

(08 Apr '11, 11:59) Rocketman Rocketman's gravatar image

Yeah, just copy to desktop and delete those lines with gs.apple in them and then replace, can always manually edit them back in later.....also see more edits ^^^ if none of this works then I'll upload a copy of my hosts file for you to use.

(08 Apr '11, 12:02) venusanann venusanann's gravatar image

still not working same error, are your sure, the gevey sim has nothing to do?

(08 Apr '11, 12:15) Rocketman Rocketman's gravatar image

Well take it out then, other than being in the sim tray, I can't see how it can affect it. What is the error 'word for word'

Also download this hosts file and open it and see if it's identical to yours in your /etc/ folder, (it just has the gs.apple addresses removed)

(08 Apr '11, 12:18) venusanann venusanann's gravatar image

Its in spanish but I will try to translate: First extracts software and than this message: (The iPhone "iPhone" could not connect with the iPhone software restore server or it is temporally unavailable. Try again later.) The strange thing is that it connects to apple to download the software but not tu restore. What do I do with those host files that were modified?

(08 Apr '11, 12:37) Rocketman Rocketman's gravatar image

Just compared, its just the same.

(08 Apr '11, 12:41) Rocketman Rocketman's gravatar image

Weird, I'll rack my already fried brains and get back to you. Need to do some more digging.

(08 Apr '11, 12:44) venusanann venusanann's gravatar image

ok sorry for that, it might be a stupid omission I guess.....will wait thnx

(08 Apr '11, 12:47) Rocketman Rocketman's gravatar image

Finally I got to JB with windows snowbreeze and than restored with itunes, though I wonder what happened! Anyway thanks a lot!!!!

(08 Apr '11, 15:45) Rocketman Rocketman's gravatar image

Awesome! This one was a real head-scratcher.

(08 Apr '11, 15:57) spockers ♦♦ spockers's gravatar image

Yeah you can bet!!! thanks a lot!!!!

(08 Apr '11, 16:05) Rocketman Rocketman's gravatar image

Regarding this old problem while restoring with my macbook, still having the same problem, can somebody go back to check all this process and help please!

(15 Sep '11, 10:46) Rocketman Rocketman's gravatar image

Well if you still get that message then have a read through this and take any required action accordingly.

(15 Sep '11, 11:35) venusanann venusanann's gravatar image

its the other way around, this problem I'm having with my mac, I've accomplished the JB task with itunes/Windows but want to solve this. Is the exact problem you are pointing me, but with my macbook.

(15 Sep '11, 11:44) Rocketman Rocketman's gravatar image

Then google how to check/get access to the hosts file for your version of OSX and then post what it contains

(15 Sep '11, 13:01) venusanann venusanann's gravatar image

is there a specialized site where I can receive more specific help? I guess this issue is out of jailbreak issues, is more on hosts problems, I will appreciate

(15 Sep '11, 14:31) Rocketman Rocketman's gravatar image

my advice is to hash out all lines except for the one starting with 127.0.0.1, thats the only line that makes sense.

(15 Sep '11, 14:40) knightz4u knightz4u's gravatar image

Are those last lines ok:

#74.208.10.249 gs.apple.com

127.0.0.1 gs.apple.com

I've been reading that the last IP (127.0.0.1) is my own computer. Even if I delete and reboot, when I open itunes and try to do the restore thing in some point it comes back. The hash thing is a bit confusing for me....

(15 Sep '11, 15:18) Rocketman Rocketman's gravatar image

The hash tags tell your computer to ignore whatever is after them in the line, and you are right the 127.0.0.1 is your own computer, this is how the tinyumbrella TSS server uses the shsh saved on your hard drive to restore.

(15 Sep '11, 15:33) therealcmac therealcmac's gravatar image

Understood, so, what else can I do?

(15 Sep '11, 15:40) Rocketman Rocketman's gravatar image

Well on my Mac both of those gs.apple.com lines are commented out, and I can stock restore via apple servers.

(15 Sep '11, 15:49) venusanann venusanann's gravatar image

Insert a hashtag before all lines in your hosts file, the only line that is usually there is the one for localhost:

127.0.0.1 localhost

(15 Sep '11, 15:50) knightz4u knightz4u's gravatar image

OP, make it the same as what you posted further up there ^^^^, comment out both gs.apple.com entries, close and reopen itunes or just restart your Mac, then try the restore again. There's a tutorial here about adding a gs.apple.com entry, so just repalce that bit with adding a hash tag in front of your other gs.apple.com entry, ignore the tut title and just extract the info you need to do the editing of the hosts file

(15 Sep '11, 15:57) venusanann venusanann's gravatar image

That's the part were I'm stucked! this is how my hosts files looks like now:

Host Database

localhost is used to configure the loopback interface

when the system is booting. Do not change this entry.

127.0.0.1 localhost 255.255.255.255 broadcasthost ::1 localhost fe80::1%lo0 localhost

74.208.10.249 gs.apple.com

127.0.0.1 gs.apple.com

(15 Sep '11, 16:17) Rocketman Rocketman's gravatar image

You need to add a hash tag (#) to the 127.0.0.1 gs.apple.com entry

(15 Sep '11, 16:19) venusanann venusanann's gravatar image

After I add this hashtag to the last line, (as I did it before) do I need to restore, and open TU again? or just DFU it and restore it?

(15 Sep '11, 16:26) Rocketman Rocketman's gravatar image

Well this is to just enable a stock restore via Apple (TU must not be open when doing the restore), if you need to restore using locally saved shsh's then you open TU and run the TSS server. What exactly are you wanting to do?

(15 Sep '11, 16:38) venusanann venusanann's gravatar image

I would like to restore to a custom 4.3.3 IPSW. But I can also restore to stock 4.3.3 only that nothing seems to be working.

(15 Sep '11, 17:12) Rocketman Rocketman's gravatar image

k, so you've edited your hosts file right?

(15 Sep '11, 17:56) venusanann venusanann's gravatar image

yes, I did everything. Still appears the same message exactly after it tries to extract the ipsw file selected. I´ve tried with stock files and also custom ipsw with TU opened, this is how the last 2 lines are at the moment: #74.208.10.249 gs.apple.com

#127.0.0.1 gs.apple.com

With a PC, I don´t have any problems, but don´t have one on hand.

(16 Sep '11, 09:31) Rocketman Rocketman's gravatar image

Are you letting itunes locate the stock ipsw?, try deleting/removing the firmware ipsw from the iphone software updates folder, and then try to restore again, lets see if itunes can connect to the server to download an ipsw, logic says it wont, but try anyway.

(16 Sep '11, 10:54) venusanann venusanann's gravatar image

the folder is empty, and the stock ipsw I´ve downloaded from iclarified and is located at the desktop. With option+restore I select the file. I had done the 4.3.5 download to test that and it work, I mean it downloaded, I did it just to test but did not completed the download, that´s why the folder is empty.

(16 Sep '11, 11:16) Rocketman Rocketman's gravatar image

Well if itunes can download an ipsw then it must be connecting to the server, maybe the ipsw you downloaded is somehow corrupted. I'm also reading via google to have a space between the hash and the start of the line(s), although my hosts file isn't like that but, hey, it's wort a try, but first I'd let itunes download the ipsw and see if it restores it that way.

(16 Sep '11, 11:33) venusanann venusanann's gravatar image

ok let me download again, and I´ll come back in a few hours, thanks

(16 Sep '11, 11:44) Rocketman Rocketman's gravatar image

Although iclarified is a reputable site, I always recommend downloading firmware from here, but where ever it comes from you need to make sure it completes without interuption.

(16 Sep '11, 11:59) venusanann venusanann's gravatar image

Hi guys, me again, nothing seems to work over here. I´ve downloaded a fresh ipsw but the same message apperars....I am really frustrated with this issue, don´t know what else to do.

(17 Sep '11, 09:44) Rocketman Rocketman's gravatar image

Try a complete removal/reinstall of itunes

(17 Sep '11, 09:53) venusanann venusanann's gravatar image

After 2 days, I´m coming back, nothing above worked, as if nothing has been done, the same error pops up every time, no matter what.

(19 Sep '11, 11:13) Rocketman Rocketman's gravatar image

I'm back just to report that I did the CORRECT removal of iTunes, and voila! it finally worked. There was something wrong with my iTunes that was corrected when removed/reinstall. Just wanted you guys to know, after all, many of you scratched your heads with me for a long time, Thank you guys, very much!!!!!

(19 Sep '11, 16:31) Rocketman Rocketman's gravatar image

Excellent bit of news, well done, glad you got there in the end.

(19 Sep '11, 17:07) venusanann venusanann's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194

Asked: 07 Apr '11, 09:52

Seen: 3,083 times

Last updated: 19 Sep '11, 17:07

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.