Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i have a iphone 3gs baseband 6.15. it was on 4.2.1, but when i creat a custom firmware with sn0wbreeze to update the phone, i always get 1015 near the end. i tried using ireb and tiny umbrella to kick out of recovery, but it just goes back every time. any help please?

asked 05 Apr '11, 21:17

nymkhan8's gravatar image

nymkhan8
76226

any help?

(05 Apr '11, 21:44) nymkhan8 nymkhan8's gravatar image

You should try sn0wbreeze 2.5.1, just released. Changelog.

link

answered 06 Apr '11, 19:55

spockers's gravatar image

spockers ♦♦
69.9k3911660

TinyUmbrella's fix recovery doesn't work on 4.3.1. Try iREB (click the "Recovery mode loop fixer" tab.)

link

answered 05 Apr '11, 21:49

spockers's gravatar image

spockers ♦♦
69.9k3911660

i did, the phone just reboots then goes back to recovery (connect to itunes) screen.

(05 Apr '11, 21:51) nymkhan8 nymkhan8's gravatar image

Hmmm... Have you tried a stock 4.3.1 restore?

(05 Apr '11, 22:12) spockers ♦♦ spockers's gravatar image

@spockers the stock firmware will not work due to having the iPad baseband. It can only be restored with custom firmware. However do not try a bunch exit recovery tools in sequence, if you use one tool and it doesn't work then you need to restore to the custom firmware before trying the next recovery exit tool.

(05 Apr '11, 23:34) knightz4u knightz4u's gravatar image

@knightz4u Yep, my mistake. How can he restore again to cfw without getting into pwned dfu though?

(06 Apr '11, 00:12) spockers ♦♦ spockers's gravatar image

He can always get into Pwned DFU, using either iReb itself or the integrated iReb in Sn0wbreeze.

(06 Apr '11, 00:15) knightz4u knightz4u's gravatar image

my problems not getting into pwned dfu, but is error 1015 on itunes after i try to restore to a cooked 4.3.1 (bb 6.15). I made one my self and also tried downloading some off the internet, but they all give error 1015. when i try to restore to 4.2.1 (bb 6.15) it works (i had 4.2.1 before trying all this). so, any help?

(06 Apr '11, 18:42) nymkhan8 nymkhan8's gravatar image

What's the model number of your iPhone?

(06 Apr '11, 19:14) spockers ♦♦ spockers's gravatar image

5k92902***r, i used forecast. it's old botroom. i think.

(06 Apr '11, 19:26) nymkhan8 nymkhan8's gravatar image

my bad model: mb717ll

(06 Apr '11, 19:27) nymkhan8 nymkhan8's gravatar image

I just wanted to make sure it's a 3gs and not a 3g, you'd be surprised how many people think they have one device and actually have another. If you click gs.apple.com do you get an Apple 404 page, or cydia?

(06 Apr '11, 19:44) spockers ♦♦ spockers's gravatar image

thanx, worked like a charm!

link

answered 06 Apr '11, 20:41

nymkhan8's gravatar image

nymkhan8
76226

close please.

(06 Apr '11, 20:41) nymkhan8 nymkhan8's gravatar image

What worked like a charm? Sn0wbreeze 2.5.1? If so, accept the answer so it's flagged as correct when other people read it (click the checkmark to the left).

(06 Apr '11, 20:44) spockers ♦♦ spockers's gravatar image

o didn't know, i'll do that now.

(06 Apr '11, 20:45) nymkhan8 nymkhan8's gravatar image

Finally, I got it.

I think the main fact for occuring this problem was "being upgraded to baseband 06.15.00".

I'm using 3GS - FW version 4.3.1 - Baseband 06.15.00. Anyway, I got to solved it and the solution is below:

Requirements

Step 1 - Download iOS 4.3.1 and build an custom firmware using sn0wbreeze 2.5.1.Be notice to build with "Baseband Preservation Mode".

Step 2 - Restore 4.3.1 (official firmware) with iTunes 10.2.x . It will get an 1015 error before the restore would done. Don't worry, just unplug the cable, close iTunes, plug the cable back, enter DFU Mode using iREB-r4,then restore the custom firmware that built with sn0wbreeze.

Step 3 - After being restored, the iPhone will not open normally but will automatically enter DFU mode itself. The last thing you have to do is "open redsn0w as Administrator and jailbreak by checking Install Cydia".

Step 4 - Jailbreak with Cydia will last about 15 to 20 minutes, then you will see "Your iPhone is being unlocked" in iTunes.

I think iOS 4.3.2 can also be solved by using above methods. But you have to use sn0wbreeze 2.6 and redsn0w 0.9.6 rc13 instead of that I have mentioned above.

Sorry for my broken English? CHEERS~!!

link

answered 19 Apr '11, 16:27

sainyiphyo's gravatar image

sainyiphyo
1

@sainyiphyo the steps you mentioned are not the recommended way, but more of a histroy log of what you did. The recomended (and proper) way is after restoring with official 4.3.1 error 1015 comes up which can be fixed with "Exit Recovery" from either TinyUmbrella or iReb second tab.

Then you can run redsn0w 0.9.6rc12 (and now rc14) to jailbreak and install Cydia.

(19 Apr '11, 23:57) knightz4u knightz4u's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,524
×212

Asked: 05 Apr '11, 21:17

Seen: 5,665 times

Last updated: 19 Apr '11, 23:57

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.