Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

0
1

Yea, so I recently jailbroken my iphone 4, 7.1.2 and I got all the basic packages... But for some reason my winterboard isn't functioning properly. No matter what theme I choose, the background of my iphone doesn't change from what I had manually set from my images before. And it's not the themes, I've tried a lot of different themes that are known to work on my previous devices. I've tried uninstalling winterboard and reinstalling, nothing seems to work, any help would really be appreciated Thanks

asked 12 Oct '14, 10:44

Quicktatox's gravatar image

Quicktatox
11112

closed 13 Oct '14, 13:19

farahtwiggy's gravatar image

farahtwiggy ♦♦
6.4k37

The question has been closed for being "Argumentative" by farahtwiggy, 13 Oct '14, 13:19


With iFile, go to /var/mobile/library/preferences and delete any file that says "winterboard" and reinstall the tweak. If this doesn't work, then that means wallpaper themes are incompatible with iOS 7.

link

answered 12 Oct '14, 11:07

Tony99's gravatar image

Tony99
31.0k222337

edited 12 Oct '14, 12:35

-1

This is what cydia does when it removes the tweak

(12 Oct '14, 11:11) Aphex Aphex's gravatar image
1

You're wrong. The preference file stays on the device until you manually delete the file. When you remove a tweak, the preference file stays.

(12 Oct '14, 11:34) Tony99 Tony99's gravatar image

When I go to /var there's no "library". there is "Lib" but there's no /preferences in it

(12 Oct '14, 12:34) Quicktatox Quicktatox's gravatar image

I apologize, the location is actually /var/mobile/library/preferences

(12 Oct '14, 12:35) Tony99 Tony99's gravatar image

I tried that, but unfortunately it didn't work. Do you know any other way to fix it? I think the wallpaper should be able to change. Thanks for the help

(12 Oct '14, 13:09) Quicktatox Quicktatox's gravatar image

"If this doesn't work, then that means wallpaper themes are incompatible with iOS 7."

(12 Oct '14, 14:06) Tony99 Tony99's gravatar image

Check the wallpapers inside the settings app

(12 Oct '14, 16:43) rjr112487 rjr112487's gravatar image

I'm curious.. you don't mention that you checked if the wallpaper was enabled in Winterboard or in Settings. Just because you download a theme doesn't mean it's automatically enabled. I'd like to assume you know to check both, but one can't be certain when troubleshooting unless the user explicitly says... I'm not on a JB device at the moment, but I seem to recall having to enable my theme in Winterboard, then confirm in Settings. Good luck!

(12 Oct '14, 17:25) battlewithin battlewithin's gravatar image

@battlewithin "wallpaper themes are incompatible with iOS 7."

(12 Oct '14, 17:27) Tony99 Tony99's gravatar image

@tony99 "troll." You don't need to repost the same response 3 times. I used wallpaper themes on iOS 7. Some are compatible. Shoot, the dang wallpaper transferred to iOS 8!

(13 Oct '14, 06:15) battlewithin battlewithin's gravatar image

Ok i'll be more specific. On iOS 7.1, 7.1.1 and 7.1.2, the ability to apply wallpapers via winterboard stopped working. And no, i'm not trolling, I've been with this site for awhile now.

(13 Oct '14, 13:15) Tony99 Tony99's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,266
×425
×290

Asked: 12 Oct '14, 10:44

Seen: 3,920 times

Last updated: 13 Oct '14, 14:15

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.