Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

evasi0n7 can jailbreak iOS 7.0-7.0.6 untethered. p0sixspwn can jailbreak iOS 6.1.3-6.1.5 untethered (see here for 6.1.6).
How to jailbreak iOS 7.0-7.0.6 (and fix problems). iOS 7.1 is not jailbreakable, except an unsupported tethered iPhone 4 jailbreak.
Restoring or updating will update your device to iOS 7.1 and remove your jailbreak. There is no way to downgrade from iOS 7.1 to 7.0.x.

Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to chat, you can join us here (irc.freenode.net #JailbreakQA). Chat rules.

Hey guys, I REALLY need some help, this morning i tried to restore my jailbroken iPhone 3GS from 4.1 to 4.3.1, but it just got stuck when the bar on the iphone is loading, so i tried it two more times and it keeps getting stuck just under the apple logo.

I have Literally tried EVERYTHING, dfu mode does nothing, i used pwnage tool to build my own, the bar got a little further but still remaind stuck, the same happened when tryed using 4.2.1 instead of 4.3.1

ive been at it for hours SOMEONE PLEASE HELP ME OUT OF THIS MESS!

I have a Mac running 10.6.6 Snow Leopard

This question is marked "community wiki".

asked 04 Apr '11, 15:44

ShockZz's gravatar image

ShockZz
31227


I'll take a punt as I had a similar problem not long ago, do you have TinyUmbrella installed and your hosts redirected away from Apple? I found that opening TU when it got stuck kickstarted the process and it completed, or retry after deselecting 'set hosts to cydia on exit' in TU advanced, apply, exit.

No need to use custom firmware either unless you're preserving baseband, just restore to stock 4.3.1 and then run Redsn0w

link

answered 04 Apr '11, 15:51

venusanann's gravatar image

venusanann ♦
13.3k11618

edited 04 Apr '11, 15:56

I forgot about TinyUmbrella, I'll try that now.

Thanks

(04 Apr '11, 15:59) ShockZz ShockZz's gravatar image

Ok, open TU and make sure under 'advanced' you deselect 'set hosts to cydia on exit', apply, then exit. Click on gs.apple.com and make sure it goes to an Apple 404 page, if it doesn't reset safari and try again. Once done, try to restore again.

What is your baseband situation, are you using ultrasn0w for unlock or original provider sim, or factory unlocked?

link

answered 04 Apr '11, 16:34

venusanann's gravatar image

venusanann ♦
13.3k11618

IT ACTUALLY WORKS> Ive been trying to get my phone to start from bricked stage for, Id say 10 hrs, trying every single avenue on the net, and nothing worked. This actually worked. Just simply open Tiny Umbrella when the bar stops, and Walla! works like a charm. So glad I stumbled upon this. Thanks guys!

link

answered 13 Apr '11, 14:32

ffetishman's gravatar image

ffetishman
161

Lol, this has got to be the craziest fix ever, noone knows how it works under the hood, weird, but that is exactly what happened to me, the bar stopped and would not continue until I accidentally opened TU. I think i had wifi sync installed as well which doesn't help, so who knows what happened, when it fixes it you don't really care.

(13 Apr '11, 14:43) venusanann ♦ venusanann's gravatar image

When you open TU, it adds the cydia re-direct to your hosts file, regardless of the TU settings. If you have "Set hosts to cydia on exit" un-checked, then the entry gets commented out when you exit TU.

(13 Apr '11, 14:55) spockers ♦ spockers's gravatar image

I can't remember now, I know we had a time troubleshooting it, messing with hosts files and such, but it did do my head in tiny bit and I certainly aint going there again lol

(13 Apr '11, 14:59) venusanann ♦ venusanann's gravatar image

I tried opening TinyUmberlla when it gets stuck, but it just stays the same, I'm not too familiar with TU so I may be doing something wrong?

link

answered 04 Apr '11, 16:27

ShockZz's gravatar image

ShockZz
31227

Phew, Its done, I'm not sure what made it work but I tried restoring again it stopped at the same bit but then slowly creeped up and it seems fine now running 4.3.1

Thanks for the help

link

answered 04 Apr '11, 17:13

ShockZz's gravatar image

ShockZz
31227

Good stuff

(04 Apr '11, 17:14) venusanann ♦ venusanann's gravatar image

shockzz,

can you try to say what you may have done to fix it and anyone else can you try to help too? I have an Iphone 4 and was trying to do the same upgrade from 4.1 to 4.3.1. I have never really used tiny umbrella before so I do not know if i am doing in correctly. I unchecked as you guys had mentioned and then started the TSS server before I tried to update in Itunes. After trying a few more times I recieved this error message "the iphone "Iphone" could not be restored. An unknown error occurred (1013)." Does anyone have any other suggestions or more in detail suggestions to follow?

link

answered 05 Apr '11, 19:41

corallus05's gravatar image

corallus05
1

Do you need to preserve your baseband? That error means your baseband was not updated, but if you don't have a need to preserve it, no need to run TSS server.

(05 Apr '11, 19:47) spockers ♦ spockers's gravatar image

no, I was just hoping to get it back to the unjailbroken iphone firmware so baseband is not an issue i believe. In itunes, the error mentioned above does not always appear and the updating just pauses around 2/3rds complete on the iphone and almost 100% completed in iTunes.

(05 Apr '11, 20:49) corallus05 corallus05's gravatar image

Well to be honest I dont think it was TinyUmbrella that did it. TU was just open but I hadn't used it yet and I just tried to restore 1 more time and it worked. A friend of mine said he had the same problem and he just kept trying to restore and eventually it worked.

link

answered 06 Apr '11, 02:16

ShockZz's gravatar image

ShockZz
31227

So it only worked when TU was open?

(06 Apr '11, 02:27) venusanann ♦ venusanann's gravatar image

Well I dont think it was TU that did it since I had only just opened it and not even touched it yet, maybe just keep trying to restore and it will eventually work? or you could try it with TinyUmbrella open, it might do something?

(06 Apr '11, 02:41) ShockZz ShockZz's gravatar image

All I did was open it as well, still confuses me about what role it played, but it did do something lol

(06 Apr '11, 02:51) venusanann ♦ venusanann's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6,760
×2,830
×1,519
×1,259
×995
×897
×398
×212
×155

Asked: 04 Apr '11, 15:44

Seen: 6,131 times

Last updated: 13 Apr '11, 14:59

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.