Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

So basically im having a similar problem to the guy who posted here: http://www.jailbreakqa.com/questions/227606/imessage-wont-display-mms-files-and-im-out-of-ideas

I got a new iphone 5S 16gb and set it up as a new phone because i didnt have enough space on the 5S to transfer data from my previous iphone 4S 32gb. Because my text messages did not transfer, I decided to manually transfer the files from my iphone 4s (runing ios 7.0.6) to my iphone 5s (ios 7.1.2). So i copied the "/private/var/Mobile/Library/SMS" folder, and pasted it in my new phone.

Everything seemed to be working fine, i got all my previous texts however all new incoming photos (and i assume videos) do not display. it shows a question mark as shown in the reference link above. I tried to follow the same instructions, and changed the permissions of the SMS folder to 755 including all subdirectories and files, however when i reboot the phone, the newly sent picture imessages still do not display. All my previous imessage photos (the ones from my iphone 4s) show and display correctly.

It seems to be a problem with new imessage photos on my new phone only that are having this problem. Any ideas? i dont wanto reset my phone. Maybe there is a better way to transfer my SMS so its more compatible with the iphone 5s? maybe the db. files are structured differently and thats why its not working? dno. Any help is much appreciated!!!

Have you tried removing the 3 database files? Yes, it will remove your texts, but that's better than not being able to send/receive pics.

(26 Aug '14, 20:57) spockers ♦♦ spockers's gravatar image

I just tried that now, i deleted the sms.db, sms.db-shm and sms.db-wal, rebooted, sent an imessage photo, it sends correctly and is visible, but when i reboot the phone, i get the same problem, it shows a question mark instead of the photo.

so that didnt work.

(26 Aug '14, 21:31) jacob22 jacob22's gravatar image

Maybe you need to delete the attachments folder also, that's the only thing I can think of.

(26 Aug '14, 21:40) spockers ♦♦ spockers's gravatar image

i didnt try that yet, but thats really not what im looking for. The point is I wanto keep all my attachments and messages.

(26 Aug '14, 22:26) jacob22 jacob22's gravatar image

You could use something like DiskAid to export them as text and export the pictures.

(26 Aug '14, 22:30) spockers ♦♦ spockers's gravatar image

Did you recursively change the permission on the Attachments folder to 0700 Octal? If not, try that because that's how the other guy solved his problem thanks to @meteochu

edit: You can use winscp or the chmod command in terminal to do this

link

answered 27 Aug '14, 02:19

nimonster's gravatar image

nimonster
898511161

edited 27 Aug '14, 02:26

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×162
×104
×94
×83
×3

Asked: 26 Aug '14, 20:14

Seen: 24,427 times

Last updated: 27 Aug '14, 02:26

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.