Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Hi, I have an untethered iPad running 3.2.2 that has had jailbreak done using greenpois0n. I now wish to upgrade to 4.2.1 (or newer) and re-jailbreak or keep my existing jailbreak.

I understand how to jailbreak a new non-jailbreak apple device, but have not been able to find much info on upgrading the firmware on existing iPads that already have the jailbreak on them.

Can I downlowd an .ipsw file of the web and install it then run greenpois0n?

If I connect to iTunes and do the upgrade it will take me to the latest firmware which has not been publicly broken.

thanks, -B

asked 31 Mar '11, 14:44

bward76's gravatar image

bward76
1112


If you want to upgrade to 4.2.1 and rejailbreak you need to have 4.2.1 shsh's, do you have those?

link

answered 31 Mar '11, 14:48

venusanann's gravatar image

venusanann
13.3k11618

I understand that I can use tinyumbrella to get a 4.2.1 shsh from my 3.2.2 unit since it has an older firmware version. Is this correct or do I need to get it signed somehow through apple?

(31 Mar '11, 14:58) bward76 bward76's gravatar image

If you don't already have them then you cannot get them now, if you are currently jailbroken open Cydia and see if it lists any shsh's across the top of it's homepage, failing that use TinyUmbrella, connect and select ipad, hit 'save shsh' and watch the log to see what it tells you.

link

answered 31 Mar '11, 15:28

venusanann's gravatar image

venusanann
13.3k11618

If you want to install new firmware, you will always lose the jailbreak, but you can jailbreak it after the installation again.

To install any firmware, you need SHSH for that version. For the newest (currently 4.3.1) you get it from Apple. So if you want to install 4.2.1, you need SHSH backup. If you don't have it, you cannot get it anymore - from nowhere, and impossible to install firmware ever. But as you were jailbroken before, there is a good chance that you have a backup on Cydia server. Run TinyUmbrella, click Save All button and find out what versions were backuped on Cydia server. If you have 4.2.1 SHSH backup, just exit TinyUmbrella and install downloaded ipsw with iTunes. Then jailbreak with greenpois0n. Or you can also create a custom firmware and install that.

link

answered 31 Mar '11, 15:29

http's gravatar image

http ♦
5.3k423451

what "http" said is correct except for the "exit TinyUmbrella" part. It needs to be running when you run the restore of an old (4.2.1) version in iTunes otherwise it will fail.

(31 Mar '11, 16:55) Pepper ♦ Pepper's gravatar image

Actually it doesn't need to run, because TU changes your hosts file to point gs.apple.com to a Cydia server.

(01 Apr '11, 02:12) http ♦ http's gravatar image

Then you should also explain that you need to do a shift (PC) alt (Mac) - restore via iTunes, and select the appropriate ipsw

(01 Apr '11, 03:35) venusanann venusanann's gravatar image

You can jailbreak on 4.3.1, the issue is you'll be tethered, a few things aren't working right now. What's best to do is wait a week or so, the iPhone Dev Team will be releasing i0n1c's 4.3.1 untether any day now, just stay on 3.2.2 for a little longer friend!

link

answered 31 Mar '11, 18:35

perfectpete216's gravatar image

perfectpete216
1.1k202443

ok, so I installed tinyumbrella and connected my ipad. It shows that saved SHSHs for Brad's iPad are:

3.2.2 4.2.1 4.2b3 4.3 4.3.1

I guess since I have had this ipad jailbroke for so long Cydia automatically backs the up shsh files as Apple releases them?

So since my shsh was automatically saved for me via cydia when I jailbreak, this means I can install 4.2.1 (which is the best unteathered jailbreak right now.). I admit I'm not terribly familiar with iTunes, I don't see how I can install the ipsw using itunes. I have downloaded the 4.2.1 ipsw from a non-apple source.

All the help so far is much appreciated.

link

answered 31 Mar '11, 19:47

bward76's gravatar image

bward76
1112

That formatted my post a little strange. I do have the 4.2.1 shsh according to tinyUmbrella, as well as a few others.

(31 Mar '11, 19:49) bward76 bward76's gravatar image

You're good to go. Open iTunes, hold the shift key down (alt on a Mac) and click the "Restore" button. This will open a dialog to choose the ipsw. Pick the 4.2.1 file you downloaded. If it's from a non-Apple source, I'd trash it and get it from Apple. There's no telling what you're getting otherwise. Go to http://www.felixbruns.de/iPod/firmware/ and get it, it links directly to Apple, it's just laid out in a convenient drop-down selection list.

(31 Mar '11, 20:44) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,118
×730
×247

Asked: 31 Mar '11, 14:44

Seen: 6,952 times

Last updated: 01 Apr '11, 03:35

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.