Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Ok so I had an i4 4.2.1 OTB I restored with custom ipsw built using PwnageTool No Monte, then used gp so I could have animated boot, it was working perfect. Now I exchanged my i4 with another one that had bb 01.59 I did the same thing, restore with custom ipsw 4.2.1 and ran gp but it gets stuck either on "error no successful firmware download after 60000 ms...giving up" or "unable to mount user filesystem" so my question is there a way i can make both work? I tried restoring to official 4.2.1 with tinyumbrela to preserve bb but it gets stuck on dfu and the only way to get it out was custom ipsw. I just want animated boot lol is that too much to ask :p


I think first we need to get the phone to official 4.2.1 and boot it normally, as the custom firmware "may" be interfering.

Try to restore to official 4.2.1 ipsw, then after that use iReb to kick out of recovery, some people reported iReb to work when nothing else does.

After it's restored to 4.2.1 then you can run GP on top.

link

answered 01 Apr '11, 04:32

knightz4u's gravatar image

knightz4u
4.9k91828

I'll try that, I didn't use iReb before, I hope it works.

(01 Apr '11, 15:34) GHOSTYAIRO GHOSTYAIRO's gravatar image

Ok, with the official 4.2.1 you got a 1015 error, you can run greenpois0n at this stage to jailbreak and recover out of the DFU loop.

The second thing you mentioned are errors while running GP (this will be the same with official 4.2.1 firmware), in order not to have problems make sure you have the following: - Your computer needs to have Internet connection, GP downloads 2 files totalling about 5MB (iBSS and kernelcache). - Always extract greenpois0n before running (do not run it from within the zip file). - On subsequent runs (if you hit a snag) always delete the downloaded files (iBSS and kernelcache) before running GP again, to avoid having corruption in these files. - Your computer must have latest iTunes instaled. - Sometime firewalls or proxies could interfer with GP downloads, so try to avoid having them.

Once your jailbreak is good, you will see the GP boot logo, you can change this if you look in Cydia for "Boot Logo" then you can find plenty of alternatives.

Good Luck!

link

answered 31 Mar '11, 03:18

knightz4u's gravatar image

knightz4u
4.9k91828

Thanks, I have the latest version of iTunes, internet connection is fine, GP is out of the zip too, I'm using mac, where the iBSS and kernelcache are downloaded so I can delete them?

(31 Mar '11, 03:22) GHOSTYAIRO GHOSTYAIRO's gravatar image

i think it would be greenpois0n.app/Contents/MacOS

(31 Mar '11, 03:27) knightz4u knightz4u's gravatar image

Got them they were on my home folder, deleted them and started GP again, however same problem, also I started GP from terminal using sudo command and noticed a lot of "libusb:error" the last one was "libusb:error [darwin_transfer_status] transfer error: timed out Exiting libpois0n" I'll try to do a clean restore with official ipsw and use GP as you suggested and see what happens, thanks.

(31 Mar '11, 03:36) GHOSTYAIRO GHOSTYAIRO's gravatar image

Well, GP didn't boot up my phone after official/tinyumbrela restore, I restored with custom again, I guess I'll have no animated boot after all :(

(31 Mar '11, 04:03) GHOSTYAIRO GHOSTYAIRO's gravatar image

can you try greenpois0n on a different computer, sometime using a different USB port helps too, but i prefer trying a different computer (it should have iTunes installed).

(31 Mar '11, 04:54) knightz4u knightz4u's gravatar image

I'll try it on another computer at work and post results.

(31 Mar '11, 09:43) GHOSTYAIRO GHOSTYAIRO's gravatar image

Ok I tried with the computer at work, same story, it gives me the error no successful firmware... then unable to mount user filesystem, after about 3 minutes a bunch of code starts showing really fast and the phone boots up normally but no animation. This computer i am using right now, I've used to jailbreak all my cooworkers' and their friends family and dog's iphones lol, only mine has this problem, I wonder what that could be.

(31 Mar '11, 11:39) GHOSTYAIRO GHOSTYAIRO's gravatar image

Ok so finally got it working, I restored with official ipsw with TU on background, which I tried before but this time the phone ended up in recovery instead of DFU, then I used iReb but the phone went back to Recovery, then I used the Fixrecovery from TU and the phone booted up, ran GP and gave the same error but this time it continued and finally got the GP animation and everything works perfect so far, thanks @knightz4u

link

answered 01 Apr '11, 20:08

GHOSTYAIRO's gravatar image

GHOSTYAIRO
2976413

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,847
×105
×20

Asked: 31 Mar '11, 03:08

Seen: 2,778 times

Last updated: 01 Apr '11, 20:23

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.