Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Has anyone found a safe way to install the WWDC app on iOS 7.0.x? It says it requires iOS 7.1. I know you can go to System/Library/CoreServices and edit SystemVersion.plist, but if I do that will my iPhone 5 be able to reboot or will the untether fail and get me stuck in a reboot loop and force me to restore my iPhone? Has anyone tried changing SystemVersion.plist to fake iOS 7.1 with the evasi0n7 jailbreak?

Just in case anyone cares, I can confirm that editing SystemVersion.plist to iOS 7.1.1 and rebooting the device (tested on iPhone5,2 iOS 7.0.6) allows the installation of the WWDC app that requires iOS 7.1 or higher. I then reverted SystemVersion.plist back to 7.0.6 and rebooted again. The evasi0n7 untether is still fully functional and the WWDC app still works. I just tested it because I am about to restore to 7.1.1 to use the Pangu jailbreak, so I wasn't worried about breaking anything.

(26 Jun '14, 14:47) astrosfan1996 astrosfan1996's gravatar image

The question has been closed for being "Solved" by spockers, 01 Jun '14, 17:09


You should be able to download the last compatible version by downloading it via iTunes on your PC and it will install it to your device as it's downloading on your PC. Once it's complete you can delete the app off of your iPhone ( as it will not actually DL fully on your phone right away ) and launch the app store app on your iPhone and go to the purchased list and the app should be there with the cloud icon next to it. Select the cloud icon and it will ask if you want to download the last compatible version of the app.


answered 30 May '14, 09:13

Gsurels's gravatar image


edited 30 May '14, 09:17

By the way you will need to have the cloud turned on, on your iPhone to do it. I just tried it on my iPhone and it worked.

(30 May '14, 09:14) Gsurels Gsurels's gravatar image

It only ever supported iOS 7.1+.

(30 May '14, 09:17) iAdam1n ♦ iAdam1n's gravatar image

How's that possible when I just installed it successfully and used it on IOS 6.1.4 by downloading the version that was compatible for 6.1.4 ( when the app was purple )

(30 May '14, 09:20) Gsurels Gsurels's gravatar image

The old version from last year works but it doesn't have anything about WWDC 14

(30 May '14, 09:20) astrosfan1996 astrosfan1996's gravatar image

Got ya. Thanks for the clarification.

(30 May '14, 09:21) Gsurels Gsurels's gravatar image

How to: use iFunBox and navigate to /System/Library/CoreServices. Drag the SystemVersion.plist file on your desktop and edit it with these info: ProductBuildVersion 11D201, ProductVersion 7.1. Drag the edited file on the device back (overwrite the original one). Power off the device. Turn it on and please wait 1-2 minutes (evasi0n view and then a loading progress bar will be shown: don't worry). Check the current system version of Settings -> General -> Info. Download the WWDC 2014 app from AppStore.


answered 01 Jun '14, 11:39

mattewre's gravatar image


Not wise as this can cause issues with the untether.

(01 Jun '14, 12:52) iAdam1n ♦ iAdam1n's gravatar image

It doesn't. So please don't terrorise other users or downvote. Of course this is not a suggested method for unexperienced user. Please verify your statements (as I did, testing on my devices) and don't write "it can..". Evasi0n checks if the kernel is really from 7.0.x at boot, it doesn't trust the SystemVersion file.

(01 Jun '14, 12:58) mattewre mattewre's gravatar image

It can xD see the numerous posts on here where folks have screwed up messing with system version and ended up restoring.

(01 Jun '14, 13:03) Tilerone Tilerone's gravatar image

of course. Wrong edit of SystemVersion.plist can cause problems and can be dangerous. But not if it is correctly edited and not with Evasi0n untethered jailbreak (the device boots without any problems after that Evasi0n checks the kernel at boot -well.. the evasion tool that is automatically loaded after reboot scared me!-).

(01 Jun '14, 13:08) mattewre mattewre's gravatar image

So before I try this on my iPhone 5, have you actually tested this exact procedure? And if so, what device did you use? And I assume that using iFile would achieve the same result, right?

(01 Jun '14, 17:06) astrosfan1996 astrosfan1996's gravatar image

If you think having the WWDC app is worth losing your jailbreak for, just man up and restore to 7.1.1, because that's the likely end of this particular road.

(01 Jun '14, 17:08) spockers ♦♦ spockers's gravatar image

@mattewre It's really not a good idea to edit SystemVersion.plist ever, even if this worked for you in this specific case. A lot of things on the system depend on that version number being right; changing it can have unexpected side-effects.

(01 Jun '14, 17:28) britta britta's gravatar image

@spockers I am trying to get this app without losing my jailbreak, hence the "how do I install this on 7.0.x" question. I just wanted to see if anyone else had tried modifying SystemVersion.plist before I try it myself.

(01 Jun '14, 19:37) astrosfan1996 astrosfan1996's gravatar image

I understand. Even if they had, I wouldn't risk it, but that's just me. You'll be able to watch the videos without it.

(01 Jun '14, 21:29) spockers ♦♦ spockers's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 30 May '14, 08:58

Seen: 2,333 times

Last updated: 26 Jun '14, 14:47

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.