Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i have hit Reset all settings, weeks ago. ever since have tried everything I could find on the jailbreak boards to get things back to normal. Cydia apps are gone( hidden), like ifile. cydia tweaks are still there and it is still jailbroken. I can reach cydia tru http only, but cydia apps will not show. i have tried reinstall with ifunbox both ifile and cydia with .deb files. Did not work. I have run uicache, and rejailbreaked numberous times, also with removing the evasi0n icon.

my guess is i need to do a full reinstall of 7.0X, but i don't have a blob ( or whatever it is called) ( i am not very experienced with ios on deeper level, at least i was not before this problem). Is this even possible? i am afraid it is not and that hitting Reset is fatal.

someone have a tip? any questions i will be happy to answer thanks for reading

asked 08 May '14, 06:02

teknoid's gravatar image

teknoid
61125

edited 08 May '14, 17:05


You cant restore anything but 7.1.1 and it sounds like you clicked Erase all content and settings

link

answered 08 May '14, 06:04

theiphoneguy's gravatar image

theiphoneguy ♦
41.9k65420

i am sure i really hit reset all setting and not erase al. the apps are still there but hidden

(08 May '14, 06:08) teknoid teknoid's gravatar image

reset settings will not do that. No apple is NOT signing 7.0.4, ONLY 7.1.1

(08 May '14, 06:09) theiphoneguy ♦ theiphoneguy's gravatar image

thanks, is there any other way to load a fresh ios 7.04.

i am sure i have done a reset all without the erase part

(08 May '14, 06:11) teknoid teknoid's gravatar image

no

(08 May '14, 06:13) theiphoneguy ♦ theiphoneguy's gravatar image
-1

... it still jailbroken and cydia tweaks still work.

but i guess your Constructive NO actually means: I don't know

(08 May '14, 06:32) teknoid teknoid's gravatar image
1

i know the difference between "no" and "i dont know" thank you very much

(08 May '14, 06:42) theiphoneguy ♦ theiphoneguy's gravatar image
-1

but offcourse, just like i know the difference between Reset All and Reset and Erase all data. which would also be highly unlogical for me to do.

and the sound not working? don't know? thought so, bye!

i will look for a real knowledgeable and helpful board so many wannabees around

P.S. keep it up calling people liers in the most unconstructive way

(08 May '14, 06:55) teknoid teknoid's gravatar image
1

In this case see if semi-restore helps.

(08 May '14, 06:57) A08 A08's gravatar image

adios and its obvious english is not your first language. Saying "it sounds like" is nowhere close to "i think you are lying"

(08 May '14, 07:01) theiphoneguy ♦ theiphoneguy's gravatar image

that sounds good a08, i will look i will look into that. Thank you so much

(08 May '14, 07:02) teknoid teknoid's gravatar image

@AO8 : i have done the semi restore and rejailbreaked. still no cydia icon and no ifile and all, even though i could install ifile, and it's status is installed. But most dissapointing: still the audio problem.

but thank you very much for your help anyway! much appreciated!

if anyone has an idea please don't hesitate to respond...

(08 May '14, 09:10) teknoid teknoid's gravatar image
-1

closed?

closed with unsolved problem

after getting wrong information and rudeness from iphoneguy

once more for the record: i did not Erase all content and settings. all my data was still there: wav files, pdf files, everything. All the cydia apps where on my device but without icons. the cydia tweaks where still functioning. i guess i have a problem some techies can not solve. what they can do is pressing 9 karma points down, stick to the dogma and close the thread.

Nice Karma system b.t.w. ...works really well... Really shows the state of humanity

(08 May '14, 09:22) teknoid teknoid's gravatar image
1

Are you able to boot the iDevice in safe mode - the holding Vol up button trick while it boots.

(08 May '14, 10:19) A08 A08's gravatar image

@A08 that wont help any, just like semirestore didnt help. Semi restore doesnt fix a broken jailbreak like that.

@teknoid its closed for being argumentative. I said "it sounds like" and then i said "reset settings wont do that" because it doesnt do that. you then asked if you could restore 7.0.4 at all and i answered "no" and you decided to become argumentative and insulting.

(08 May '14, 12:48) theiphoneguy ♦ theiphoneguy's gravatar image
1

This is why you install ResetAllKiller from Cydia........

(08 May '14, 12:51) Spydar007 Spydar007's gravatar image

since when is being ''argumentative" something wrong? Fact is i did not reset and Erase all content and data, and i have 2 gigs in pictures to proof it?

@A08 : thank you, I will try that

(08 May '14, 15:25) teknoid teknoid's gravatar image
1

Here's what to do. 1. Go to cydia through safari (cydia://) 2. Install OpenSSH 3. On your PC, install Putty (for windows). 4. SSH into your iPad (you can search it up if you don't know how. 5. Go to var/mobile/Library/Caches 6. Remove com.apple.installation.plist 7. Reboot your iPad

(08 May '14, 16:33) adzyu100 adzyu100's gravatar image

@teknoid whether or not you did erase or just did reset is mostly irrelevant. i did not call you a liar. you are calling names and trying to be insulting.

Any other questions?

(08 May '14, 16:57) theiphoneguy ♦ theiphoneguy's gravatar image

i know it is 'irrelevant' to you. that is very clear. Relevant to you is the whole 'karma' number game, and go around the subject and specially around fact that you don't know.

if you had expressed yourself better than a single No to a post with two statements there would not have been any misunderstanding at all. Then in a hurry you close a post where you have no answers for, it seems for constantly different reasons.

(08 May '14, 17:12) teknoid teknoid's gravatar image

dear adzyu100. thank you for responding! i have tried to delete other files like that, but not the one you mention. So I will try that now thanks again!

(08 May '14, 17:24) teknoid teknoid's gravatar image

@teknoid

1. i answered "no" to restoring 7.0.4 and i ignored the "you are sure you didnt erase" cause us arguing over that doesnt get you any closer to fixed..

2. see the second part to #1 for why i said that part is mostly irrelevant.

3. Karma is just a number. I can answer questions the same. Look here to see my karma history. ive given it all away a couple times.

4. I was in no hurry to close it till you decided to attempt at being offensive.

5. I already know karma and ego are not the same.

(08 May '14, 17:32) theiphoneguy ♦ theiphoneguy's gravatar image

dear theiphoneguy, i have other problems on my head then to look at your great karma history. when i look at mine after just politely looking for help and telling the truth I can see that i have no interest in that system whatsoever. now excuse me as i go try to fix my ipad, what i have been trying to do for weeks now. i am still sure i did not erase, and you denying that have not brought me any closer to a fix indeed. rather further...

thanks for your time. next time better i hope

(08 May '14, 17:51) teknoid teknoid's gravatar image

@ afzyu100 : i have done that just now, and it did not fix it. While doing it I remembered I tried this before. as i said i have allready tried most possible solutions that are mentioned in the forums.

thanks for your interest. still no solution bummer, (even though this question is 'closed'...)

(08 May '14, 17:58) teknoid teknoid's gravatar image

@teknoid thats the part im more confused about. Not the reset or erase. You have ifile etc so there should be a couple working recovery methods. The one that should specifically work is:

On the ipad, open safari and click the following link (or type it in) http://apt.saurik.com/debs/cydia_1.1.9_iphoneos-arm.deb and it should ask about opening or installing with ifile. tell it yes. did cydia come back?

Not sure if thats what you meant you tried where you said you tried with ifile, ifunbox and debs. if you have tried that, im confused why that isnt working

(08 May '14, 18:09) theiphoneguy ♦ theiphoneguy's gravatar image

@theiphoneguy. nice of you to help me... ( i tried manually install cydia 1.1.9 before) . this time i clicked the link and i saw ifile working for the first time since the problem occurred: the ifile icon is/was gone too. unfortunatly it did not make cydia or ifile or any other cydia app come back. i choose 'installer' and i did reboot. thanks for your interest! still no luck...

(08 May '14, 18:20) teknoid teknoid's gravatar image

see thats the part thats getting me is why is that not working, it should

(08 May '14, 19:09) theiphoneguy ♦ theiphoneguy's gravatar image

i soo wish it did... worse thing is that i can t use ifile anymore. that and no cydia tweaks offcourse...

(08 May '14, 20:17) teknoid teknoid's gravatar image
1

Delete cydia substrate it will delete all the tweaks on the phone and bring it back to normal jailbreak state then all you have to do after deleting cydia substrate all your tweaks and cydia stuff will be gone as soon as it's done reinstall cydia substrate do not turn the phone off without reinstalling it once done you can install your tweaks and cydia apps again and all will be fine I had the same problem I reset all settings in general settings area and it stuffed everything up if you do what I have stated it will fix the issues you are having I know first hand it works

(09 May '14, 00:18) Jaydoxxx Jaydoxxx's gravatar image
1

how are they going to do that if they cant open cydia? did you read all the comments?

(09 May '14, 00:46) theiphoneguy ♦ theiphoneguy's gravatar image

hi Jaydoxx, thank you for your reponds! I did just that now: going to cydia tru safari and uninstall cydia substrate. the device rebooted after: i was forced to choose Respring. i then reinstalled cydia substrate. but all is still the same. If i try to open ifle by typing ifile:// in safari it will show the ifile startup screen for a few seconds, then goes back to the homescreen...

@ theiphoneguy: any chance this question could be re-opened?

thanks everybody for anticipation!

(09 May '14, 03:30) teknoid teknoid's gravatar image
1

Done (reopened)

(09 May '14, 03:32) theiphoneguy ♦ theiphoneguy's gravatar image

thanks!

(09 May '14, 03:42) teknoid teknoid's gravatar image

@Jaydoxx: i tried again and this time i 'tricked' cydia into not rebooting after uninstall and reinstall of cydia substrate. but my cydia apps where not all gone: for instance ifile is still 'installed', even though i don't know how to start it up...

(09 May '14, 03:52) teknoid teknoid's gravatar image
2

I did read it and I had the same problem and fixed the way I told him to do it why did you have to thumbs down my comment for trying to help the bloke smh

(09 May '14, 03:57) Jaydoxxx Jaydoxxx's gravatar image
1

I'm in the same boat. A workaround for me so far is to use activator to make shortcuts for cydia and related apps as it can see them as system applications in it's settings.

(09 May '14, 03:57) rubycerebra rubycerebra's gravatar image

hi rubycerebra,

hmmmm sounds interesting but i think i have lost activator along the way, ( when doing the semi restore) . lets see if i can make that work... at least it is something...still it feels that it should be fixable, with one little tactical tweak don't it?

(09 May '14, 04:02) teknoid teknoid's gravatar image
1

Sorry mate of I add any comments to try help you resolve the same issue I had and I fixed it and now my phone is working perfectly theiphoneguy fellow on here will just give me negative points I would really like to help you resolve your issue but I'm going to get that everytime I comment I come on here to help and not get shot down and negative points from theiphoneguy otherwise I would help you fix the same issue you have a I not long ago did myself and fixed

(09 May '14, 04:02) Jaydoxxx Jaydoxxx's gravatar image

nope, only if you dont read it all :p

(09 May '14, 04:03) theiphoneguy ♦ theiphoneguy's gravatar image
1

I had the exact same problem on my phone and fixed I did read it all and how the hell would you know if someone didn't read something lol what are you a psychic no your not your assuming

(09 May '14, 04:14) Jaydoxxx Jaydoxxx's gravatar image

by rubycerebra's tip i installed activator and tru that i can now startup ifile at least. Win!

(09 May '14, 04:23) teknoid teknoid's gravatar image
1

Having no problems with using activator but it would be nice to get back to a full jailbreak. There must be a way as it seems only a small problem.

(09 May '14, 04:27) rubycerebra rubycerebra's gravatar image

Why must there ?

(09 May '14, 04:28) Tilerone Tilerone's gravatar image

hi Tilerone, thanks for your input!

Jaydoxx says he fixed the issue... and it does seem like a problem in the 'user interface', not in the jailbreak, so thats why we think it seems fixable....

thanks for your anticipation!

(09 May '14, 04:38) teknoid teknoid's gravatar image
1

Be nice if everyone used the add a comment tab unless answering the original posted question xD

Yeah he fixed HIS issue but different users have different factors effecting it such as bad reps and tweaks etc. what works for one doesn't work for everyone...... We have hundreds of threads like your where cydia isn't obtainable except through safari, and they DONT all get fixed. Another work around is creating a homescreen shortcut to cydia and replacing icon with a cydia .png it's not a fix ....just a workaround

(09 May '14, 05:18) Tilerone Tilerone's gravatar image

some users cant see the add comment button like its not there. unknown why and not any specific reason some users it doesnt display

(09 May '14, 05:23) theiphoneguy ♦ theiphoneguy's gravatar image
1

Since you can access cydia via safari, reinstalling the apps like ifile in cydia will make the ifile icon reappear. Also try clearing uicache and reinstalling cydia substrate.

(09 May '14, 05:31) justinred ♦ justinred's gravatar image

@ justinred: I allready did al that and for numberous times :(

@ Tilerone : thanks for the workaround, will be usefull

(09 May '14, 05:53) teknoid teknoid's gravatar image

correcting your karma so if it pops a message saying awarded on an answer and you dont see it, its just me working it :)

(09 May '14, 06:12) theiphoneguy ♦ theiphoneguy's gravatar image

@ justinred: how do you clear uicache?

(09 May '14, 07:18) teknoid teknoid's gravatar image
1

Using ifile or ssh, backup and delete /var/mobile/Library/Caches/com.apple.mobile.installation.plist and /var/mobile/Library/Caches/com.apple.LaunchServices-xxx.csstore then reboot.

(09 May '14, 08:14) justinred ♦ justinred's gravatar image

@ justinred: I just did it (and did it before, numerous times). I then uninstalled ifile en re-installed it after but nothing changed. All the apps are still there, just the springboard icons are all gone...

(09 May '14, 11:19) teknoid teknoid's gravatar image

still no solution for this

(10 May '14, 06:38) teknoid teknoid's gravatar image

Try hitting reset all settings again..:P

(10 May '14, 06:55) Jbkidi5 Jbkidi5's gravatar image
1

Only my solution for it the way I fixed it I can tell you how and help you fix it but everytime I say something on here I get down voted and points deducted from theiphoneguy on here I had the exact same problems when I hit reset all settings and it stuffed out exactly the same as yours mate and is now 100% fixed

(10 May '14, 20:44) Jaydoxxx Jaydoxxx's gravatar image
1

I know Jaydoxx, and it is more than riddiculous that... in fact this thread is the story of people with high reputation points not being very constructive and even obstructing well-willing and helpful people like you to anticipate and come to a solution. But please give it a try anyway please. I have looked at your past forum activity and you do a lot of helping people so that is real 'karma points' to me... maybe shoot me an email ;) thanks!

(11 May '14, 05:05) teknoid teknoid's gravatar image
1

@jaydoxxx and @teknoid......

What works for one doesn't always work for another as info is left out and there can be too many other factors influencing the outcome of a so called solution.

Saying " this IS the fix " is why downvotes can occur as a lot of experienced folk Know that the response should be "this may help"

We've seen this issue thousands of times and there's never a straight forward " this works solution" it's always try this ....then try that.

And sometimes there is no solution. (The joys of jailbreaking AND user error)

Do t dwell on down votes .... Karma means nothing really ......but bare in mind those with very high karma get it for one reason alone ....... They DO KNOW WHAT THEY ARE TALKING ABOUT.

(11 May '14, 06:46) Tilerone Tilerone's gravatar image

@ Tilerone. read this thread from the start to see who are actually trying to fix the problem and who are not and keep on going off topic...

(11 May '14, 08:07) teknoid teknoid's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,258
×125
×100
×58

Asked: 08 May '14, 06:02

Seen: 2,761 times

Last updated: 11 May '14, 08:15

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.