Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

After upgrading to Cydia 1.1, on iPhone 4 using v4.0.1, my iPhone is stuck on boot scrren. I've done the following: 1. Enter DFU mode. 2. Started Tiny Umbrella. Started TSS server. Under recovery devices, shows me ECID (DEC) 457522620 & ECID (HEX) 1B453DBC. Nothing listed under Saved SHSHs for 457522620. Device model - INVALID. 3. Started iTunes. 4. Attempted regular restore to existing v4.0.1, soft restoring to downloaded firmwares v4.0.1 & v4.1. 5. All attempts yield, "The iPhone could not be restored. An uknown error has ocurred (3002)." 6. All attempts have failed. 7. Tried using iRecovery, however I can figure out how to install the libusb-1.0.8. 8. Tried jailbraking with Green Poison.

asked 28 Mar '11, 10:58

Qletis's gravatar image

Qletis
113

edited 28 Mar '11, 10:59


link

answered 29 Mar '11, 04:28

ggonxhi's gravatar image

ggonxhi
161

That's cool, didn't know that was possible, thanks.

(29 Mar '11, 11:02) spockers ♦♦ spockers's gravatar image

So you don't have any shsh's?, when you jailbroke at 4.0.1 did you not select 'make my life easier' when you first opened Cydia?

I take it you have/had the 1.59.00 unlockable baseband and you wish to retain that...yes?

I think worst case scenario is that you tweet or go through the tweets of @notcom, the TinyUmbrella dev, and try to find out if the TU update method with baseband preservation, includes going to 4.3.1, and there you'd have to sit and wait for a jailbreak to get at ultrasn0w.

link

answered 28 Mar '11, 11:43

venusanann's gravatar image

venusanann
13.3k11618

edited 28 Mar '11, 11:47

When I jailbroke, last year, I selected make my life easier on Cydia. I dont care which firmware v4.0.1 or better, I just want to restore my bricked iPhone.

Ive made it 3/4 of the way through restoring on both v4.0.1 and v4.1, then iTunes errors and restore fails. I've tried restoring both v4.0.1 and v4.1. 3/4 way through restoring, iTunes verifies, then fails.

(28 Mar '11, 12:47) Qletis Qletis's gravatar image

What errors are you getting from itunes?, did you use ultrasn0w for service?, are you using shsh's to restore to 4.0.1?

(28 Mar '11, 12:50) venusanann venusanann's gravatar image

I dont know how to obtain my SHSH's. During restoring, the progress bar moves ~3/4 way across, using both v4.0.1 or v.4.1, then errors. Now, instead of being stuck on boot screen , I'm now stuck at restore screen with iTunes and cord icons.

(28 Mar '11, 22:48) Qletis Qletis's gravatar image

Get TinyUmbrella, run it, connect your iPhone, hit "Save SHSH" and see what the log says. If it says you have 4.2.1, click "Start TSS server", leave TU open, grab a copy of your 4.2.1 firmware, open iTunes, hold shift(alt on a Mac) and click restore. Point it to your 4.2.1 ipsw, let it do it's thing. You will get an error at/near the end, probably 10xx, that's normal. It means you're in recovery loop. Get iREB and click the "Fix recovery mode loop" tab. That's for Windows. If you're on a mac, you can try the recovery fix button in TU.

link

answered 28 Mar '11, 22:53

spockers's gravatar image

spockers ♦♦
69.9k3911660

edited 28 Mar '11, 22:55

The save SHSH is grey'd out.

(28 Mar '11, 23:08) Qletis Qletis's gravatar image

Select your phone on the left.

(28 Mar '11, 23:09) spockers ♦♦ spockers's gravatar image

Additionally, I cant get any of the restore to occur with TU open, only restores with TU closed, but fails ~3/4.

(28 Mar '11, 23:09) Qletis Qletis's gravatar image

Can't download iREB either. I click on the link and irc chat box appears.

(28 Mar '11, 23:11) Qletis Qletis's gravatar image

It's the big blue button in the middle. A box will pop pup with a Windows / Mac choice.

(28 Mar '11, 23:12) spockers ♦♦ spockers's gravatar image

Fails with what error?

(28 Mar '11, 23:12) spockers ♦♦ spockers's gravatar image

Ok, Ive downloaded it. Do I have to have TU open? If so, the restore never occurs.

(28 Mar '11, 23:15) Qletis Qletis's gravatar image

Isnt v4.2.1 for Verizon only?

(28 Mar '11, 23:17) Qletis Qletis's gravatar image

No, that's 4.2.6. You need TSS server running if you want to preserve your baseband. What error NUMBER does iTunes fail with?

(28 Mar '11, 23:25) spockers ♦♦ spockers's gravatar image

I unplugged iPhone and polugged back in. It booted into v4.1!! Wow! Close call..Should I update to v4.2.1?

(28 Mar '11, 23:34) Qletis Qletis's gravatar image

If you have shsh's for 4.2.1. If not, you can't. Apparently you do, though, or you'd have ended up on 4.3.1 instead of 4.1.

(28 Mar '11, 23:35) spockers ♦♦ spockers's gravatar image

I deleted the host file, since it was point towards Cydia. Also, I had all the SHSH's saved by Cydia, starting with v4.0.1. How I get those?

(28 Mar '11, 23:37) Qletis Qletis's gravatar image

Get TinyUmbrella, run it, connect your iPhone, hit "Save SHSH" and see what the log says. Read my answer above again.

(28 Mar '11, 23:38) spockers ♦♦ spockers's gravatar image

I started TU. Says I have the following SHSH's: iPhone4 4.1 (8B117) iPhone4 4.2.1 (8C148) iPhone4 4.2B3 (8C5115c) iPhone4 4.3.1 (8G4)

(28 Mar '11, 23:41) Qletis Qletis's gravatar image

Also reads, "Cannot Start TSS Service DO NOT TRY RESTORING YOUR DEVICE!!! Your hosts file is not writable!"

(28 Mar '11, 23:41) Qletis Qletis's gravatar image

OK you're in good shape. You can restore to any of those versions.

(28 Mar '11, 23:42) spockers ♦♦ spockers's gravatar image

Make sure the TSS server is running in TU if you want to keep your current baseband.

(28 Mar '11, 23:43) spockers ♦♦ spockers's gravatar image

Since, I've deleted the host file. When starting TU, I get, " "Cannot Start TSS Service DO NOT TRY RESTORING YOUR DEVICE!!! Your hosts file is not writable!"

(28 Mar '11, 23:48) Qletis Qletis's gravatar image

You deleted your hosts file. You need to create a blank one and try again.

(28 Mar '11, 23:50) spockers ♦♦ spockers's gravatar image

Should I use Green Pois0n or Redsn0w to jailbrake?

(28 Mar '11, 23:50) Qletis Qletis's gravatar image

How do I create 1? Cuz and paste urs here? I'll save as host file?

(28 Mar '11, 23:52) Qletis Qletis's gravatar image

Are you on Windows or mac?

(28 Mar '11, 23:56) spockers ♦♦ spockers's gravatar image

Don't get ahead of me here, we'll jailbreak after you get some firmware installed.

(28 Mar '11, 23:57) spockers ♦♦ spockers's gravatar image

Im on windows. I've restored my previous back up & iTunes is finishing backup on v4.1.

(28 Mar '11, 23:59) Qletis Qletis's gravatar image

BTW, do u have Skype? Wud be easier...

(29 Mar '11, 00:00) Qletis Qletis's gravatar image

Yes, but my wife's asleep 10 feet from me, don't wanna wake her up. This will have to do. Just right-click your desktop, choose New->Text document, rename it to HOSTS and copy it to C:\Windows\System32\drivers\etc then try TSS server again. Make sure it's just named HOSTS not HOSTS.txt

(29 Mar '11, 00:04) spockers ♦♦ spockers's gravatar image

Im ready to jailbreake v4.1.

(29 Mar '11, 00:16) Qletis Qletis's gravatar image

OK proceed with my answer above, just use 4.1 instead, same steps.

(29 Mar '11, 00:18) spockers ♦♦ spockers's gravatar image

My iPhone is up and running v4.1 with all my settings restored, contacts, texts and emails...

Just waiting to jailbrake now.

(29 Mar '11, 00:20) Qletis Qletis's gravatar image

You're probably wondering why I'm telling you to restore. It always works better if you start with a clean restore. If you don't want to, you can proceed directly to limera1n.com and run that, but if it hangs, just restore as above.

(29 Mar '11, 00:21) spockers ♦♦ spockers's gravatar image

I did a fresh restore to v4.1. limera1n will do v4.1? What about Green Poison or Redsn0w?

(29 Mar '11, 00:23) Qletis Qletis's gravatar image

Yes, no, and no. Limera1n's easier anyway.

(29 Mar '11, 00:24) spockers ♦♦ spockers's gravatar image

Piracy is forbidden here, you'll have to figure that out by yourself.

(29 Mar '11, 00:32) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 28 Mar '11, 10:58

Seen: 1,695 times

Last updated: 29 Mar '11, 11:02

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.