Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I'm looking at http://apt.saurik.com/debs/ and there are different versions still available. Although, I don't know how long these versions will be there. Is it possible to make Cydia install an older version instead of always the latest one?

asked 10 Mar '14, 23:01

radj's gravatar image

radj
81611

The packages will never be removed. Why do you want to downgrade a package anyways? The latest version always has the least amount of bugs and glitches.

(10 Mar '14, 23:03) Will0401 Will0401's gravatar image

Not via the cydia GUI, but you can do it manually using several different methods the easiest of which is iFile in my opinion. Why would you want to though?

(10 Mar '14, 23:03) spockers ♦♦ spockers's gravatar image

Investigative purposes. Seeing what changed between versions.

(10 Mar '14, 23:06) radj radj's gravatar image

Ha, that's why there's a changelog. :P

(10 Mar '14, 23:07) Will0401 Will0401's gravatar image

But not all details are in the changelog. And I want to try out the older versions for myself :)

(10 Mar '14, 23:08) radj radj's gravatar image
1

Put the deb file on your iOS filesystem using something like iFunbox, then open it with iFile and choose "Installer." I believe you can also enter the deb URL in Safari and choose iFile to open it with.

(10 Mar '14, 23:09) spockers ♦♦ spockers's gravatar image

Download iFile from Cydia.

Download the .deb you want to install from Safari on the device.

Say "Open in iFile."

Press Installer, and bazinga, you've installed the older version of the package.

link

answered 10 Mar '14, 23:10

Will0401's gravatar image

Will0401
14.1k132224

Hmmm. It merely runs dpkg on the .deb file (which I have tried) but it doesn't resolve dependencies like Cydia does. This leads me to a new question... how does Cydia resolve dependencies? I search for the dependency via Cydia but it's not there (ie, libvncserver).

(10 Mar '14, 23:21) radj radj's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×4,404
×66
×38
×15

Asked: 10 Mar '14, 23:01

Seen: 2,117 times

Last updated: 11 Mar '14, 00:04

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.