Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

1
1

I bought packages in the BigBoss repo (CameraTweak2, Springtomize 3, etc) and after upgrading my 5s to 7.0.6 many of the tweaks I bought can no longer be found. Has anyone else had this problem?

asked 22 Feb '14, 20:36

warmachine42's gravatar image

warmachine42
417112

edited 22 Feb '14, 22:30

Changes>Refresh. They should show up.

(22 Feb '14, 20:50) iAdam1n ♦ iAdam1n's gravatar image

I did that, still nothing

(22 Feb '14, 20:58) warmachine42 warmachine42's gravatar image

Same with me...BioProtect, ExKey, and MultitaskingGestures..all are not found on BigBoss. So frustrating!

(22 Feb '14, 21:42) HDTX HDTX's gravatar image

I was just about to make a post about this. Lets hope it gets sorted out sooner than later.

(22 Feb '14, 23:23) zombiebot zombiebot's gravatar image

Tried installing from cydia home > manage account?

(22 Feb '14, 23:42) justinred ♦ justinred's gravatar image

me too! downloaded callbar but it won't work and springtomize 3 is no where to be found. only thing to be working for me is bitesms :(

(22 Feb '14, 23:49) dimyl452 dimyl452's gravatar image

tried still doesn't work, can't find some packages i bought...restoring my phone again now and re-jailbreaking will see if that works...

(22 Feb '14, 23:59) dimyl452 dimyl452's gravatar image

Also happening for me. I restored and re-jailbroke as well. My iPhone 5S loaded the repository fine on first jailbreak. My iPad Air refuses to see some of these packages, like NoSpot iOS 7, BarMagnet, etc.

(23 Feb '14, 00:41) Tatsh Tatsh's gravatar image

Going to my purchased packages, then visiting BattSaver's depiction http://i.imgur.com/NS8lkdr.png

(23 Feb '14, 00:54) Tatsh Tatsh's gravatar image

The same thing happen to me

(23 Feb '14, 01:02) Rockie Rockie's gravatar image

Did everyone having this issue use iTunes update button instead of itunes restore firmware button?

(23 Feb '14, 01:10) justinred ♦ justinred's gravatar image

i completely restored twice now and re-jailbreaked but still not working

(23 Feb '14, 01:15) dimyl452 dimyl452's gravatar image
2

Use icleaner to clean up your cydia packages list.

(23 Feb '14, 01:20) justinred ♦ justinred's gravatar image

icleaner did the job for me :) thanks!!

(23 Feb '14, 01:50) dimyl452 dimyl452's gravatar image

What did you guys use to fix it with icleaner? This sucks! Although I'm glad I'm not the only one so it will get resolved soon.

(23 Feb '14, 02:26) Cvbcbcmv Cvbcbcmv's gravatar image

Everybody use the answer right below mine. I just did it; it works like a charm!

(23 Feb '14, 02:39) Cvbcbcmv Cvbcbcmv's gravatar image

This topic recently came up in #iphonedev on irc.saurik.com. I speculated that Cydia's cache got out of whack with the state of the packages that the underlying package manager (apt) knew about. The procedure to correct this is straightforward but will require you to tinker with some of the files the Cydia stores on your iOS device.

I recommended the following steps, and it seems to have helped Tatsh.

  • Cydia stores the "Release" files (the repository package lists) in /var/lib/apt/lists
  • Make sure Cydia is closed
  • You need to delete all files with the following TWO exceptions: lock (file) and partial (directory).
  • Once the files are deleted, re-open Cydia.
  • Cydia will then re-download all of the Release files from the various repositories
  • When it says "reloading data", Cydia is resolving the packages from the repositories with the underlying package manager (apt)
  • After this step is performed, your package cache will be consistent again

So, how do we delete these files?

The easiest way is to download the iFile package (if it shows up in Cydia). It's shareware and will let you use it for a limited time. I recommend you purchase it, because it's a great tool to have. Navigate the filesystem to the /var -> lib -> apt -> lists directory. Use the edit button in the upper right to allow you to select the files. Remember, do NOT select lock nor partial. Once the files are selected, tap the trash can icon in tab bar. Empty the trash. Fire up Cydia and get back to work.

The more difficult way is to use the shell (via MobileTerminal or ssh). It's a bit more technical but still works.

cd /var/lib/apt/lists
rm Diff
rm *Release*
rm *Index*
rm *gpg
rm *Packages

These commands will remove all the cached data from the directory. Then, fire up Cydia and get to work.

It's been brought to my attention that if you can get iCleaner (package from Cydia) installed, you can use the Cleanup Cydia Sources option to do these deletions for you. YMMV.

ALSO, if you're experiencing an issue where some Cydia applications do not have an icon in SpringBoard (like Springtomize, Activator), the SpringBoard cache is out of whack. There are a variety of tools in Cydia that can force SpringBoard to rebuild its cache. The easiest is via a shell via the following commands.

su - mobile
uicache
respring
link

answered 23 Feb '14, 01:21

aksansai's gravatar image

aksansai
3415210

edited 23 Feb '14, 01:31

I just experienced this issue with an A7 iPad mini Retina (64-bit). I did not experience this issue on two iPhone 5 nor two iPad 2s. Intriguing.

(23 Feb '14, 02:13) aksansai aksansai's gravatar image

Note, the procedure I specified above worked for me on the iPad mini Retina.

(23 Feb '14, 02:15) aksansai aksansai's gravatar image

THIS METHOD WORKS! THANK YOU!

(23 Feb '14, 02:30) Cvbcbcmv Cvbcbcmv's gravatar image

You're welcome! :)

(23 Feb '14, 04:41) aksansai aksansai's gravatar image

evasi0n 1.0.7 has been released to address the underlying issue. However, if Cydia gets a little out of hand in the future, this is a way to get it back in shape.

(02 Mar '14, 00:15) aksansai aksansai's gravatar image

I restored/evasi0n again, and after this second time, my packages were there.

link

answered 23 Feb '14, 00:07

j0yk's gravatar image

j0yk
111

i'm trying that now...let's hope it works

(23 Feb '14, 00:09) dimyl452 dimyl452's gravatar image

trying this now too

(23 Feb '14, 00:38) zombiebot zombiebot's gravatar image

didn't work for me :(

(23 Feb '14, 01:15) dimyl452 dimyl452's gravatar image

Solved after removing and readding

link

answered 23 Feb '14, 02:24

Unurbold's gravatar image

Unurbold
112

-2

This happened to me, but to everything. I cant seem to load any packages, even after refreshing. It says "wow you have exceeded the number of packages" and that there is an error in var/dpkg/status, also that it cannot load the packages, so it's the same situation that you are in, but with all of my packages. I still have my previously installed tweaks, but nothing shows up in the cydia app.

link
This answer is marked "community wiki".

answered 22 Feb '14, 23:32

Mexboy's gravatar image

Mexboy
1112

If it says "wow you exceeded the number of packages" you just have to many packages. Delete a source and it will work. That will happen when you add to many repos

(23 Feb '14, 00:09) Shonc502 Shonc502's gravatar image

Enter safe mode by pressing and holding volume up whist booting up device......then Delete all piracy related repos and app

(23 Feb '14, 01:25) Tilerone Tilerone's gravatar image

I read an article online that said this is why evasion released 1.0.7. There was an issue with packages refreshing in cydia. I didn't fully understand the article but I'm guessing this is what they were referring to. So from what I've seen restore and get the latest evasion 1.0.7. Not sure if this is true so don't jump all over me! This is for the public and I did not post in answer, it is under comment!

(02 Mar '14, 07:12) Shonc502 Shonc502's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,266
×124
×115
×64

Asked: 22 Feb '14, 20:36

Seen: 8,014 times

Last updated: 02 Mar '14, 07:12

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.