Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

2
3

Ok, so, this one is pretty unusual and I fear it may be a pain to resolve (if possible)...

I updated my iPhone 5 from iOS 6.1 to 7.0.4 and jailbroke using evasi0n 1.0.2 about a week ago. I was jailbroken prior to updating as well. Ever since then, I have not been able to view any MMS messages. I've tried quite a number of things and nothing has helped at all. I consider myself pretty savvy with this stuff, but I'm not an expert, a programmer, and I have limited familiarity with SQLite databases.

All incoming MMS messages look like this: Incoming MMS

Later on (I'm not quite sure when), they change to this: MMS file gone

I'm quite confident that the files are arriving, as I can see a preview on the lockscreen: MMS on lockscreen

Here's a list of everything I can recall trying: - disabling most tweaks - reinstalling tweaks - uninstalling tweaks that aren't fully compatible with iOS 7 - removing biteSMS - running the permissions fix function in SBSettings - looking for anything obvious in the SMS database - deleting the two temp database files in the /var/mobile/Library/SMS folder - restoring - When I installed iOS 6, I encountered issues restoring from iTunes, but had success restoring from iCloud, so I tried that here. It didn't help; the issue persisted even before I ran evasi0n.

I have not tried "Reset All Settings," partially because I don't want to, but mostly just because I can't see it helping. I haven't tried setting it up as a new device either, just because I assume it will work (primarily because I haven't been able to find anything else about this issue and there's no way it's being caused by hardware). I did make a backup of sms.db and then delete it to see if a fresh database would resolve things, but, uh, no one is awake to send me a test picture :)

From looking in sms.db a little bit, I get the impression the files arrive on the phone, but aren't stored properly and/or aren't transferred to the correct location. I see some of the attachments are listed in /var/tmp/, but in folders that either don't exist when I look for them, or do exist and then disappear. I was able to go in and find com.apple.MobileSMS in this location at one point, which had a folder or two in it containing the most recent MMS I received, but it was gone when I went back.

Short of reseting all settings or restoring the device to new, I'm out of ideas. Any help would be very very much appreciated!!

have you tried to restore to stock while you still can to see if that's the issue ?

(10 Jan '14, 01:33) WalterWhite WalterWhite's gravatar image

No, only because I don't see how it could be anything other than software and restoring to stock would be to verify a hardware issue (or repair a software issue for those who can't dig around in the filesystem!).

(10 Jan '14, 01:41) Bretterson Bretterson's gravatar image
1

Tried boot + volume up to disable cydia tweaks and test?

(10 Jan '14, 01:50) justinred ♦ justinred's gravatar image

I didn't force it to test that, but it doesn't work in safe mode.

(10 Jan '14, 10:36) Bretterson Bretterson's gravatar image

The question has been closed for being "Solved by meteo" by WalterWhite, 11 Jan '14, 12:42


can't see those screenies. but judging by your question, MMS files just means images and stuff, and if you can't see them, it means there's a problem with the permission stuff. Change the /var/mobile/Library/SMS/Attachments permission to 700, with Owner and Group as mobile. If that doesn't work, try changing sms.db to 644, with Owner and Group both as mobile as well. hope that helps.

link

answered 10 Jan '14, 01:42

meteochu's gravatar image

meteochu
78317

1

wait. i see them now. that is definitely a permission issue. (had it before) just follow my stuff ^^^ and that'll do.

(10 Jan '14, 01:43) meteochu meteochu's gravatar image

I just replaced the links with regular Dropbox links instead of shortened ones. Probably not the best for embedding, whoops!

I also guessed it was probably a permissions thing, but I didn't know what they should be! I'll give it a shot now....

(10 Jan '14, 01:47) Bretterson Bretterson's gravatar image

I'll have to give a test tomorrow since no one can send a test message now. I should've been in bed awhile ago anyway. Thanks for the help, I'll let you know!

(10 Jan '14, 01:57) Bretterson Bretterson's gravatar image

just send yourself an image (yes, it might sound like you're a loner, but its the fastest way to test something). and see if it works.

(10 Jan '14, 02:01) meteochu meteochu's gravatar image

I would, but sending one to myself was working semi-ok. I could see it at first, but it would still change to the question mark later.

Assuming I did it correctly (it's fairly possible I didn't), changing permissions doesn't appear to have worked.

(10 Jan '14, 10:38) Bretterson Bretterson's gravatar image

Do I need to apply the change to all of the content within attachments? And/or could the permissions be wrong on the /var/tmp folder (I'm guessing this is pretty unlikely).

(10 Jan '14, 10:44) Bretterson Bretterson's gravatar image
2

You're gonna have to change all folders recursively, otherwise it'll still break.

(10 Jan '14, 11:17) meteochu meteochu's gravatar image

Gotcha. I'll try to do that. Do I need to have all the files inside be 700, or should they be 644?

Would I use something like this?: http://stackoverflow.com/questions/3740152/how-to-set-chmod-for-a-folder-and-all-of-its-subfolders-and-files-in-linux-ubunt/14634721#14634721

(10 Jan '14, 12:12) Bretterson Bretterson's gravatar image
4

change all subfolders to 700 (so recursively on the main Attachment folder) and change the .db files to 644.

(10 Jan '14, 12:15) meteochu meteochu's gravatar image

Oh man. Thank you so much!! I wish I had posted here earlier before I decided to mess with restoring and such. I just wanted to test everything I could think of on my own before I did. In the end I lost about 2 hours worth of messages, but everything else is perfect.

Like I mentioned earlier, I had a theory it might be a permissions issue, but I didn't know how to look into it. I really appreciate the help!

Incoming MMS

(10 Jan '14, 15:16) Bretterson Bretterson's gravatar image
1

No worries. Glad I could help out :)

(10 Jan '14, 15:58) meteochu meteochu's gravatar image

I have no idea if awarding points matters here or what an appropriate amount to give actually is, but I gave some...!

(10 Jan '14, 18:42) Bretterson Bretterson's gravatar image

hi. I'm having the same similar problem with my iPhone 5s =( how did you change the sms.dl i went into Ifile and tried and i didn't find anything saying owner or group to edit:/ please help!

(30 Jan '14, 13:09) bft134 bft134's gravatar image

@bft134: Did you ever figure this out? Sorry, I just saw your comment.

(20 Jul '14, 10:52) Bretterson Bretterson's gravatar image

Just to be sure, your mms files were working on 6.1 jailbroken?. I have problems receiving mms files too, but it is not jailbreak problem. Because I had that problem with my iPhone 4S, then stock 6.1.3 iPhone 5 and iOS 7.0.4 jailbroken. I think it is problem with my SIM card or with Rogers in Canada. I have limited data with mms photo or files. But one thing I found it is interesting, If I turned my data off, I would get the small SMS picture on the lock screen. But as soon as I swipe the unlock screen, the pic on the SMS is gone. If I turn the data on. I can receive pics with SMS no problem. I remember I called Rogers, they told me in order to get SMS pic, need to turn data on, even I had wifi. So I stop looking for a fix.

link

answered 10 Jan '14, 01:56

ihandyrepair's gravatar image

ihandyrepair
18712

1

Mine broke when i tried to manually copy stuff back into my iPod from an extracted backup. It'll also break in Stock after you restore it with a jailbroken backup (because the permission values are saved). It's not Roger's problem(they most likely lied, well, they probably just don't know what they're talking about.), just go into those files and change those settings. The old files might be unviewable though, but anything new that comes in will be visible to you.

(10 Jan '14, 02:00) meteochu meteochu's gravatar image

They did work on 6.1, however like meteo, I did actually have to copy the files back at some point to restore texts I deleted accidentally.

I also had to make a tiny fix in the database file because of a minor issue with a few old messages not marked as read. I had zero issues with it after either of those though.

(10 Jan '14, 10:42) Bretterson Bretterson's gravatar image

I think you should try resetting the settings, I know it doesn't seem like it'll do nothing but I said the same thing a few days ago when I was trying to activate my iMessages.

I changed the plist for my carrier and somehow my phone ended losing reception everytime I locked the screen. I hit "reset all settings" iPhone rebooted bout 3 times and it got fixed. Few days after that I completely replaced my carrier plist for another carriers and my phone would get no service or nothing, once again, reset settings, phone rebooted a few times and it worked again. I even got my imessages working on my interposed iPhone 4S and got 4G.

(10 Jan '14, 12:24) EthanRR EthanRR's gravatar image
1

Thanks, but I did end up resolving it with the permissions advice from meteo!

(11 Jan '14, 03:11) Bretterson Bretterson's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,258
×162
×104
×83
×57
×28
×27
×8

Asked: 10 Jan '14, 01:30

Seen: 8,589 times

Last updated: 20 Jul '14, 10:52

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.