Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

24
3

Restored to clean 4.2.1 and all of my books worked perfectly. After running Greenpois0n but before even opening Loader or installing Cydia I can no longer open any books purchased through iTunes. Only PDF files and free books from other sources will open.


UPDATE #3: [2/15/11] PwnageTool 4.2 has been released, and will let Mac Users create Custom firmware bundles to untether, hacktivate, preserve baseband, AND fix iBooks DRM issue:

@Musclenerd: PwnageTool 4.2 released http://is.gd/pd1vpN . Includes @chronicdevteam 4.2.1 untether and @comex iBooks fix!

iPhone-Dev Team Blog Post: What's In A Name?
OFFICIAL Bittorrent: PwnageTool_4.2.dmg.6176918.TPB.torrent

SHA-1 Sum: af365f5de19d7ee19cbe1c67b2f226996a46b3ac


Below is an image of the screen you get when opening a DRM book:

iTunes Config Error

asked 05 Feb '11, 12:43

poindexter6's gravatar image

poindexter6
361113

edited 15 Feb '11, 17:02

gomanski's gravatar image

gomanski
2.3k78

It's also important to note that its only DRM protected books. That may be why people are reporting that it works fine for them.

(05 Feb '11, 12:52) poindexter6 poindexter6's gravatar image
2

I am having the same problem in iBooks, I restored 4.2.1 using tinyumbrella to preserve BB on my iPhone 4 that was previously on 4.1 jailbroken with limera1n. Used greenpois0n rc5-2 on a 2nd gen MacBook Air running SL 10.6.6 to successfully perform the jailbreak.

The exact error message is "There is a problem with the configuration of your iPhone. Please restore with iTunes and reinstall iBooks."

I know the latest beta of the redsn0w jailbreak had this problem as well. Does the exploit which allowed the jailbreak have anything to do with the iBooks DRM?

(05 Feb '11, 13:37) flypx flypx's gravatar image
1

actually redsn0w has this problem too, on 4.1 as well as 4.2.1

(05 Feb '11, 13:44) djfalconer djfalconer's gravatar image
2

Yes, everyone with a recent device (new bootrom 3GS, iPad or iPhone4) will have this issue with either greenpois0n or redsn0w on 4.2.1. greenpois0n (perma-untether) it will always occur, redsn0w with Monte (same) and the only way you'll be able to read the DRMed books is unjailbroken... for now. Here's hoping someone from the (chronic or iPhone) Dev Teams comes up with a fix, because this issue is actually kind of sucky.

(05 Feb '11, 19:21) pyfgcrl pyfgcrl's gravatar image
3

Can anyone pastie the output of the syslog when you try to do this?

(05 Feb '11, 20:25) comex ♦ comex's gravatar image

@comex I would love to help but don't know how to get to syslog. If you're willing to explain or point to instructions I'll get it to you.

(05 Feb '11, 20:28) poindexter6 poindexter6's gravatar image
3

This has been happening since red snow (i used recent b8 not sure when it actually started), but you used to be able to keep pressing and it would eventually open (5-10 times) now with Gp it will not open at all no matter how many times I press it.

(05 Feb '11, 23:13) Ngmead Ngmead's gravatar image

@comex http://pastie.org/1533086 My first time doing the syslog. I pasted everything from when I started the syslog by installing syslogd in cydia, opened iBooks, then attempted to open some of the books that give the error a couple of times each. SSH in to get the syslog then removed syslogd. Let me know if you need me to do it again or in a certain way. Thanks!

(06 Feb '11, 01:00) flypx flypx's gravatar image

Here's another syslog, in case it's any use... http://pastebin.com/693EDF8L

(07 Feb '11, 14:02) deeem119 deeem119's gravatar image

@comex http://pastie.org/private/c5vwsiakckoldden2zrmq

That's the syslog from just running iBooks and acknowledging the error. Hope it helps.

(07 Feb '11, 18:40) unstatusthequo unstatusthequo's gravatar image

@comex I pasted the syslog as an answer

(07 Feb '11, 19:23) MattYeah MattYeah's gravatar image

I am having the same problem

(09 Feb '11, 17:40) kaymonster454 kaymonster454's gravatar image

Here is the error message i receive..."There is a problem with the configuration of your iPad. Please restore with iTunes and reinstall iBooks."

(09 Feb '11, 17:44) kaymonster454 kaymonster454's gravatar image
3

RC6 doesn't fix the problem.

(13 Feb '11, 05:28) keskiveut keskiveut's gravatar image

This is not a Greenpoison only problem I have a iPhone 4 with non green jailbreak and 4.1 and it has the same issue so it is the new update of iBooks.

(13 Feb '11, 23:38) onthegoto onthegoto's gravatar image
1

As the first post says, Apple is doing dirty and naughty tricks to keep us jailbrakers out of their bookstore. So I guess they're not going to go back on this debacle either. I guess their mentality now on jailbreaking must be "If they don't like our walled garden, FINE, but we're not going to let them back in. SERVANT! CLOSE THE iBOOKSTORE TO THE HERETICS!!!"

(14 Feb '11, 21:46) ShadowEO ShadowEO's gravatar image
1

Couldn't this be fixed with a simple Cydia package that prevents iBooks from openIng this file? Then the check would fail and Apple would think you are vanilla.

(15 Feb '11, 09:27) poindexter6 poindexter6's gravatar image

I think a simple Cydia package may be the route they are planning to take.

(15 Feb '11, 14:02) xiingli xiingli's gravatar image

Is there a Windows version of this jailbreak? And do you have to restore to a clean FW (remove greenpois0n) before you can proceed? Or, can you just jailbreak it again over the greenpois0n JB? Thanks for the help.

(16 Feb '11, 13:13) xiingli xiingli's gravatar image

There are now several official fixes for this issue.


Option 1 - PwnageTool 4.2 / Sn0wBreeze 2.2

These two tools now provide the ability for jailbreakers to create custom .ipsw files that both preserve older basebands, and include @comex's iBooks fix.

This blog post provides an excellent how-to on how to backup your phone, create a custom .ipsw file, and restore it to your phone.

Please note, this method does require performing a restore on your phone, but is also the best method for unlockers on older basebands.


Option 2 - Cydia Package

If you are already jailbroken with greenpois0n or another jailbreak, and would prefer not to jailbreak, you can install @comex's DRM fix in the form of this .deb file (http://a.qoid.us/hunnypot.deb) or by using the following cydia source:

Step 1: Launch Cydia >> Manage >> Source >> Edit >> Add >> type – http://cydia.machackpc.com >> Add Source >> Done

Step 2: Tap on MacHackPC Community Repository

Step 3: Tap on honnypot

Step 4: Tap on Install and then Tap on confirm to complete the installation

Step 5: Now, give your iOS device a reboot and sync your iOS device with iTunes.

Note: If that does not work, Launch AppStore app and re download iBooks on your iOS Device.

link

answered 15 Feb '11, 17:04

gomanski's gravatar image

gomanski
2.3k78

edited 17 Feb '11, 17:52

1

I apologize for my impatience.... Lol but do you have an idea on a ETA for the packages to available via cydia?

(15 Feb '11, 22:09) Steed Steed's gravatar image

cant install the deb keep having issues installing the deb

(16 Feb '11, 18:08) squirrelman10 squirrelman10's gravatar image

Install ifile, email the deb to yourself. Open in ifile a menu will pop up. Click install. And your done it works

(16 Feb '11, 18:24) justinb51 justinb51's gravatar image

i get a dpkg error when i try installing the file

(16 Feb '11, 22:02) squirrelman10 squirrelman10's gravatar image

Works like a charm... Take that apple... Right in the shorts! Ha ha

(17 Feb '11, 21:46) dminnici dminnici's gravatar image

option 2 worked like a treat. Thank you for the information

(26 Feb '11, 17:29) coupeborgward coupeborgward's gravatar image
10

If you don't want to re-jailbreak, try this deb: http://a.qoid.us/hunnypot.deb

link

answered 15 Feb '11, 22:07

comex's gravatar image

comex ♦
3.3k102629

Comex!!! You are the man!! Thanks for the deb file. iBooks now works flawlessly. Thank you so much for the fix. Where do I donate??

(15 Feb '11, 22:22) Steed Steed's gravatar image

Beautiful...iBooks working as smooth as frogs hair ! Thank you all for your hard work and time !

(15 Feb '11, 22:29) Ashes80 Ashes80's gravatar image

you all Rock!!!! Keep it up, and yeah...where do we donate?

(15 Feb '11, 22:30) Junyoure Junyoure's gravatar image

do we use the .deb to fix iBooks?

(16 Feb '11, 01:51) 420jailbreak 420jailbreak's gravatar image

How do I use the file? When I click on it it says that mobile safari cannot download the file. Please a few instructions.

(16 Feb '11, 02:08) justinb51 justinb51's gravatar image

Install via ssh, lots of guides on the inets, look around. Option 2, wait until package is put on cydia ?

(16 Feb '11, 02:25) Ashes80 Ashes80's gravatar image

You need safari download manager and ifile to do this on the device. Once downloaded, navigate to it in ifile, click on the deb and it will give options. Run installer then reboot and your done. iBooks works again:)

(16 Feb '11, 12:40) Steed Steed's gravatar image

you need to SSH into your iDevice with WinSCP and copy the .deb file into the tmp folder. (quit cydia if it's running!) hit ctrl+t in winscp and run the following command: dpkg -i /tmp/hunnypot.deb. when you're done restart your iDevice and the .deb file should be installed. Good luck! :)

(16 Feb '11, 13:54) arcs5 arcs5's gravatar image
1

Thank you comex! I humbly bow to your superior tech skillz.

(16 Feb '11, 15:06) Pepper ♦ Pepper's gravatar image

justinb51 you need a download manager or ssh or something like that Is a cydia package to be released?

(16 Feb '11, 15:52) williperson williperson's gravatar image

you can install it using ifile

(20 Feb '11, 08:57) MattYeah MattYeah's gravatar image

I hit the same issue, but needed to restore. For most eBook drm you can leverage calibre with the drm plugins to strip drm from your books. Here is a great blog post on this topic: http://apprenticealf.wordpress.com/2011/01/13/ebooks-formats-drm-and-you-—-a-guide-for-the-perplexed/

However, I have not seen a plugin to strip fair play drm from iBook purchased ebooks.

link

answered 10 Feb '11, 19:10

vanishingpoint's gravatar image

vanishingpoint
311

I looked at that link but it doesn't cover iPhones and iPads (or at least I didn't see it there) how do you apply that to these devices since you can't read those snooks on your computer?

(10 Feb '11, 19:39) justinb51 justinb51's gravatar image
2

When you install Calibre it connects to a tethered iPhone/iPad and it can transfer your books to and from those devices.

(12 Feb '11, 00:26) vanishingpoint vanishingpoint's gravatar image
1

I agree, use Calibre to process your epub (iBooks format) books. It's really good at stripping away DRM. You can also convert to other types like mobi to just use the Kindle app instead.

(15 Feb '11, 09:32) prokizzle prokizzle's gravatar image

Everything I have found has said that iTunes DRM cannot be removed through Calibre. Have you got this working successfully?

(15 Feb '11, 09:54) poindexter6 poindexter6's gravatar image

Anyone have success with Calibre ?

(15 Feb '11, 10:14) Ashes80 Ashes80's gravatar image

How do I go about using Calibre to strip the ebook of the DRM? Do I have to SSH my phone and pull out the file?

(15 Feb '11, 12:42) xiingli xiingli's gravatar image

Purchase in Kindle, use Unswindle to strip DRM, Then convert to ePub with Calibre

(15 Feb '11, 12:57) prokizzle prokizzle's gravatar image

FYI, on a WiFi-only 64g iPad, originally jb with Redsnow 0.9.6 (tethered), then jb unthethered with Greenpois0n Windows RC5, I had a lot of problems getting iBooks to work. Restored to 4.2.1 stock, jb with Sn0wbreeze 2.2, iBooks still didn't work, and hunnypot wouldn't install. Restored and tried again with Sn0wbreeze, still didn't work. Restored to stock 4.2.1 again, jb with Greenpois0n RC6, then installed hunnypot via Cydia (http://cydia.machackpc.com repo), iBooks worked like a charm. Nice work comex and pushfix, thank you. Just wanted to point out Sn0wbreeze 2.2 iBooks fix may not work on iPad.

link

answered 16 Feb '11, 23:53

Dgtiii's gravatar image

Dgtiii
1

Ah, thanks for the info, it seems sn0wbreeze doesn't contain the @comex fix that PwnageTool does. But you're right, installing hunnypot does just fine.

(17 Feb '11, 00:07) gomanski gomanski's gravatar image

ih8sn0ws SB 2.2.1 works for verizon iphones for those who dont know

link

answered 27 Feb '11, 13:50

squirrelman10's gravatar image

squirrelman10
4612715

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×1,847
×1,588
×73

Asked: 05 Feb '11, 12:43

Seen: 17,606 times

Last updated: 27 Feb '11, 13:50

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.