Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Hi guys,

I tried to restore my iPhone 5 today from my iTunes backup which I made before jail breaking. iOS 7.0.4.

ITunes places the phone in the anticipated recovery mode and begins the process however it seems to hang on "waiting for iPhone" the phone screen turns black and I wait about 15 minutes until iTunes reports that it could not restore with an error 4005.

A hard reset on the phone leads to the recovery mode screen instructing a connection with iTunes. The process then starts again, no amount of button combos will exit the recovery mode. I can however put it into DFU mode but the exact same behavior occurs when trying to restore or restore from backup in iTunes.

To gain access to the phone I had to download TinyUmbrella to force the exit out of recovery mode. This then allowed the phone to boot but I'm back at square one and unable to restore.

Can anyone point me in the right direction here? After 4hours fiddling I'm chasing my tail. Thank you in advance for any advice.

asked 05 Jan '14, 22:59

Bumblebee17's gravatar image


closed 29 Nov '15, 11:46

theiphoneguy's gravatar image

theiphoneguy ♦

The question has been closed for being "Other - old and people cant read dates. here's looking at you techy12345" by theiphoneguy, 29 Nov '15, 11:46

Try the following:

  • Reboot computer
  • Different USB cable
  • Different USB port
  • Different computer
  • Reinstalling iTunes completely
  • Redownloading iOS 7.0.4

Even though they shouldn't, some of these can actually fix this sort of issue.


answered 06 Jan '14, 02:34

Endareth's gravatar image


I kept having the same problem in my iPad and iPhone, could never fix it so I just had to use a different computer and it work first try. If you figure out a different way please post, otherwise hope you have access to another computer.


answered 06 Jan '14, 04:54

Emerica6708's gravatar image


iphone 4s io 7.0.4 turned phone off over weekend turned back on and stuck in boot logo tried restore in dfu and recovery mode both have same result iTunes downloads 7.0.6 then unpacks it then tries to restore, computer goes beep beep phone turns on and restore process starts................ but doesn't b/c when phone turns on it gets stuck in same boot logo issue....... then iTunes gets error 14005 please help :>( is there a 3rd party program I can use to wipe iphone and then start from scratch? anything? please


answered 22 Feb '14, 20:17

brubin10's gravatar image


Do you have avg antivirus.? It caused me an errors on iTunes.

(22 Feb '14, 20:42) Shonc502 Shonc502's gravatar image

Try iLex Rat

(22 Feb '14, 21:56) A08 A08's gravatar image

You need to respring it(hold down power and home) then when the apple logo comes up hold one of the volume buttons down until it boots up. If you are jailbroken your tweaks will not work. You just need to keep rebooting to your device until it fixes it self.

(29 Nov '15, 08:22) Techy12345 Techy12345's gravatar image

@techy12345 you need to read, you just replied to an almost 2 year old comment.....

(29 Nov '15, 11:45) theiphoneguy ♦ theiphoneguy's gravatar image

I've just had the same problem, but managed to solve it. Take a look at this article over at Apple: (it may require you to read a lot). You can skip straight to step "5. Verify that the Apple Mobile Device USB Driver is installed" then expand "If the device is not recognized while in Recovery Mode". Follow the steps in there, and you should be good to go.

All the best.


answered 22 Feb '14, 20:58

arifullahworld's gravatar image


See here. It is purely a USB timing issue. The steps outlined would work. Beware that iPhone went into Recovery mode. For A5 and + iDevices this invariably leads to Full Restore. With the release of iOS 7.0.6 now, you may have to do a Full Restore to current iOS and then attempt restoring from backup or preferably sync data back onto iPhone using tabs in iTunes.


answered 22 Feb '14, 21:53

A08's gravatar image


I found online that it's needed to replace the battery to get rid of the error 4005. I followed the guide and replaced the battery. The 4005 problem was fixed. Now my iPhone restored normally via iTunes.



answered 09 Nov '15, 08:42

istephannn's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 05 Jan '14, 22:59

Seen: 48,041 times

Last updated: 29 Nov '15, 11:46

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.