Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Before swipeselection was updated to IOS7 some guy posted on reddit a .deb package to fix it via Ifile, it worked, but yesterday I had some atualizations and one of them was swipeselection. After that my phone got into boot loop and I think it's this package. How do I uninstall it?

asked 03 Jan '14, 12:34

valdir_bmn's gravatar image

valdir_bmn
26418

closed 14 Jul '15, 16:13

theiphoneguy's gravatar image

theiphoneguy ♦
42.1k65420

The question has been closed for being "Other - old" by theiphoneguy, 14 Jul '15, 16:13


Click Cydia, search for swipeselection and hit "modify", find the remove button and hit that and then "confirm" that should do it.

link

answered 03 Jan '14, 19:33

sandyv's gravatar image

sandyv
1.2k11219

But the problem is the .dev package that I installed via Ifile, not swipeselection

(03 Jan '14, 19:35) valdir_bmn valdir_bmn's gravatar image

Ok find the repo of the dev package, do you remember it? Find the file you installed, hopefully you can remember what it was? That makes it a little complicated, a restore may be your only alternative,.... :(

(03 Jan '14, 19:37) sandyv sandyv's gravatar image

I downloaded a .dev file via safari and opened with Ifile then I installed it. I didn't isntalled it via cydia

(03 Jan '14, 19:43) valdir_bmn valdir_bmn's gravatar image

As I said above, that makes it a little more complicated.... (A LOT more complicated) sorry....

(03 Jan '14, 19:43) sandyv sandyv's gravatar image
1

Even of you didn't install it via Cydia, the deb will be listed as a Cydia package I think.

(03 Jan '14, 19:58) LaMaravilla LaMaravilla's gravatar image

Someone?

(03 Jan '14, 20:44) valdir_bmn valdir_bmn's gravatar image

Hey, I know your frustrated, but I myself (and maybe most of us here) can understand Cydia and so forth... but getting into ifile issues is a whole new ball game.

(03 Jan '14, 20:47) sandyv sandyv's gravatar image

@LaMaravilla is right... It should be listed as a package in Cydia.

(03 Jan '14, 20:48) Will0401 Will0401's gravatar image

Try disabling mobilesubstrate, hold down the volume up button while booting, if that doesnt work try semi-restore and if that doesnt work you have to restore.

link

answered 03 Jan '14, 12:46

daniel664's gravatar image

daniel664
2.5k59

O already have it out of boot loop I just want to know how to uninstall the package

(03 Jan '14, 13:22) valdir_bmn valdir_bmn's gravatar image

Mobile Termnal or SSH. dpkg -r PackageName

link

answered 03 Jan '14, 21:07

justinred's gravatar image

justinred ♦
51.4k74717

Open ifile, open the .deb file with zip viewer and select control.tar.gz then the unpsck icon, it should extract one file called control.tar.gz, open this file with zip viewer to and extract control, open it you will find something like package: com.domain.packagename, search for it in cydia, when you have found the package tap manage the delete.

link

answered 04 Jan '14, 02:24

daniel664's gravatar image

daniel664
2.5k59

Open Cydia and download and install the following Apps/Tweaks

  • MobileTerminal
  • iFile

Naviagte within iFile to /var/lib/bpkg and open the “status” file with text viewer. Search for the apps/tweaks you wish to uninstall and take note of the Package. (should be similar to com.ihacksrepo.displaycandy)

The package for displaycandy is com.ihacksrepo.displaycandy Open MobileTerminal and type the following - su root (press return) - alpine (this is the default password, press return) -dpkg -r com.ihacksrepo.displaycandy (or what ever source your package is and press return)

Re-Spring or restart your phone and you’re all done!

link

answered 04 Jan '14, 02:31

TeRmRaN19's gravatar image

TeRmRaN19
1465311

Open ifile and go to

Var/mobile/documents

There you will find the deb file you installed! Once you have the name go to

Cydia/manage/pakages

And in there look for the name of the file you installed and open it

Modify/remove

And you are done!!

This isnt that complicated I done this a lot so it isnt! Need more assistance let me know!!

link

answered 04 Jan '14, 03:28

1107963's gravatar image

1107963
231613

-1

valdir_bmn: do u already solved ur problem with deb files??

link

answered 14 Jul '15, 15:47

R4k50's gravatar image

R4k50
-91

almost 2 year old question..... hope they solved it by now or moved on

(14 Jul '15, 16:13) theiphoneguy ♦ theiphoneguy's gravatar image
-1

valdir_mbn: do u already solved ur problem with deb files??

link

answered 14 Jul '15, 15:48

R4k50's gravatar image

R4k50
-91

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,358
×1,258
×400

Asked: 03 Jan '14, 12:34

Seen: 30,242 times

Last updated: 14 Jul '15, 16:13

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.