Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i would like to get back into some sense of working order and any help would be appreciated. i jailbroke my iphone running 4.2.1 with greenposion. now i am stuck in the recovery loop and cant get out. i have scevenged the net and now i am here. i put my iphone in dfu mode and i am connected to tiny umbrella, hit fix recovery and i am looking at a black screen now....

asked 09 Mar '11, 18:35

itunis's gravatar image

itunis
2113


Do you have any apple entries in your hosts file? Sounds like you do. If you click this link (http://gs.apple.com) now, it should take you to apple. If it takes you to cydia, you need to edit your hosts file.

How to Fix Error Code 1013:

Mac OS X:

Step 1. On your Mac, go to your “Applications” folder.

Step 2. Now navigate to the “Utilities” folder.

Step 3. Launch "Terminal".

Step 4. Type "sudo nano /etc/hosts" (without quotes) and hit return.

Step 5. Enter your password

Step 6. Use the down arrow key to find the “gs.apple.com” entries. Once the cursor is in front, make sure you comment out the line(s) by entering “#” in front of the text.

Step 7. Save the file by pressing CONTROL+O.

Step 8. Exit the nano editor by pressing CONTROL+X.

Step 9. Restore your iDevice.

link

answered 09 Mar '11, 21:25

spockers's gravatar image

spockers ♦♦
69.9k3911660

edited 09 Mar '11, 21:27

haha1 i just found the same info on youtube.

http://www.youtube.com/watch?v=ktqU9Um-vp4

thanks for everyone's help!!

(09 Mar '11, 21:43) itunis itunis's gravatar image

Welcome, glad it worked.

(09 Mar '11, 21:45) spockers ♦♦ spockers's gravatar image

TinyUmbrella will kick you out of Recovery Mode, not DFU mode.

If you plug your iPhone in and start up iTunes, does it get detected, and if so, what as? If you're in DFU mode, power it off by holding down Sleep & Home for 7 seconds or so, and let it boot normally. If it goes into Recovery Mode, download the latest TinyUmbrella and try that to kick it out.

If that still fails, you may need to restore in iTunes and re-jailbreak.

link

answered 09 Mar '11, 18:43

Endareth's gravatar image

Endareth
6.7k232439

1013 is a "normal" error, it indicates the restore failed to update your baseband (this is exactly what we generally want), but it leaves the device in a recovery loop. The new "Fix Recovery" feature in TU is designed for exactly that situation. If that still doesn't work, try @spockers' solution of using iREB.

link

answered 09 Mar '11, 19:47

Endareth's gravatar image

Endareth
6.7k232439

Just hold power+ home button and it will kick out of DFU mode. If not, use redsn0w to boot tethered and then reboot to test if the greenpois0n exploit and untether worked.

link

answered 09 Mar '11, 20:11

matoetheiostream's gravatar image

matoetheiostream
73344752

kicked out dfu mode, connect to itunes screen returned. fix recovery button is greyed out.usable buttons are exit recovery save shsh and start tss server...

looking for redsnow now.

(09 Mar '11, 20:25) itunis itunis's gravatar image

just used redsnow. twice. saw the pineapple logo on my screen. now i am looking at the connect to itunes screen...

(09 Mar '11, 20:39) itunis itunis's gravatar image

If you don't need to preserve your baseband, do this:

Open iTunes. Hold down the option key and click the restore button in iTunes. Point it to the stock 4.2.1 firmware. This should fix it.

(09 Mar '11, 20:52) spockers ♦♦ spockers's gravatar image

already tried that. used iPhone3,1_4.2.1_8C148_Restore.ipsw. i get the 1013 error...

(09 Mar '11, 21:05) itunis itunis's gravatar image

if i go through the motions and try to restore normally through itunes. i get the 1013 error. so i looked online for help and here i am....

as you requested..... i connect to itunes, iphone is detected. i get message about being in recovery mode.

downloaded tiny umbrella 4.30, clicked exit recovery button. apple logo flash on screen a couple of times then back to recovery screen.

what about this fix recovery button?

link

answered 09 Mar '11, 19:35

itunis's gravatar image

itunis
2113

1

You're in recovery loop. Try TU's "fix recovery." If that doesn't work, get iREB (http://ih8sn0w.com/index.php/download/file/ireb/pc) and click on the "recovery mode loop fixer" tab.

(09 Mar '11, 19:39) spockers ♦♦ spockers's gravatar image

ok thanks again. i will get to reading that info in a moment...

i entered dfu mode then the fix recovery button became available. hit fix recovery and my log shows this...

03/09/2011 19:41:32.945 DFU Device connected 03/09/2011 19:41:41.043 DFU Device disconnected 03/09/2011 19:41:41.268 DFU Device connected 03/09/2011 19:41:52.819 Attempting to fix recovery... 03/09/2011 19:41:53.372 Starting fix recovery sequence... 03/09/2011 19:41:53.388 Fix Recovery has finished. Allow device to reboot!

i am waiting to reboot. i have a black screen. what do i do now?

link

answered 09 Mar '11, 19:59

itunis's gravatar image

itunis
2113

edited 09 Mar '11, 19:59

Sounds like it didn't work. Didn't work for me when I was testing it last night either. Try iREB.

(09 Mar '11, 20:05) spockers ♦♦ spockers's gravatar image

went straight to download the ireb app and noticed its for pc and i am on a mac.....

(09 Mar '11, 20:07) itunis itunis's gravatar image

if fix recovery worked, what would happen? what would i see? what would i do?

(09 Mar '11, 20:08) itunis itunis's gravatar image

It should boot normally if it worked.

(09 Mar '11, 20:10) spockers ♦♦ spockers's gravatar image

I haven't need to try this myself, but are you sure you needed to go into DFU mode rather than Recovery mode in order to do the "Fix Recovery" in TU?

Anyway, if it worked, a reboot of the device should just let it boot normally.

(09 Mar '11, 20:11) Endareth Endareth's gravatar image

alright.... i before i used greenposion i download Tu and hit save shsh...

i pressed start tss server...

03/09/2011 20:10:22.908 TSS Server Started! 03/09/2011 20:10:23.036 TSS Accepting connections...

would should happen now?

(09 Mar '11, 20:14) itunis itunis's gravatar image

Nothing. That's just for preserving your baseband or downgrading firmware. It's waiting for iTunes to try to contact Apple, and it will intercept that and talk to iTunes, telling it that everything's ok.

(09 Mar '11, 20:18) spockers ♦♦ spockers's gravatar image

if i start from the beginning.... i plug it in and the only buttons available are exit recovery, save shsh, and start tss server. fix recovery button is available if i hold power+home for 10sec then home for 10sec....

(09 Mar '11, 20:21) itunis itunis's gravatar image
1

Yeah in my testing, if it's in recovery loop, TU doesn't recognize it until you can get it into DFU.

(09 Mar '11, 20:23) spockers ♦♦ spockers's gravatar image

If you don't need to preserve your baseband, then open TinyUmbrella, go to the Advanced tab, and un-tick the "Set hosts to cydia on exit" then close TinyUmbrella. You should then be able to option-restore to stock 4.2.1 with iTunes, assuming they're still signing 4.2.1 (they should be since 4.3 has only been out for a few hours.)

(09 Mar '11, 20:27) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 09 Mar '11, 18:35

Seen: 1,591 times

Last updated: 09 Mar '11, 21:45

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.