Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

1
1

Hello, I have an iPhone 4 jailbraked with 6.1.2.
I have saved the SHSH blobs with tinyumbrella for the following firmwares:
iPhone4 6.1 (10B144) iPhone4 6.1.2 (10B146)
iPhone4 6.1.3 (10B329)
I have read something on Saurik's blog that some of the saved SHSH won't be useful for downgrading - even if they have been saved during the signing window. How can I be sure that those blobs are useful?
I fear that cydia may have saved them in the -bad- period and then tinyumbrella might have requested them from cydia.

I'd like to test iOS 7 but I'd like to be able to revert to 6.1.2 if something goes wrong... Any hint?


12next »

Use iFaith to check your blobs and see if they are valid. Either way, you can and should get new 6.1.3 blobs using iFaith.

link

answered 18 Sep '13, 13:20

compilingEntropy's gravatar image

compilingEntropy
4.1k77

i am afraid iFaith is windows only :(

(18 Sep '13, 13:37) nick2k3 nick2k3's gravatar image

Yes, it is windoz only tool.

(18 Sep '13, 13:39) slavakulikoff slavakulikoff's gravatar image

Ok I am in windows 7, I have downloaded iFaith, run as Administrator, selected "DUMP SHSH blobs" followed the instruction to enter DFU mode. iFaith says: You failed to enter DFU mode. Try again. but the phone IS in DFU mode, it does also say so in the USB device details: "Apple mobile device (DFU mode)"

any hint on what am I doing wrong?

(18 Sep '13, 16:14) nick2k3 nick2k3's gravatar image

I have never done it on win 7, as the matter of fact i probably never will...

(18 Sep '13, 16:21) slavakulikoff slavakulikoff's gravatar image

so what os should I try it with? windows 8? I have seen videos on youtube in which after a few seconds ifaith says to release power button it quickly recognize the iphone.. instead I get the second countdown to expire and then I get the failed dfu mode.. any help?

(18 Sep '13, 16:39) nick2k3 nick2k3's gravatar image

SOLVED: I updated itunes and thus I think some drivers and then ifaith quickly recognized the phone in dfu mode. thanks!

(18 Sep '13, 17:03) nick2k3 nick2k3's gravatar image

You should also do "Show available SHSH caches on server" to get 6.1.3 before it's too late. You can try uploading your 6.1 and 6.1.2 blobs that you have stored locally with this option as well, and iFaith will check to see if they are valid (they likely aren't, but it's worth trying).

(18 Sep '13, 19:24) compilingEntropy compilingEntropy's gravatar image

I already have 6.1.3 shsh both on cydia and tinyumbrella :)

one question, I have recovered the 6.1.2 certificate with iFaith and I will eventually use it for downgrading; I used to have (locally) a 6.1.2 certificate which I don't know if it has been grabbed from cydia. However I tried the "verify SHSH blob" function of redsn0w and it says the old 6.1.2 certificate is OK. Should I trust it? can I use the certificate obtained with iFaith with redsn0w?

(19 Sep '13, 03:35) nick2k3 nick2k3's gravatar image

Redsn0w is really out of date right now, use iFaith instead. If you saved 6.1.2 blobs off of your device with iFaith, you can use iFaith to stitch those blobs into an IPSW, enter pwned DFU mode, and restore to 6.1.2.

(21 Sep '13, 06:18) compilingEntropy compilingEntropy's gravatar image

If Cydia lists those SHSH blobs at the top of the "TSS Center" (linked from the Cydia homepage), they are valid blobs saved on Cydia's servers. Cydia doesn't display invalid blobs. (It's also possible though that you have valid blobs saved only locally and not on the servers.)

link

answered 18 Sep '13, 13:57

britta's gravatar image

britta ♦♦
23.9k105133

edited 18 Sep '13, 13:57

Cydia TSS Center says I have 5.1.1 and 6.1.3.
Tinyumbrella says I have 6.1.2. I guess I'll try and see if the last one is OK signign an ipsw ;)

(18 Sep '13, 15:29) nick2k3 nick2k3's gravatar image

The reliable way to verify shsh is tool called ifaith. If you saved those shsh with tinyumbrella then they are corrupted and cannot be used, however you need to verify it. If your iphone4 is on 6.1.2, you can dump shsh srom device with the same ifaith.

link

answered 18 Sep '13, 13:21

slavakulikoff's gravatar image

slavakulikoff
4.2k58

That's incorrect, TinyUmbrella blobs are perfectly valid. It's only when you use TinyUmbrella to save blobs from Cydia's servers, which saved invalid blobs, that TinyUmbrella gets blobs that aren't valid.

(18 Sep '13, 13:22) compilingEntropy compilingEntropy's gravatar image

That is what i meant. Based on my general observation, that is how most users save shsh with "request shsh from cydia" checked. You are right about cydia corrupting 6.1.2 blobs, not tiny. However if OP does not have valid shsh for 6.1.2 ifaith must be used to dump them from the device, and/or the only way to verify them is to use ifaith.

(18 Sep '13, 13:30) slavakulikoff slavakulikoff's gravatar image

It does not work that way. Blobs are unique to the device. You cannot use any blob on any device other than the one Apple issued to, or for that matter for any other iOS version on that phone or any other. Any blob other than one issued to your device is USELESS.

link

answered 09 Nov '13, 12:06

mikewsw17's gravatar image

mikewsw17
1.6k25535

Hi, I have my ios 6.1.2 SHSH backup via iFaith. I've restored my iphone with custom firmware created by iFaith. My question is it possible to use it for downgrade from ios 7.0 to ios 6.1.2,and thank you in advance.

link
This answer is marked "community wiki".

answered 21 Sep '13, 07:50

mahdihind8187's gravatar image

mahdihind8187
111

edited 21 Sep '13, 08:19

King%20Shoot's gravatar image

King Shoot
9.9k29486

According to iH8sn0w, as of the moment, no. Apple broke iFaith stitch downgrades from iOS7. Wait for an iFaith update.

(21 Sep '13, 08:06) justinred ♦ justinred's gravatar image

hi here I dared tested ios 7 but nothing new so I doungrounder my iphone to ios 6.1.2 has almost 64 tweaks I install and I noticed that all offers ios 7 is already on cydia and since long. Here I wanted to share my experience because I was not quite on the dounground

link
This answer is marked "community wiki".

answered 21 Sep '13, 08:23

mahdihind8187's gravatar image

mahdihind8187
111

I'm sorry for the spelling and the translation I speak French and I use a translation software. I grieve

link

answered 21 Sep '13, 08:26

mahdihind8187's gravatar image

mahdihind8187
111

hey can you send me your iPhone4 6.1.2 (10B146) blobs I forgot to save my files So i cant downgrade my iphone 4 when you do can you send me the files to this email nicki_1234@hotmail.de

link

answered 09 Nov '13, 11:26

applefreak66's gravatar image

applefreak66
112

ohm man then im screwt :( ios 7 sucks thx any ways :)

link

answered 09 Nov '13, 12:12

applefreak66's gravatar image

applefreak66
112

hi! can anyone here with a kind heart share with me their SHSH Blobs for IOS 6.1.3? i updated my ios accidentally to ios7 which turned out to be unlikable for me with my iphone 4. my phone ran slower as it was when i first got it... please anyone.... pls send me a copy through villamorjanjoshua@yahoo.com.ph thank you so much in advance and may you have happy holidays ahead!

link

answered 19 Dec '13, 07:57

villamorjanjoshua's gravatar image

villamorjanjoshua
111

Sorry, SHSH Blobs are unique to a particular device; sharing them helps no one.

(19 Dec '13, 08:30) cracker cracker's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,445
×1,139
×752
×600
×186
×138

Asked: 18 Sep '13, 13:18

Seen: 24,982 times

Last updated: 19 Dec '13, 08:31

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.