Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.


A friend gave me her iPhone 3GS because it was stuck in recovery mode.

After a restore with iTunes, the iPhone asked to restore again. (although iTunes had shown the popup saying the iPhone was going to restart and the restore was done...)

I tried using TinyUmbrella, iRecovery and Recovery Fix in Redsn0w, but none of them worked. So I performed a jailbreak using Redsn0w, which wasn't a desired solution because my friend didn't ask a jailbreak at all and because it has some bad consequences like being unable to restart normal. (tethered jailbreak at 6.1.3)

After the jailbreak, the phone finally restarted. Everything worked fine, except the home button wasn't working at all. I tried the trick opening a default app and holding the power button until the slider comes up and then holding the home button until it disappears, but it didn't help. I tried AssistiveTouch from Apple and installed Activator, and they both can simulate successfully the home button action. I also tried pressing the home button in Safe Mode without success.

All these things lead to a hardware problem, BUT after entering more than 20 times (successfully) DFU mode and Recovery mode, I think I can be sure the home button IS still alive...

My friend doesn't know much about jailbreaking etc and she only knows the trouble began with the recovery loop. My conclusion would be that there is a problem with some root files or something, which causes the unability to startup the phone without a jailbreak and which causes some trouble with the home button actions...

Can someone give me an explanation or, even better, a solution..? (warranty is already exceeded)

You said "After a restore with iTunes, the iPhone asked to restore again. (although iTunes had shown the popup saying the iPhone was going to restart and the restore was done...)"

That's really odd. Try restoring in iTunes again (make sure it's the latest iTunes version) and see what happens.

(28 Jun '13, 20:15) spockers ♦♦ spockers's gravatar image

Also, how do you know you're entering DFU? Many people have some confusion on what DFU is.

(28 Jun '13, 20:17) spockers ♦♦ spockers's gravatar image

1) iTunes says the restore is done, also the preloader disappears on the device, but when it tries to start it gets stuck and again shows the recovery mode image. After that iTunes again shows the popup "there is a device in recovery mode..."

2) I know it because redsn0w tells me it's in recovery mode and after the right combination, it shows "DFU mode, new bootrom, 06.15.00 (after downgrading baseband from 06.15.08), I jailbreaked it (tried to downgrade,...) like 6 times from now, and it always patched limera1n etc.

(28 Jun '13, 20:25) Fusion Fusion's gravatar image

Edit: I don't think 06.15.08 exists, I meant 05.16.08, is this the normal baseband for 6.1.3 on a 3GS?

(29 Jun '13, 08:35) Fusion Fusion's gravatar image

Yes 6.15 is the Ipad baseband, you get 5.16 after restoring on itunes.

(29 Jun '13, 08:36) sandyv sandyv's gravatar image

Also since you've done everything else you probably have seen the "alcohol" trick for the home button? It worked for me and home button still works perfectly after a month!

(29 Jun '13, 08:46) sandyv sandyv's gravatar image

I just beated the infinite recovery loop thanks to this page! (I used the volume up trick) Now, I have a clean iPhone but still the home button doesn't react... I'll try the alcohol trick but is it possible that a device can enter dfu mode with a broken home button and without using a special trick (using the combination: power->home+power->home)?

(29 Jun '13, 09:07) Fusion Fusion's gravatar image

I could not get into dfu with my home button broken at all, even though there is an option in Redsn0w to attempt this, it didn't work for me. Just be very careful with the alcohol fix! Make sure the phone is off as well. Maybe it will work for you. I was pleasantly surprised myself! :)

(29 Jun '13, 09:09) sandyv sandyv's gravatar image

Alcohol didn't work... I also opened the device but everything seems normal, last option was AssistiveTouch...

(29 Jun '13, 13:26) Fusion Fusion's gravatar image

I didn't like assistive touch, If you can find Zephyr (not sure how its spelt) in Cydia it is really great though.

(29 Jun '13, 14:05) sandyv sandyv's gravatar image

Installed it yesterday, but I think my friend would have more trouble checking the phone's battery life because of a tethered jailbreak...

(29 Jun '13, 14:09) Fusion Fusion's gravatar image

Why would your friend have trouble checking battery life? A good app for that is Battery Doctor Pro, free in Cydia.

(29 Jun '13, 15:21) sandyv sandyv's gravatar image

the problem is your baseband (6.15) try downgrade first untill your baseband 5.13 then you can restore again to 6.1.3 official.


answered 29 Jun '13, 06:10

vbee3303124's gravatar image


Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 28 Jun '13, 20:12

Seen: 2,346 times

Last updated: 29 Jun '13, 15:21

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.