Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

20
4

About

SemiRestore is a new tool developed by CoolStar (me) to reset A5+ devices on iOS 5.0-6.1.2 to as far back to stock as possible while still retaining the jailbreak.

What this does do

  1. Uninstalls all Cydia packages
  2. Fixes host file issues
  3. Erases all user data
  4. Fixes permissions
  5. Fixes activation issues
  6. Fixes iMessage/Facetime issues
  7. Fixes Safe mode issues randomly appearing
  8. Reinstalls Cydia (in case it was deleted)

What this does not do

  1. Upgrade your iOS Version
  2. Downgrade your iOS Version
  3. Jailbreak your iOS Device
  4. Fix broken System Files

Requirements

Your device must be jailbroken on iOS 5.0-6.1.2. It may not be in DFU or Recovery mode. It must be booted into iOS. SpringBoard doesn't need to be visible for this to work. It just needs to be in iOS.

Known Issues

  1. Bug: Sometimes the USB version may crash when clicking the SemiRestore button.

    Fix: Verify the device is properly jailbroken and has AFC2 installed

  2. Issue: The USB version may get stuck at "Starting SemiRestore Service..."

Check: Verify the Untether is working properly, and that permissions are set properly. If you have SSH access, you can copy and paste this script to fix it:

    chmod +x /usr/libexec/BackupAgent
    rm /usr/libexec/SemiRestore-lockdown
    rm /usr/bin/semirestored
    rm /usr/bin/semirestorelogo
    rm /System/Library/LaunchDaemons/org.coolstar.semirestored.plist
    rm /System/Library/LaunchDaemons/org.coolstar.semirestorelogo.plist
    rm -rf /Library/SemiRestore
    if [[ -f /System/Library/Lockdown/Services-old.plist ]]; then
        rm /System/Library/Lockdown/Services.plist
        mv /System/Library/Lockdown/Services-old.plist /System/Library/Lockdown/Services.plist
    fi
  1. Bug: Sometimes the SemiRestore logo will appear glitchy and you may think SemiRestore is broken as depicted in this picture: https://twitter.com/coolstarorg/status/347055099501244417/photo/1

    What you should do: Ignore the splash screen. The splash screen is separate from the actual SemiRestore binary, and just make sure no errors are reported on the computer.

    What is the cause for this? On iOS 6 and higher, a new background service was introduced: "backboardd". If you're seeing this glitch, it's because a tweak being uninstalled caused a reboot. SemiRestore unloads backboardd usually to make sure the splash screen appears fine on the next reboot. If a tweak causes it, it's abrupt and SemiRestore can't fix it yet. CoolStar is looking into this and will fix it soon.

  2. Error: SemiRestore may error out saying that one of its files was corrupted and it can't open

    Solution: Make sure you're downloading SemiRestore from the official website here. This error is because CoolStar coded in checksums to make sure scams and other fakes can't tamper with SemiRestore's warning messages about paid scams. If you downloaded it from the official website and are having issues, check your internet connection and make sure it's reliable.

  3. Windows Version Error: SemiRestore may not be able to launch saying that "MSVCP100.dll" was not found.

    Solution: Download the Microsoft Visual C++ 2010 redistributable package from Microsoft.
    If you're on x86 (32-bit): http://www.microsoft.com/en-us/download/details.aspx?id=5555
    If you're on x64 (64-bit): http://www.microsoft.com/en-us/download/details.aspx?id=14632
    Visit this Microsoft Support page if you don't know which you have.

  4. Question: SemiRestore stops at "Stage 2" or "Performing Clean Up". What's up?

    This is because you had either a lot of Cydia tweaks installed, or a lot of data saved. Please be patient as SemiRestore is deleting them.

  5. Bug: The device may get stuck at the SemiRestore logo on bootup after a failed SemiRestore

    This has been fixed in 1.0.2

    Fix: Delete /usr/bin/semirestorelogo.

This question is marked "community wiki".

asked 22 Jun '13, 18:44

coolstarorg's gravatar image

coolstarorg
2.2k3513

closed 13 Aug '13, 15:47

spockers's gravatar image

spockers ♦♦
69.9k3911560

I don't know how to use openSSH I'm using windows.

(23 Jun '13, 01:00) donthackme donthackme's gravatar image
(23 Jun '13, 01:08) donthackme donthackme's gravatar image

Is this the same like Evasi0n?

(23 Jun '13, 01:24) donthackme donthackme's gravatar image
3

@nanananhat Read what it says. It clearly states it is NOT a Upgrade/Downgrade or Jailbreak package. So evasi0n? No.

(23 Jun '13, 01:34) mikewsw17 mikewsw17's gravatar image

@nanananhat Read the comment I left on your question. It'll explain what to do.

(23 Jun '13, 01:56) NmUn NmUn's gravatar image
1

I cant open it. Microsoft Visual C++ Runtime Library. pic.twitter.com/hoTWy36HWE

(23 Jun '13, 02:21) frankquad frankquad's gravatar image
1

Pretty sure telling coolstar about this in the IRC, twitter and here is overkill. He's probably looking into this right now. Or he may even be sleeping. Patience bro :)

(23 Jun '13, 02:27) NmUn NmUn's gravatar image

=O That's not I. >>>>>> OP of the twitpic =D

(23 Jun '13, 05:43) namidc namidc's gravatar image

I just tried Semi-Restore on an iphone 5 (6.0.2) and it told me it finished successfully but I'm kinda stuck with a phone that keeps rebooting. Any solutions? Or maybe people that have the same issue? Thanks.

(23 Jun '13, 17:25) Frox Frox's gravatar image

@Frox: delete /usr/bin/semirestored.

(23 Jun '13, 21:19) coolstarorg coolstarorg's gravatar image

I got the error "USB socked closed unexpectelly".Firstly i think that had something to do with the restrictions that I missed to disable but that wasnt the fault probably buecause I got the same message the second time I tried semirestore after I disabled restrictions..Semirestore continues to run (desptite GUI crush on windows)on my iphone but it definately not talking 5-10 minutes as people saying..I can see quickly that is deleted almost everything installed from cydia but two left Intelliscreenx and activator.

(23 Jun '13, 21:40) netjammer netjammer's gravatar image

@coolstarorg Thanks for your reply. It kinda goes from Apple logo to non-spinning wheel and reboots again. I never get to see the lock screen so I can't access the files to delete something.

(24 Jun '13, 05:30) Frox Frox's gravatar image

@Frox: Use iFunbox

(24 Jun '13, 05:59) coolstarorg coolstarorg's gravatar image

@coolstarorg I actually tried it with iFunbox after your first reply but for some reason it doesn't seem to see the raw file system or the phone being connected. It is either in the continues loop of rebooting or I can put it into DFU mode but getting to access it with iFunbox while in DFU is not possible.

(24 Jun '13, 08:22) Frox Frox's gravatar image
1

@coolstarorg the semi-restore did not work very well. cydia apps still there but not in my home secreen. Also, all my apps are disappeared, so what should I do? Ooh and I don't have access to SSH.

(24 Jun '13, 09:39) yawa1992 yawa1992's gravatar image

i semirestored ipad 3 ios 6.1.2 and get USB socked closed unexpectelly error. now after restart i see semirestore logo and nothing else

(24 Jun '13, 11:07) abulhallaj abulhallaj's gravatar image

delete /usr/bin/semirestorelogo in iFunbox.

(24 Jun '13, 11:14) coolstarorg coolstarorg's gravatar image

@yawa1992 just rerun SemiRestore and it'll fix it. Also, if the apps disappeared, that's what supposed to happen as SemiRestore's job is to delete them.

(24 Jun '13, 12:34) coolstarorg coolstarorg's gravatar image

@coolstarorg I already did it, but look what happened when I rerun SemiRestore. http://s23.postimg.org/i03d999h7/image.jpg And the apps I don't mean the Cyrus apps the apps that I download from Appstore.

(24 Jun '13, 13:56) yawa1992 yawa1992's gravatar image

@yawa1992 Semi-Restore is almost exactly like, if not exactly like , the Reset all button (A Working one) for Jailbroken iDevices. So your Apple apps, your Cydia tweaks and apps, and all photos, videos, contacts,etc are wiped from the phone.

(24 Jun '13, 14:31) BlackJack09 BlackJack09's gravatar image

@coolstarorg @BlackJack09 so how about the picture and the problem that comes up when I rerun SemiRestore?

(24 Jun '13, 15:59) yawa1992 yawa1992's gravatar image
1

Argh someone help me please! This is so annoying! Keep getting the Microsoft Visual C++ 'Assertion Failed' error, see screenshot below. Any help would be most appreciated.

alt text

(24 Jun '13, 16:28) V3-571G V3-571G's gravatar image

if you have SSH access, run the script I posted above. Or if you have iFile, go to /usr/libexec, tap on the blue arrow next to "SemiRestore-lockdown", scroll down to access permissions, and set it to "Read, Write, Execute" for Owner, and "Read, Execute" for all group and world

(24 Jun '13, 16:58) coolstarorg coolstarorg's gravatar image

Still not working unfortunately, i keep getting the Microsoft Visual C++ error during the 'Starting SemiRestore service' stage. Read, write and execute were already selected on 'User', Read and execute were already selected on 'Group', Read and execute were already selected on 'World'. I'm using a iPhone 4 on iOS 6.0.1 with the Evasion jailbreak. Please help!

(24 Jun '13, 17:13) V3-571G V3-571G's gravatar image

@yawa1992 run the script I posted above over SSH and it'll fix that issue.

(24 Jun '13, 17:23) coolstarorg coolstarorg's gravatar image

@coolstarorg I couldn't run SSH from iFunBox because SemiRestore delete OpenSSH and when I tried to install it again it does not show up inside the settings.

(24 Jun '13, 18:24) yawa1992 yawa1992's gravatar image

reboot your device and try again.

(24 Jun '13, 18:24) coolstarorg coolstarorg's gravatar image

Ipad 2 with 6.12, jailbroken, but can't activate my ipad after semirestore. Have reboot both my windows and ipad many times. Can Help?

(25 Jun '13, 02:16) hpyman88 hpyman88's gravatar image

what's the error when you try activating it? Also, is the iPad wifi-only or does it support 3G?

(25 Jun '13, 02:17) coolstarorg coolstarorg's gravatar image

wifi-only, 3G not supported. On ipad it shows "Your ipad could not be activated because the activation server is temporary unavailable. Try to connecting your ipad to itunes to activateit, or try again in a couple of minutes". Have try itunes, connected but shows "We are sorry,we are unable to continue with your activation at this time"

(25 Jun '13, 02:24) hpyman88 hpyman88's gravatar image

Sorry checked. It's 3G model

(25 Jun '13, 02:31) hpyman88 hpyman88's gravatar image

sounds like an issue at apple's end. If you want, you could try re-running SemiRestore.

(25 Jun '13, 02:31) coolstarorg coolstarorg's gravatar image
1

I have try re-running, but failed to run, 1st time running is good. Using windows 7, using compatible XP sp3 mode to run, its fine at first time

(25 Jun '13, 02:36) hpyman88 hpyman88's gravatar image
1

When semirestore says it's complete, my iPhone 4S restart but stay stuck with the Apple icone and the loading bar at about 75% and stays like this indefinitly !! I tried to reboot many times but still blocked !!

Please help

(25 Jun '13, 12:01) lapo75 lapo75's gravatar image

rerun SemiRestore

(25 Jun '13, 16:54) coolstarorg coolstarorg's gravatar image

I CAN t it s NOT booting at all, it stays in the loading stage since 6 hours now... Each Time i reboot it stays at this stage. I CAN put is in dfu et restore mode but nothing CAN mke it boot normaly exept restore it with iTunes but i Will loose my jb.

(25 Jun '13, 18:17) lapo75 lapo75's gravatar image

I have the same problem "Your ipad could not be activated because the activation server is temporary unavailable", stuck at could not activate iPad screen. I try many ways like power off and on my ipad, off my router and disconnect the cable, then connect back. and I have try to re-run the semi-restore, and this time I got error "Microsoft C++ runtime library, assertion failed?", I try running semi-restore and the same error happen. I try to re-install the Microsoft C++ runtime, and the error still happen. Why I run semi-restore successful in the first time? The successful message on the semi-restore and the close button appear. After I press the close button and go to iPad, First it ask for language, wifi setting, then when come to the screen activating your iPad, it failed!!! WHEN I try to re-run the semi-restore again, the assertion failed error come out..... I run iTools and check the status of my iPad2 , it show that my iPad2 is not activated and is not jailbreak... This semi-restore supposed to keep my jailbreak intact, how come my jailbreak gone? I try to use evasi0n 1.53 to do unthether, the error message said that the iPad2 need to be activated first before running the untether jailbreak. How can I get my iPad2 back to IOS 6.1.2 Untethered jailbreak? Please Help???? my iPad2 is Wifi+3G GSM model.

(26 Jun '13, 03:37) luckyse7en luckyse7en's gravatar image

Hi guys I ran semi-restored on my ip5 w/6.1 installed and it cleaned up the device but when i open my settings I have a bunch of blank icons where my app store app setting used to be. How do I get rid of the blank icons?

(26 Jun '13, 16:02) gmane gmane's gravatar image

When ever i connect my iPod 4 and try to restore it always stops responding at the first step.

(28 Jun '13, 09:36) ANIR0X2K00L ANIR0X2K00L's gravatar image

This happens with the windows version. Right-click Semi-Restore.exe and select properties. Open the compatibility tab and turn on compatibility mode and set it to XP SP3. Tick the box for running it as admin and apply. It should run fine now. I have to do this on my windows 7 computer to get it to run.

(28 Jun '13, 15:18) NmUn NmUn's gravatar image

I have semi-restored my iPod Touch 4 (6.1). Some cydia apps are still instaled, but some of them dont work (i.e. Safari Download enabler). I reinstalled them, removed and install other apps, however, they still dont work.

(28 Jun '13, 18:35) meguelcrez meguelcrez's gravatar image

rerun SemiRestore.

(02 Jul '13, 22:45) coolstarorg coolstarorg's gravatar image

uninstall Mobile Substrate and then re-install it.

(02 Jul '13, 22:46) coolstarorg coolstarorg's gravatar image

Hi coolstar, thanks for the program :) I used semirestore and it seemed to work okay, it removed all the apps and most of the data but it didn't seem to go entirely smoothly and some data was not deleted. I tried running semirestore again because that seems to be your suggestion for a lot of problems on here but every time I get the error: Assertion Failed. Program: ... File: DeviceManager.cpp Line: 351 Expression: afc_file_ref_open(connection, path, 1, &fileRef) == 0 ... I think I need to run semirestore again to finish things but I get that error every time. Any help would be greatly appreciated

(05 Jul '13, 21:37) SparkySnarky SparkySnarky's gravatar image

Meant to add that it does this at the 'creating backup' stage not the 'starting semi restore service...' stage. Also if it matters at all I'm on iPhone 4S ios 6.1.2

(06 Jul '13, 05:23) SparkySnarky SparkySnarky's gravatar image

I have an iPhone 5 (6.1.2) that has finished the Semi-restore process -- but is stuck on the apple boot screen with 3/4 of the progress bar complete.

Any advice on what to do?

(07 Jul '13, 17:17) able16 able16's gravatar image

Something I haven't seen mentioned yet... After running Semi-Restore (version and system info below), Mobile Substrate reports to Cydia that it is installed, and passes dependency checks. However, it needed to be re-installed (I did it within Cydia - re-install). It took me a few to figure out why some things were not functioning once installed after the Semi-Restore. Once I reinstalled Mobile Substrate, all packages appear to function properly.

An issue that I am still having is that restoring my device from a backup does not seem to restore any of the content to my device. I tried with 2 backups. This may be related to the fact that all my apps are still being reported as being installed, in iTunes and in any area of the iDevice that reads the user app store.

I would love to provide you with a log, but either I manually deleted it (i don't think i did, but maybe..) or the iTunes Restore From Backup removed it. Either way, it's gone. I am going to re-run Semi-Restore now and will let you know if any of these problems reoccur.


Semi-Restore v1.0.3 for Windows on Windows 8 Pro x64

iPod Touch 5th Gen 32gb w/ iOS 6.1 - jailbroken with initial release of evasi0n for windows

(17 Jul '13, 23:46) technotic technotic's gravatar image

I have an iPhone 5 (6.0.1) sunned Semi-restore process many times (about 12) and every time it stucks on the apple boot screen with 80% of the progress bar complete on funbox the iphone is empty and nothing to do((( what i should do now?

(13 Aug '13, 11:23) mark_sh2004 mark_sh2004's gravatar image

@coolstarorg I am an experienced *nix user and would like to manually perform all the steps over ssh within a screen terminal. Could you post all the commands with arguments semi-restore is doing on the device (rm, ln, apt-get/dpkg, sync, reboot)? Thanks.

(17 Aug '13, 13:39) gigel gigel's gravatar image

whatever happened to the mac version of semi-restore?!

(15 Oct '13, 16:41) RTouris RTouris's gravatar image

The question has been closed for being "to assist in locating the "add a comment" button" by spockers, 13 Aug '13, 15:47

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,266
×77
×14
×6

Asked: 22 Jun '13, 18:44

Seen: 61,683 times

Last updated: 15 Oct '13, 16:41

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.